NTFS newbie question

Hi all.
I modified the default fstab lines created by the default SUSE installation putting dmask and fmask = 002, and this way a gained rw access to my ntfs partitions.

Then I discovered that no executables could not be run, either by the user or the root: from the terminal I received a permission issue. The same executables, copied in my home dir, could be run with no problems.
So, I modified the line again putting the default and exec options, unmounted all, mounted all and nothing changed. I actually did not try to reboot, but formerly unmounting and remounting worked for me.

What am I missing?!? Sorry I don’t have my fstab file here, I can post it this evening if needed.


This is an example of a line for ntfs in fstab

/dev/sda2 /path_to/mount_point ntfs-3g defaults 0 0

Without any masks: I have not tried actually. Thanks.

But if it works, why should the masking I put (002) block the execution of files??
I’ll try, thanks.

Nothing to do.

This is my fstab:

/dev/disk/by-id/ata-WDC_WD1600BEVT-35ZCT1_WD-WXCX08137352-part5 swap                 swap       defaults              0 0
/dev/disk/by-id/ata-WDC_WD1600BEVT-35ZCT1_WD-WXCX08137352-part6 /                    ext3       defaults              1 1
/dev/disk/by-id/ata-WDC_WD1600BEVT-35ZCT1_WD-WXCX08137352-part7 /home                ext3       acl,user_xattr        1 2

#/dev/disk/by-id/ata-WDC_WD1600BEVT-35ZCT1_WD-WXCX08137352-part2 /windows/C           ntfs-3g    #auto,default,exec,users,gid=users,fmask=002,dmask=002,locale=en_US.UTF-8 0 0
#/dev/disk/by-id/ata-WDC_WD1600BEVT-35ZCT1_WD-WXCX08137352-part3 /windows/D           ntfs-3g    #auto,default,exec,users,gid=users,fmask=002,dmask=002,locale=en_US.UTF-8 0 0

/dev/disk/by-id/ata-WDC_WD1600BEVT-35ZCT1_WD-WXCX08137352-part2 /windows/C           ntfs-3g    auto,default,exec,user,users,umask=0,locale=en_US.UTF-8 0 0
/dev/disk/by-id/ata-WDC_WD1600BEVT-35ZCT1_WD-WXCX08137352-part3 /windows/D           ntfs-3g    auto,default,exec,user,users,umask=0,locale=en_US.UTF-8 0 0

proc                 /proc                proc       defaults              0 0
sysfs                /sys                 sysfs      noauto                0 0
debugfs              /sys/kernel/debug    debugfs    noauto                0 0
devpts               /dev/pts             devpts     mode=0620,gid=5       0 0

I put the former lines under comment, and introduced the new ones with umask=0. Read and write access as before, but I cannot execute programs, either after “chmod-ding” them to be even more sure of their asccessibility in execution.

I can’t get my head around all those options so to make it simple:

If you do like this:

/dev/disk/etc_etc-part3 /windows/D  ntfs-3g    defaults 0 0

Then they will be owned by root:root and drwxrwxrwx, so they should be executable by you as a member of “others”.

If you do like this:

/dev/disk/etc_etc-part3 /windows/D  ntfs-3g    uid=1000,gid=100,umask=0022 0 0

Then they will be owned by 1000:users and drwxr-xr-x, so they should be executable by user 1000 as the owner. Presumably you are uid 1000. Check your uid in Yast → security and users → User and Group management.

REF: HowTo Mount NTFS Filesystem Partition Read Write Access in openSUSE 10, 11

Did you try

/dev/disk/by-id/ata-WDC_WD1600BEVT-35ZCT1_WD-WXCX08137352-part2 /windows/C           ntfs-3g    defaults    0 0
/dev/disk/by-id/ata-WDC_WD1600BEVT-35ZCT1_WD-WXCX08137352-part3 /windows/D           ntfs-3g    defaults    0 0

@caf4926 Too slooooooooooooowwwwww

Ok, the simple option “defaults 0 0” works fine. It would be very interesting to understand what in the former string blocked the execution…

Anyway, this is enough for me now. I plan to refine some protection (and let you know the results), but for now I stop here.

Thanks a lot to all of you!!

Well done. Thanks for letting us know.:wink:

Just a few comments that might clarify what happened, or at least indicate why it didn’t work for you:
Options: “default” is not a valid option and AFAIK neither are “auto”, “exec”, “user” or “users”. I see these sprinkled around in forums, but I don’t think they do anything because ntfs-3g is not a normal mount command.

Regarding chmod: doesn’t work on ntfs-3g filesystems.

So you can’t be sure exactly what might happen with the recipe you had. :slight_smile:

Thanks, that’s something I did not know.

:open_mouth: Oups…

Right. So for my experiments I shall move backwards: from the working recipe you provided up introducing restrictions until I get the problem again.

Thanks a lot!!