ntfs-3g problem with DosBox

Hi Lizards,

I (think) I have a read only ntfs-3g read only mounting problem.

If I start up DosBox every thing seems right, yet when I fire up the game Blake Stone, I am unable to load any saved mission.

I’m also running DosBox on Ubuntu and Windows 10, without any problems.

Here is the Tumbleweed /etc/fstab

UUID=1bc3cb7d-d0a0-442a-b70b-ff4460d0dec5 / ext4 acl,user_xattr 1 1
UUID=BA74C04174BFFE5F /Windows ntfs-3g user,users,gid=users,fmask=133,dmask=022,locale=nl_NL.UTF-8 0 0
UUID=68ACE1214B6B5A6D /dos ntfs-3g user,users,gid=users,fmask=133,dmask=022,locale=nl_NL.UTF-8 0 0

Edit, the sftab was automatically generated by Yast2.

Hissyfissy know it all me, I thought I was able to fix the problem by replacing the last line by copying an pasting the line from my Ubuntu /etc/fstab (using Kate as root)

UUID=68ACE1214B6B5A6D /dos ntfs-3g defaults,umask=007,gid=46 0 0

Unfortunately that didn’t work. When I start DosBox, it now gets stuck into a loop mounting the (virtual) C:\ drive.

Edit, the mounted partition is a 1.70 GB NTFS partition on which all my DOS, Amiga, MSX, music and videos are stored, so I can access them from all my Operating Systems.

Any ideas how to fix this?


Sounds like permission problems

Hard to know what to fix, because I don’t know enough about your system.

If you have Windows installed, then the first step should be to boot Windows. And then, from windows, run a “CHKDSK /F” on that Windows drive.

If you are using a recent Windows (Win 8 or later), then it may be set for fast boot. With fast-boot, it does not cleanly shutdown file systems. It “hibernates” them. That leaves them looking corrupt to other operating systems, so linux will mount read-only. That’s possibly what is happening.

To make matters worse, Windows cheats on this. I turned off fast-boot, but still could not mount my Windows drive in linux. I had to turn off hibernation (in Windows) before I could get a clean shutdown of that file system. So if turning off fast-boot doesn’t solve the problem, try turning off hibernation in Windows.


Thanks for your reply, nothing to do with Windows, since it works fine on Ubuntu, running DosBox.

It’s a seperate ntfs partion, without Windows installed on it.

The partition only includes DOS, Amiga, MSX software (for emulators), music and videos. The only OS installed on that physical drive is Tumbleweed.


Marti van Lin (alias ML2MST)

Thanks for confirming, that was my idea as well.

I’ll experiment a bit more (remove the user entries) and will report back if I’m able to fix it.


Hi all,

Finally found the solution.

Changed the line in /etc/fstab to:

UUID=68ACE1214B6B5A6D /dos                 ntfs-3g    defaults     0 0

That fixed it.