NT 4 redirector time out error 3013 attempting to connect to a samba share

This is only occuring on a single computer hosting an old but necessary application and I am not finding any ideas anywhere.
A script attempts to map a samba share hosted on a Suse server. The net use commands returns “System error 240 has occured. The session was cancelled.” AN event ID 3013 “The redirector has timed out a request to”. This occurs every time and has apprantly for the last three weeks.
All other computers connect regardless of OS level.
Can anyone give me any ideas to try? Any assistance will be greatly appreciated.

You mentioned ‘net use’ so I assume your broken client is windows. Since
the SUSE server running Samba can be accessed by “[all] other computers…
regardless of OS level” it seems like your client is the problem, doesn’t
it? If not why can all other systems connect?

A few ways to fix windows:

  1. Replace it with Linux (I’d do this one).
  2. Turn off its firewall for testing if your environment is completely
    secure (not possible, but you can try) and then beware of the viruses
    you’re going to catch from the network while doing this.
  3. See if the Linux server’s Samba logs can help you identify why things
    fail with this particular windows client.
  4. Compare this broken client to other working clients.

Good luck.

On 02/19/2013 03:36 PM, msillers wrote:
> on a Suse server.

i guess that “Suse server” is running SUSE Linux Enterprise Sever

if so, these are the openSUSE forums and very folks here qualified
or experienced enough to help you with that system…

suggest you ask again in the SLES forums, here: http://forums.suse.com/

the Pass/ID used here works there also…

note: you are welcome to check back here to see if you get lucky!

openSUSE®, the “German Engineered Automobile” of operating systems!

The problem sounds like something very fundamental, not because something happened after a network connection has been established.

  1. Do normal network troubleshooting. Is the specified IP address correct? Have you tried PING? Have you tried connecting to any other Share(I typically create another share for testing on the same machine)?

2.What other events/problems are being reported in your NT4 box? I would be surprised if a machine that old is still running with clean reports. If your log goes back 3 weeks, then it may be particularly important to analyze what may have happened at that time.

  1. Have you tried mapping a drive? You can implement during bootup or manually afterwards.

  2. Be aware that the SMB protocol has undergone many changes and may be more of an issue for machines of different vintage, not just different OS.