nspluginwrapper for firefox 3, 64bit -- no flash

I’ve read through the other threads of folks running openSuSE-11.0 with 64bit firefox3, and resolving flash issues with nspluginwrapper.

I re-installed the flash-plugin from macromedia and the two nspluginwrapper rpms from nspluginwrapper [Web > Gwenole Beauchesne]


and whereas previously a box would appear empty where flash content was to be found, I now receive messages like, Hello, you either have JavaScript turned off or an old version of Adobe’s Flash Player. Get the latest Flash player.

I tried the suggestion here to use the NoScript plugin to allow scripts from sites I choose, but the flash player is still undetected. Any ideas?

I am assuming you have downloaded the flash player rpm from the Adobe website. If so please try this:
1.open a terminal and login as root (this is for system-wide installation, if you want to install for your account only then this is not necessary).
2.Enter the following command
nspluginwrapper -i /usr/lib/flash-plugin/libflashplayer.so

However flash player is supposed to work on firefox3 for a default 64 bit installation from the openSUSE 11.0 dvd (as far as I know both nspluginwrapper and flash player are installed by default and there is nothing more to do). Therefore you could also try uninstalling the nspluginwrapper and flash player packages using yast and reinstalling them from the dvd. In that case the above command from the terminal will not be necessary.
Hope that helps.

Yes, I downloaded the flash player rpm from the Adobe website.
As root, I entered,

nspluginwrapper -i /usr/lib/flash-plugin/libflashplayer.so

and received,

nspluginwrapper -i /usr/lib/flash-plugin/libflashplayer.so
/usr/lib/nspluginwrapper/i386/linux/npviewer.bin: error while loading shared libraries: libgobject-2.0.so.0: wrong ELF class: ELFCLASS64
nspluginwrapper: no appropriate viewer found for /usr/lib/flash-plugin/libflashplayer.so

Is this error telling at all?

I also believe both nspluginwrapper and flash player were installed by default on the openSuSE-11.0 dvd. I tried uninstalling them with Yast and then reinstalling them, but this did nothing.

Any other ideas?

Thread moved to Multimedia

Some other suggestions I tried to implement:

from here

rpm -qa | grep flash

I removed flash-plugin and libflashsupport

From this thread in general
I installed Mplayer and mplayerplug-in
removed pulseaudio
installed w32codec-all

When visiting a site with flash I still receive the message, “Hello, you either have JavaScript turned off or an old version of Adobe’s Flash Player. Get the latest Flash player.” Is it indeed enabled in my browser though.

Before I tried to “fix” any of the missing video, there would at least be a gray rectangular area, no sound or image.

I’m running opensuse x86_64 11.0 installed from just the cd though. I used zypper to install nspluginwrapper and then ran

nspluginwrapper -i /usr/lib/flash-plugin/libflashplayer.so
and now flash is working!!

I could have lived without it but it is annoying to get those blank screen at some sites. I like zypper better than yast I must admit but not really sure why it worked for me. I’m grateful for the info in this thread though and Yay opensuse!

I’m glad other folks are getting it working.
I tried removing flash-player again, re-installing, and running

nspluginwrapper -i /usr/lib/flash-plugin/libflashplayer.so

This time I get a different error message:

nspluginwrapper: /usr/lib/browser-plugins/libflashplayer.so is not a valid NPAPI plugin

Perhaps I’m approaching the truth of flash.
But I’m not quite sure what else to try, or where to go from here. Any ideas or directions to look into?

I get this same error, does anyone no a fix?

doroshjt, have you found a solution?

I’ve tried uninstalling firefox, flash-player and nspluginwrapper, reinstalling and trying:

nspluginwrapper -i /usr/lib/firefox/plugins/libflash
nspluginwrapper: /usr/lib/firefox/plugins/libflashplayer.so is not a valid NPAPI


nspluginwrapper -i /usr/lib/browser-plugins/libflash
nspluginwrapper: no appropriate viewer found for /usr/lib/browser-plugins/libfla

as I’ve seen these two varieties floating around. Any idea what these errors indicate? how to overcome them?


gives me

DivX Browser Plug-In
    File name: mplayerplug-in-dvx.so
    mplayerplug-in 3.55

Google VLC multimedia plugin 1.0
    File name: mplayerplug-in-gmp.so
    mplayerplug-in 3.55

QuickTime Plug-in 7.4.5
    File name: mplayerplug-in-qt.so
    mplayerplug-in 3.55

RealPlayer 9
    File name: mplayerplug-in-rm.so
    mplayerplug-in 3.55

Windows Media Player Plug-in
    File name: mplayerplug-in-wmp.so
    mplayerplug-in 3.55

mplayerplug-in 3.55
    File name: mplayerplug-in.so
    mplayerplug-in 3.55

NPAPI Plugins Wrapper (20071225)

iTunes Application Detector
    File name: librhythmbox-itms-detection-plugin.so

OpenSC Signer plugin
    File name: opensc-signer.so

mplayer is the only one enabled to view flv.


rpm -q flash-player

I still have the same problem, and receive the message, “Hello, you either have JavaScript turned off or an old version of Adobe’s Flash Player. Get the latest Flash player.”

anyone have any suggestions or have this same problem?

I only use nspluginwrapper and flash-plugin from official openSUSE repositories and I never had to type any command in console. Flash works here in Firefox just like that, without any CLI magic. Try to remove Flash from Adobe and nspluginwrapper from nspluginwrapper site and install packages from official openSUSE repositories.

Thanks for the suggestion.
both the nspluginwrapper and flash-player I have installed are from the Main Repositories however (the first from the OSS one, the second from the Non-OSS).

Nope, I always give up looking, the come back every few weeks and hope someone posts something that I haven’t tried. Nothing yet for me though. Its pretty annoying the amount of sites that use flash for trival things like freakin navigation menus. Ugggg

I’m having the same issues.

Tried all the methods suggested in this thread, but nothing works.

  1. installed nspluginwrapper & flash from official repos

  2. ran this command as root

madgenius@linux-6tqh:/usr/lib/browser-plugins> sudo nspluginwrapper -i /usr/lib/browser-plugins/libflashplayer.so
which: no linux32 in (/usr/sbin:/bin:/usr/bin:/sbin)
*** NSPlugin Viewer *** preloader not found
nspluginwrapper: no appropriate viewer found for /usr/lib/browser-plugins/libflashplayer.so

Any ideas?

try entering

valid NPAPI plugin
as a Google search: you are not alone: see entries from Ubuntu; mandrake; debian … why not research and tell us if you learn from these other entries …

I only receive the “not a valid NPAPI plugin” when I applied a code for a folder which didn’t exist (i.e. libflashplayer in /usr/lib/firefox/plugins/)

Otherwise, adding a -v to previously mentioned commands,

sudo nspluginwrapper -v -i /usr/lib/browser-plugins/libflashplayer.so


nspluginwrapper -v -a -i

produces the error

/usr/lib/nspluginwrapper/i386/linux/npviewer.bin: error while loading shared libraries: 
libgobject-2.0.so.0: wrong ELF class: ELFCLASS64

Googling for this ELF error, I saw in this ubuntu page, the method of:

:/usr/lib/nspluginwrapper/i386/linux$ ldd npviewer.bin

for me this produced alternating sequences of:

libglitz.so.1 => /usr/lib/libglitz.so.1 (0xf7533000)
        libpng12.so.0 => /usr/lib/libpng12.so.0 (0xf750c000)
        libxcb-render-util.so.0 => /usr/lib/libxcb-render-util.so.0 (0xf7507000)
        libxcb-render.so.0 => /usr/lib/libxcb-render.so.0 (0xf74ff000)
        libexpat.so.1 => /lib/libexpat.so.1 (0xf74d8000)
        libXau.so.6 => /usr/lib/libXau.so.6 (0xf74d3000)
        **libgobject-2.0.so.0 => not found
        libgmodule-2.0.so.0 => not found
        libglib-2.0.so.0 => not found**

Looking in YaST I see that I have the following installed:

Four of these I updated.
If you are unfamiliar with ldd, as I was, the man page defines it:
ldd prints the shared libraries required by each program or shared library specified on the command line

Which ways can a file not be found if it is installed? In another ubuntu post there was a suggestion for a symbolic link somewhere along the lines, though not directly addressing this problem

sudo ln -s /usr/lib/browser-plugins/nspluginwrapper/x86_64/linux/npconfig /usr/bin/nspluginwrapper

That is maybe unrelated. Another poster commented that it was unnecessary because the rpm would create all the necessary symbolic links.
Do I need to create a link to, for instance, /usr/lib/libgmodule-2.0.so somewhere? or include /usr/lib in $PATH?

Thanks for your suggestions.

I’ve had the same problems, but managed to fix things now. I followed the instructions given here, and it worked for me. Here’s what I did exactly - see if it works for you.

  1. Removed flash, real-player and firefox (and any files associated with them) using Yast. Also deleted the local firefox profile (in /home/user/.mozilla directory)

  2. Disabled all repositories in Yast except for the official SUSE repositories

  3. Via the command line, installed firefox, flash and real player using zypper.

  4. Download the nspluginwrapper and viewer from the official site.

  5. Installed the rpms from the command line using the rpm -ivh command. At this stage, it said that a dependency “linux32” was absent. This package was not being installed when I had used Yast to install nspluginwrapper.

  6. Installed linux32 using zypper, then the nspluginwrapper packages using rpm -ivh command.

  7. Followed the other instructions as mentioned in the guide.

  8. Flash and real media streams work perfectly in firefox now.

Thank you for sharing detailed, step-by-step instructions; glad to hear it worked for you.

I followed your directions exactly several times and still receive the same error as before, unfortunately:

/usr/lib/nspluginwrapper/i386/linux/npviewer.bin: error while loading shared lib
raries: libgobject-2.0.so.0: wrong ELF class: ELFCLASS64
nspluginwrapper: no appropriate viewer found for /usr/lib/browser-plugins/libfla

in addition, this remains unchanged:

libgobject-2.0.so.0 => not found
libgmodule-2.0.so.0 => not found
libglib-2.0.so.0 => not found

though I do have them all installed.

The default installation seems to have installed the x86_64 and 32 bit packages of the above files. I don’t remember installing them - think it was there by default.

I do hope that you can figure out what’s happening and get things to work. Best of luck.

I guess the trick is to install the linux32 package and then run

 $ nspluginwrapper -i /usr/lib/browser-plugins/libflashplayer.so

After that, and without removing and reinstalling anything before, flash works for me and the plugin is correctly listed in the about:plugins page.