Novice, dont understand error

I want to install a .rpm package, and when i install it it says: an internal system error has occured ;and when i press more details it says: repo exeption:(

Hi Rimwe,

What are you trying to install and how (using Software Management, downloaded rpm, etc)?
Also what version of openSUSE are you running?

Running a v11.0 just installed, im trying open a .rpm package that i downloaded with firefox in pakage installer(Default for me)

Did you download it to a NTFS partition by any chance?
Try copying it over to your desktop and retry install.

Same error?

It’s in the Linux home partition, and i tried the desktop, it doesn’t work… :frowning:

Could be it’s an rpm designed for use on another system (e.g. redhat).

Maybe installing through the console will give you more hints;
open a terminal, cd to the directory with the rpm and enter ’ rpm -ivh <name of rpm>.rpm (you need to be root).

…repo exeption

Sounds like, the place that you downloaded firefox to is not seen as a ‘repository’ by YaST.

In YaST you can add a local reopo… say /home/~/Downloads/ in that case you can select the .rpm files from that location and install it via YaST.
The advantage is that YaST should solve your dependencies.

But personally I’d download firefox to its own folder say /home/~/Downloads/firefox for example and run it from there. Just add libflashplayer.so to the folder ~/plugins and it all should work !

Try to install it throught terminal ->

1./ su
2./ enter root password
3./ zypper in *.rpm (or enter full package name)

Now you should see entire process with potential errors…

Thnx, I’ll try it.:slight_smile:

I’m a noob too. So far I have been installing software by going to the opensuse software repositories. Doing that and letting yast do the rest works well for me. At some point I want to learn how to install from a tarball.

twich

I’m curious, what is the name of the file you’re trying to install? A lot of programs can be installed through yast software manager - just open up yast > software and select the software manager from there (if you’re using kde, you can access the software manager by going to the kmenu > computer > install software). Once in the software manager, you can search for the name of the application, tick the check box, hit apply and it will install.

If the program is not found in yast, you can search for it at the opensuse build service Software.openSUSE.org and use the one click install to install it. Downloading rpms is so not necessary.