nouveau will not load (no KMS)

This box ran fine under 12.3. I have just done a completely fresh install of 13.1 and now can’t get the nouveau driver to load.

from uname -a

Linux MAGYAR2 3.11.10-29-default #1 SMP Thu Mar 5 16:24:00 UTC 2015 (338c513) i686 athlon i386 GNU/Linux

from lspci -vv

01:00.0 VGA compatible controller: NVIDIA Corporation NV34 [GeForce FX 5200] (rev a1) (prog-if 00 [VGA 
        Subsystem: CardExpert Technology Device 0419
        Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- Di
        Status: Cap+ 66MHz+ UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR
- INTx-
        Latency: 32 (1250ns min, 250ns max)
        Interrupt: pin A routed to IRQ 5
        Region 0: Memory at e8000000 (32-bit, non-prefetchable) [size=16]
        Region 1: Memory at e0000000 (32-bit, prefetchable) [size=128]
        [virtual] Expansion ROM at e9000000 [disabled] [size=128]
        Capabilities: [60] Power Management version 2
                Flags: PMEClk- DSI- D1- D2- AuxCurrent=0mA PME(D0-,D1-,D2-,D3hot-,D3cold-)
                Status: D0 NoSoftRst- PME-Enable- DSel=0 DScale=0 PME-
        Capabilities: [44] AGP version 3.0
                Status: RQ=32 Iso- ArqSz=0 Cal=3 SBA+ ITACoh- GART64- HTrans- 64bit- FW+ AGP3+ Rate=x4,
                Command: RQ=1 ArqSz=0 Cal=0 SBA- AGP- GART64- 64bit- FW- Rate=<none>
        Kernel modules: nvidiafb, nouveau

Notice there is no “kernel driver in use” there.

This from the /var/log/Xorg…

[34.433] (EE) [drm] KMS not enabled
[34.433] (EE) [drm] KMS not enabled

The system is booted with Kernel command line: BOOT_IMAGE=/vmlinuz-3.11.10-29-default root=UUID=d2cfdfea-64f6-4425-bd29-0fc83bece28d apm=off acpi=off mce=off barrier=off ide=nodma idewait=50 i8042.nomux psmouse.proto=bare irqpoll pci=nommconf resume=/dev/disk/by-id/ata-ST340015A_5LA1X3X6-part2 showopts vga=0x31a

I inserted the vga= in order to get any kind of useable desktop.

None of lsmod, /proc/devices or /proc/fb show nouveau and when i try modprobe nouveau I get

modprobe nouveau
WARNING: Error inserting wmi (/lib/modules/3.11.10-29-default/kernel/drivers/platform/x86/wmi.ko): No such device
WARNING: Error inserting hwmon (/lib/modules/3.11.10-29-default/kernel/drivers/hwmon/hwmon.ko): No such device
WARNING: Error inserting thermal_sys (/lib/modules/3.11.10-29-default/kernel/drivers/thermal/thermal_sys.ko): No such device
WARNING: Error inserting video (/lib/modules/3.11.10-29-default/kernel/drivers/acpi/video.ko): No such device
WARNING: Error inserting mxm_wmi (/lib/modules/3.11.10-29-default/kernel/drivers/platform/x86/mxm-wmi.ko): No such device
WARNING: Error inserting i2c_core (/lib/modules/3.11.10-29-default/kernel/drivers/i2c/i2c-core.ko): No such device
WARNING: Error inserting i2c_algo_bit (/lib/modules/3.11.10-29-default/kernel/drivers/i2c/algos/i2c-algo-bit.ko): No such device
WARNING: Error inserting drm (/lib/modules/3.11.10-29-default/kernel/drivers/gpu/drm/drm.ko): No such device
WARNING: Error inserting drm_kms_helper (/lib/modules/3.11.10-29-default/kernel/drivers/gpu/drm/drm_kms_helper.ko): No such device
WARNING: Error inserting ttm (/lib/modules/3.11.10-29-default/kernel/drivers/gpu/drm/ttm/ttm.ko): No such device
FATAL: Error inserting nouveau (/lib/modules/3.11.10-29-default/kernel/drivers/gpu/drm/nouveau/nouveau.ko): No such device

Which I find very confusing since the card is in place, seen by the bios and lspci.

/proc/config.gz shows this for KMS


I have tried all combinations of acpi and noapic along with modeset=1, nouveau.modeset=1 but no change. I also swapped the card for a different nvidia card but got same results. I have even booted with the kernel 3.11.6-4 but that didn’t change anything.

There is no proprietary nvidia stuff present.

Any ideas? Cheers and TIA[/size][/size][/size]

Those options probably prevent nouveau from working correctly.
They (in particular apm=off and acpi=off) definitely are responsible for at least some of the warnings/errors you got when trying to load nouveau.

Try to remove all of them (except resume= and showopts) in YaST->System->Boot Loader.
(you can keep vga=0x31a, but it won’t have any effect with nouveau anyway)

If your system should not boot then for some reason, choose “Recovery Mode” under “Advanced Options”, that one should still work.

Well sell my clothes, I’m going to heaven!

I did not add the apm and acpi options in that boot line. That is, the ones at the beginning of the line and I didn’t notice them before now.

I installed from the NET install CD and it didn’t appear to want to load so I said do it with “safe options”. I wonder if those options were then carried over to the eventual live boot line.

I have done as you advised and all is OK now. Many. many thanks.


Yes, they are carried over AFAIK.

I have done as you advised and all is OK now. Many. many thanks.

Great! :slight_smile: