Nouveau not working, only vesa, and strange installation

Two pastebins:

lsmod - :~> lsmod Module - Anonymous - DmZmesMt - Pastebin.com](http://pastebin.com/DmZmesMt) no nouveau module :frowning:
Xorg.0.log 28.365] X.Org X Server - Anonymous - x5DYPE50 - Pastebin.com](http://pastebin.com/x5DYPE50)

28.938] (II) FBDEV: driver for framebuffer: fbdev

28.938] (II) VESA: driver for VESA chipsets: vesa

28.938] (++) using VT number 7

28.957] (II) Primary Device is: PCI 01@00:00:0

28.958] drmOpenDevice: node name is /dev/dri/card0

29.414] [drm] failed to load kernel module "nouveau"

29.414] (EE) [drm] failed to open device

29.415] (--) NV: Found NVIDIA GeForce FX 5200 at 01@00:00:0

29.415] (WW) Falling back to old probe method for fbdev

29.415] (II) Loading sub module "fbdevhw"

29.415] (II) LoadModule: "fbdevhw"

29.420] (II) Loading /usr/lib/xorg/modules/linux/libfbdevhw.so

29.422] (II) Module fbdevhw: vendor="X.Org Foundation"

29.422]    compiled for 1.8.0, module version = 0.0.2

29.424]    ABI class: X.Org Video Driver, version 7.0

29.425] (WW) Falling back to old probe method for vesa

Any suggestions? Probably the best is to wait for nvidia driver?

Another thing is interesting, I tried to install without boot parameters, with “acpi=off noapic nolapic”, both installation failed, twice hanging exactly when installing kernel-default.rpm, probably because of acpi. Then added “Installation – ACPI Disabled” at the end of boot options and it worked :smiley: But later added acpi=off, so now kernel optional parameters looks like “Installation – ACPI Disabled resume=/dev/disk/by-id/ata-IC35L040AVER07-0_SXPTX3T5970-part3 splash=silent quiet showopts acpi=off”. Maybe delete this “Installation – ACPI Disable” in the beginning? For now seems it is working without noapic nolapic.

Maybe this thread helps you? It describes how to get rid of nouveau and install Nvidia proprietary driver while there is no suse repository for this. No need to wait :wink:

The advice provided by joba1 should hopefully be sufficient. If you find the thread confusing, you can also read here: SDB:Configuring graphics cards - openSUSE

… in essence you likely need ‘nomodeset’ boot parameter in your boot menu (initially) to install, and then blacklist your nouveau driver per the guidance given in the link provided, and probably set yast > System > /etc/sysconfig Editor > System > Kernel > NO_KMS_IN_INITRD to “yes”.

I’m having a related problem (sort of) where I tried to install the nvidia drivers for improved 3d performance, but they were highly unstable, so I tried reverting back to nouveau, which I was quite happy with otherwise. Unfortunately, I can’t seem to get DRI working.

Output from glxinfo, xorg log, and relevant modules:
pastebin - nouveau problems on opensuse 11. - post number 1939221

Any suggestions would be appreciated

Did you use nomodeset in the kernel parameters?

I did try this originally, but it gave me a low-resolution display only. I’ve also tried reinstalling what I think to be the relevant packages for glx after removing the nvidia packages. Perhaps I should try this again now that I have an Xorg.conf (I can’t reboot for a few days due to some jobs I’m running, but I can restart X). In summary, I’m using ‘nv’ driver, asking Xorg.conf to load glx, dri, dri2, but nothing happens and I didn’t really see any complaints in the log file

You want the nvidia driver not the nv. If you read the links posted above it gives full instructions.

No, I don’t want NVIDIA, because for some reason on this laptop it causes X to “randomly” restart. I’ve had good experience with NVIDIA drivers in the past, but on this alienware it is sadly not the case in Linux (and not just SuSE Linux either).

When I first installed SuSE, I had DRI via nouveau - I’d like to get this back.

If nouveau does not work and nv does nor work and nvidia does not work that leaves only vesa. Only nouveau and nvidia have any 3D acceleration which I’d expect you would want on that hot hardware.

I’d drop back to 11.2 and hope they finally get the video straightened out in 11.4

Fair enough; maybe I’ll reinstall the base system and see if that helps when I can - 3d was definitely working in nouveau at first. You are right, I would prefer nvidia drivers for sure - I need to file some bug reports with nvidia. So is 11.4 supposed to do some major overhauling of video configuration (or are you referring to driver updates)?