Nouveau not blacklisted with proprietary Nvidia installed?

Just for the record
nomodeset is not in my grub.cfg
But the blacklist is in /etc/modprobe.d/nvidia.conf and nvidia-desktop.conf

Again, “nomodeset” is not necessary to get the nvidia driver to work.

It is necessary to prevent the nouveau kernel module to be loaded during boot though.
“nomodeset” achieves that as well as a by-product, because nouveau does not work without KMS.
It’s of course nicer to only disable nouveau than the whole KMS.

Although /etc/modprobe.d/nvidia.conf would normally not exist when you install the nvidia RPMs.
Probably you created that one yourself? (or maybe the .run installer creates it when it detects the nouveau driver)

There is /etc/modprobe.d/50-nvidia.conf, but this just sets options for the nvidia kernel module, it does not contain any blacklist.

I install Nvidia drivers thorugh software manager (which would be the RPM’s), as I mentioned before.
I don’t have nvidia.conf, though I do have nvidia-desktop.conf…

Yes, as I wrote.
The RPMs do not contain or create nvidia.conf.

nvidia-gfxG0X-kmp-desktop creates nvidia-desktop.conf with the nouveau blacklist, nvidia-gfxG0X-kmp-default creates nvidia-default.conf, and so on.

See also the file list (below the package list) in YaST->Software Management…