Nouveau not blacklisted with proprietary Nvidia installed?

I’m almost sure I have Nvidia proprietary drivers working (I always see a Nvidia screen while openSUSE is booting). I’ve always installed them through software manager.
I thought this automatically blacklisted nouveau as well, but I checked /etc/modprobe.d/50-blacklist.conf and nouveau isn’t anywhere there! So it’s not blacklisted!

Why? Have I been living with a faulty installation all this time?

If your default grub boot line includes “nomodeset”, then you don’t need to blacklist “nouveau”. The “nomodeset” already stops “nouveau” from being loaded.

And how can I check that? I don’t have any menu.lst inside /boot/grub.

Also, and sorry beforehand for this may seem like a noob question, but I’ve never actually known what “nomodeset” thing really is, despite having read several articles mentioning it. I suspect it has to do with KMS…

I don’t know why the situation changes here though:
https://en.opensuse.org/SDB:NVIDIA_the_hard_way#Disable_Kernel_Mode_Setting_.28KMS.29
“Kernel Mode Setting (KMS) works in supported versions”. Does it mean it’s no longer needed to disable, or is it by default disabled like you said?
And also, nouveau is indeed being blacklisted there even though KMS was disabled…

I think I’m completely lost, sorry again…

Please post the result of this in code tags

sudo cat /boot/grub2/grub.cfg

Hi caf,

I’m curious. nomodeset is included only on the failsafe modes (this can also be seen in Yast>System>Bootloader>Bootloader Options, for those more GUI-oriented).

sudo cat /boot/grub2/grub.cfg | grep nomodeset
linux /boot/vmlinuz-3.7.10-1.32-desktop root=UUID=f2b2d019-66d3-470e-b10c-d12430c99917 showopts apm=off noresume edd=off powersaved=off nohz=off highres=off processor.max_cstate=1 nomodeset x11failsafe ipv6.disable=1
linux /boot/vmlinuz-3.7.10-1.28-desktop root=UUID=f2b2d019-66d3-470e-b10c-d12430c99917 showopts apm=off noresume edd=off powersaved=off nohz=off highres=off processor.max_cstate=1 nomodeset x11failsafe ipv6.disable=1

It’s also not blacklisted:

:/etc/modprobe.d> cat 50-blacklist.conf | grep Nouveau
:/etc/modprobe.d> cat 50-blacklist.conf | grep nouveau
:/etc/modprobe.d> cat 50-blacklist.conf | grep NOUVEAU
:/etc/modprobe.d>

I suppose there’s other way were it’s deactivated, perhaps by systemd?

OBS: besides the nvidia drivers from the standard repo, xorg-x11-driver-video-nouveau is also installed, as well as the libdrm-nouveau2 (and-32bit) packages, and the nvidia drivers are active - 3D effects, GLX, etc.

openSUSE 12.3 64 bits, KDE 4.12

@Caf4926:

#
# DO NOT EDIT THIS FILE
#
# It is automatically generated by grub2-mkconfig using templates
# from /etc/grub.d and settings from /etc/default/grub
#

### BEGIN /etc/grub.d/00_header ###
if  -s $prefix/grubenv ]; then
  load_env
fi
set default="${saved_entry}"

if  x"${feature_menuentry_id}" = xy ]; then
  menuentry_id_option="--id"
else
  menuentry_id_option=""
fi

export menuentry_id_option

if  "${prev_saved_entry}" ]; then
  set saved_entry="${prev_saved_entry}"
  save_env saved_entry
  set prev_saved_entry=
  save_env prev_saved_entry
  set boot_once=true
fi

function savedefault {
  if  -z "${boot_once}" ]; then
    saved_entry="${chosen}"
    save_env saved_entry
  fi
}

function load_video {
  if  x$feature_all_video_module = xy ]; then
    insmod all_video
  else
    insmod efi_gop
    insmod efi_uga
    insmod ieee1275_fb
    insmod vbe
    insmod vga
    insmod video_bochs
    insmod video_cirrus
  fi
}

if  x$feature_default_font_path = xy ] ; then
   font=unicode
else
insmod part_msdos
insmod ext2
set root='hd0,msdos6'
if  x$feature_platform_search_hint = xy ]; then
  search --no-floppy --fs-uuid --set=root --hint-bios=hd0,msdos6 --hint-efi=hd0,msdos6 --hint-baremetal=ahci0,msdos6 --hint='hd0,msdos6'  cd7bd1f5-eaf6-41fc-816a-f54fd88f7542
else
  search --no-floppy --fs-uuid --set=root cd7bd1f5-eaf6-41fc-816a-f54fd88f7542
fi
    font="/usr/share/grub2/unicode.pf2"
fi

if loadfont $font ; then
  set gfxmode=auto
  load_video
  insmod gfxterm
  set locale_dir=$prefix/locale
  set lang=POSIX
  insmod gettext
fi
terminal_output gfxterm
insmod part_msdos
insmod ext2
set root='hd0,msdos6'
if  x$feature_platform_search_hint = xy ]; then
  search --no-floppy --fs-uuid --set=root --hint-bios=hd0,msdos6 --hint-efi=hd0,msdos6 --hint-baremetal=ahci0,msdos6 --hint='hd0,msdos6'  cd7bd1f5-eaf6-41fc-816a-f54fd88f7542
else
  search --no-floppy --fs-uuid --set=root cd7bd1f5-eaf6-41fc-816a-f54fd88f7542
fi
insmod gfxmenu
loadfont ($root)/boot/grub2/themes/openSUSE/DejaVuSans-Bold14.pf2
loadfont ($root)/boot/grub2/themes/openSUSE/DejaVuSans10.pf2
loadfont ($root)/boot/grub2/themes/openSUSE/DejaVuSans12.pf2
loadfont ($root)/boot/grub2/themes/openSUSE/ascii.pf2
insmod png
set theme=($root)/boot/grub2/themes/openSUSE/theme.txt
export theme
if  x${boot_once} = xtrue ]; then
  set timeout=0
elif sleep --interruptible 0 ; then
  set timeout=8
fi
### END /etc/grub.d/00_header ###

### BEGIN /etc/grub.d/10_linux ###
menuentry 'openSUSE 12.3' --class 'opensuse-12-3' --class gnu-linux --class gnu --class os $menuentry_id_option 'gnulinux-simple-cd7bd1f5-eaf6-41fc-816a-f54fd88f7542' {
    load_video
    set gfxpayload=keep
    insmod gzio
    insmod part_msdos
    insmod ext2
    set root='hd0,msdos6'
    if  x$feature_platform_search_hint = xy ]; then
      search --no-floppy --fs-uuid --set=root --hint-bios=hd0,msdos6 --hint-efi=hd0,msdos6 --hint-baremetal=ahci0,msdos6 --hint='hd0,msdos6'  cd7bd1f5-eaf6-41fc-816a-f54fd88f7542
    else
      search --no-floppy --fs-uuid --set=root cd7bd1f5-eaf6-41fc-816a-f54fd88f7542
    fi
    echo    'Loading Linux 3.7.10-1.16-desktop ...'
    linux    /boot/vmlinuz-3.7.10-1.16-desktop root=UUID=cd7bd1f5-eaf6-41fc-816a-f54fd88f7542   resume=/dev/disk/by-id/ata-ST9160821AS_5MA3HSPY-part5 splash=silent quiet showopts
    echo    'Loading initial ramdisk ...'
    initrd    /boot/initrd-3.7.10-1.16-desktop
}
submenu 'Advanced options for openSUSE 12.3' $menuentry_id_option 'gnulinux-advanced-cd7bd1f5-eaf6-41fc-816a-f54fd88f7542' {
    menuentry 'openSUSE 12.3, with Linux 3.7.10-1.16-desktop' --class 'opensuse-12-3' --class gnu-linux --class gnu --class os $menuentry_id_option 'gnulinux-3.7.10-1.16-desktop-advanced-cd7bd1f5-eaf6-41fc-816a-f54fd88f7542' {
        load_video
        set gfxpayload=keep
        insmod gzio
        insmod part_msdos
        insmod ext2
        set root='hd0,msdos6'
        if  x$feature_platform_search_hint = xy ]; then
          search --no-floppy --fs-uuid --set=root --hint-bios=hd0,msdos6 --hint-efi=hd0,msdos6 --hint-baremetal=ahci0,msdos6 --hint='hd0,msdos6'  cd7bd1f5-eaf6-41fc-816a-f54fd88f7542
        else
          search --no-floppy --fs-uuid --set=root cd7bd1f5-eaf6-41fc-816a-f54fd88f7542
        fi
        echo    'Loading Linux 3.7.10-1.16-desktop ...'
        linux    /boot/vmlinuz-3.7.10-1.16-desktop root=UUID=cd7bd1f5-eaf6-41fc-816a-f54fd88f7542   resume=/dev/disk/by-id/ata-ST9160821AS_5MA3HSPY-part5 splash=silent quiet showopts
        echo    'Loading initial ramdisk ...'
        initrd    /boot/initrd-3.7.10-1.16-desktop
    }
    menuentry 'openSUSE 12.3, with Linux 3.7.10-1.16-desktop (recovery mode)' --class 'opensuse-12-3' --class gnu-linux --class gnu --class os $menuentry_id_option 'gnulinux-3.7.10-1.16-desktop-recovery-cd7bd1f5-eaf6-41fc-816a-f54fd88f7542' {
        load_video
        set gfxpayload=keep
        insmod gzio
        insmod part_msdos
        insmod ext2
        set root='hd0,msdos6'
        if  x$feature_platform_search_hint = xy ]; then
          search --no-floppy --fs-uuid --set=root --hint-bios=hd0,msdos6 --hint-efi=hd0,msdos6 --hint-baremetal=ahci0,msdos6 --hint='hd0,msdos6'  cd7bd1f5-eaf6-41fc-816a-f54fd88f7542
        else
          search --no-floppy --fs-uuid --set=root cd7bd1f5-eaf6-41fc-816a-f54fd88f7542
        fi
        echo    'Loading Linux 3.7.10-1.16-desktop ...'
        linux    /boot/vmlinuz-3.7.10-1.16-desktop root=UUID=cd7bd1f5-eaf6-41fc-816a-f54fd88f7542  showopts apm=off noresume edd=off powersaved=off nohz=off highres=off processor.max_cstate=1 nomodeset x11failsafe
        echo    'Loading initial ramdisk ...'
        initrd    /boot/initrd-3.7.10-1.16-desktop
    }
    menuentry 'openSUSE 12.3, with Linux 3.7.10-1.4-desktop' --class 'opensuse-12-3' --class gnu-linux --class gnu --class os $menuentry_id_option 'gnulinux-3.7.10-1.4-desktop-advanced-cd7bd1f5-eaf6-41fc-816a-f54fd88f7542' {
        load_video
        set gfxpayload=keep
        insmod gzio
        insmod part_msdos
        insmod ext2
        set root='hd0,msdos6'
        if  x$feature_platform_search_hint = xy ]; then
          search --no-floppy --fs-uuid --set=root --hint-bios=hd0,msdos6 --hint-efi=hd0,msdos6 --hint-baremetal=ahci0,msdos6 --hint='hd0,msdos6'  cd7bd1f5-eaf6-41fc-816a-f54fd88f7542
        else
          search --no-floppy --fs-uuid --set=root cd7bd1f5-eaf6-41fc-816a-f54fd88f7542
        fi
        echo    'Loading Linux 3.7.10-1.4-desktop ...'
        linux    /boot/vmlinuz-3.7.10-1.4-desktop root=UUID=cd7bd1f5-eaf6-41fc-816a-f54fd88f7542   resume=/dev/disk/by-id/ata-ST9160821AS_5MA3HSPY-part5 splash=silent quiet showopts
        echo    'Loading initial ramdisk ...'
        initrd    /boot/initrd-3.7.10-1.4-desktop
    }
    menuentry 'openSUSE 12.3, with Linux 3.7.10-1.4-desktop (recovery mode)' --class 'opensuse-12-3' --class gnu-linux --class gnu --class os $menuentry_id_option 'gnulinux-3.7.10-1.4-desktop-recovery-cd7bd1f5-eaf6-41fc-816a-f54fd88f7542' {
        load_video
        set gfxpayload=keep
        insmod gzio
        insmod part_msdos
        insmod ext2
        set root='hd0,msdos6'
        if  x$feature_platform_search_hint = xy ]; then
          search --no-floppy --fs-uuid --set=root --hint-bios=hd0,msdos6 --hint-efi=hd0,msdos6 --hint-baremetal=ahci0,msdos6 --hint='hd0,msdos6'  cd7bd1f5-eaf6-41fc-816a-f54fd88f7542
        else
          search --no-floppy --fs-uuid --set=root cd7bd1f5-eaf6-41fc-816a-f54fd88f7542
        fi
        echo    'Loading Linux 3.7.10-1.4-desktop ...'
        linux    /boot/vmlinuz-3.7.10-1.4-desktop root=UUID=cd7bd1f5-eaf6-41fc-816a-f54fd88f7542  showopts apm=off noresume edd=off powersaved=off nohz=off highres=off processor.max_cstate=1 nomodeset x11failsafe
        echo    'Loading initial ramdisk ...'
        initrd    /boot/initrd-3.7.10-1.4-desktop
    }
}

### END /etc/grub.d/10_linux ###

### BEGIN /etc/grub.d/20_linux_xen ###
### END /etc/grub.d/20_linux_xen ###

### BEGIN /etc/grub.d/20_memtest86+ ###
### END /etc/grub.d/20_memtest86+ ###

### BEGIN /etc/grub.d/20_ppc_terminfo ###
### END /etc/grub.d/20_ppc_terminfo ###

### BEGIN /etc/grub.d/30_os-prober ###
menuentry 'Windows Recovery Environment (loader) (on /dev/sda1)' --class windows --class os $menuentry_id_option 'osprober-chain-CE56F82E56F818C3' {
    insmod part_msdos
    insmod ntfs
    set root='hd0,msdos1'
    if  x$feature_platform_search_hint = xy ]; then
      search --no-floppy --fs-uuid --set=root --hint-bios=hd0,msdos1 --hint-efi=hd0,msdos1 --hint-baremetal=ahci0,msdos1 --hint='hd0,msdos1'  CE56F82E56F818C3
    else
      search --no-floppy --fs-uuid --set=root CE56F82E56F818C3
    fi
    drivemap -s (hd0) ${root}
    chainloader +1
}
### END /etc/grub.d/30_os-prober ###

### BEGIN /etc/grub.d/40_custom ###
# This file provides an easy way to add custom menu entries.  Simply type the
# menu entries you want to add after this comment.  Be careful not to change
# the 'exec tail' line above.
### END /etc/grub.d/40_custom ###

### BEGIN /etc/grub.d/41_custom ###
if  -f  ${config_directory}/custom.cfg ]; then
  source ${config_directory}/custom.cfg
elif  -z "${config_directory}" -a -f  $prefix/custom.cfg ]; then
  source $prefix/custom.cfg;
fi
### END /etc/grub.d/41_custom ###

### BEGIN /etc/grub.d/90_persistent ###
### END /etc/grub.d/90_persistent ###

Let me just add some of my experience.

When I install nVidia drivers the hard way, the installer complains if nouveau is already loaded. That’s when it adds the blacklist. If I recall, it then tells me to reboot before installing.

When I did a one-time boot with “nomodeset” to install the drivers, and then switched to init level 3 (so X was not running), it did not blacklist nouveau. It may have set the NO_KMS_IN_INITRD (or whatever it is called). The nvidia drivers worked for the next couple of boots, then stopped working until I did a boot with “nomodeset”.

On my most recent install the hard way, I set “nomodeset” as a default in “/etc/default/grub”, and rebuilt “grub.cfg”. Then I rebooted to activate that, switched to init level 3, and installed the nvidia drivers. That has worked without problems, and I’m pretty sure that there isn’t a blacklist of nouveau.

Not being in front of my box which runs nvidia isn’t helping me right now.

But installing the nvidia from the repo should work.
You can manually add nomodeset to the the default boot by editing it at boot. (it isn’t present in your posted code)

I’ll check my system later, but I suspect the others here will have you sorted in no time

It is blacklisted in /etc/modprobe.d/.
But the nvidia driver packages do not add the blacklist to 50-blacklist.conf, they create a separate file nvidia-desktop.conf (or slightly different, depending on which kernel flavor you use).

That’s easier to manage, as you just have to remove the file when you uninstall the driver (that’s being done automatically of course).

Try this and you’ll find the blacklist:

grep nouveau /etc/modprobe.d/nvidia*

So nomodeset is not necessary.

All files in /etc/modprobe.d/ are respected by the system, not just 50-blacklist.conf. That’s the purpose of that directory.

Assuming that the file name is nvidia* ie starting with nvidia IMHO you can just grep all the files inside modprobe.d by

grep nouveau /etc/modprobe.d/*

or add the i flag with grep if you like, any way just saying :wink:

Yes, of course.
But I know that the file name starts with nvidia… :wink:

or add the i flag with grep if you like, any way just saying :wink:

The ‘-i’ flag is not necessary. The kernel module is indeed called “nouveau”, not “Nouveau” or anything else.

Just like all other kernel modules are lower-case only.

What if someone wrote a Nvidia.conf or MyBlacklist.conf and blacklisted nouveau in that file? lol!

I’m talking about the file that the nvidia driver packages create.

If someone wrote his own file, he should know that there is one and that it might be named differently… :wink:

Assuming he/she did not forgot about it :wink:

This is a very helpful discussion now, right?

The question was about the official nvidia driver packages.

And yes, as you yourself wrote, grepping for “nouveau” in the whole /etc/modprobe.d/ directory should find the blacklist in any case, i.e.:

grep nouveau /etc/modprobe.d/*

Can we stop now? :wink:

Any way, you can probably check for file extension too since files with the .conf extension holds the blacklisted modules.

grep nouveau /etc/modprobe.d/*.conf

but this also assumes that no clever folks would create a directory inside /etc/modprobe.d and name it **directory.conf **. I know alot of it is just an assumption. If you can remember sysadmins and users a like fell in love with openssl because of the security it provides, until they had a “Heart Bleed” rotfl!.

Stopping now, sorry for the noise.

From “man modprobe.d”:

       ... All files underneath the
       /etc/modprobe.d directory which end with the  .conf  extension  specify
       those  options  as  required.


So yes, only files which end in .conf are respected for blacklists.
And no, sub-directories inside /etc/modprobe.d/ are not searched.

But it was a certainly didactic discussion, at least for me.
But I think there was something remaining…

Thanks beforehand.

KMS=Kernel Mode Setting, i.e. the Kernel switches the display resolution instead of the user space X driver as has been done before.

Advantages are that it is faster/flickers less, and that it also has effect in text mode.

“nomodeset” disables KMS.

I don’t know why the situation changes here though:
SDB:NVIDIA the hard way - openSUSE Wiki
“Kernel Mode Setting (KMS) works in supported versions”. Does it mean it’s no longer needed to disable, or is it by default disabled like you said?
And also, nouveau is indeed being blacklisted there even though KMS was disabled…

The nvidia driver does not support KMS at all. (it does something similar in its kernel module though)
But you don’t have to disable it, the driver should work even when it is enabled.

What you do have to do is preventing that the nouveau kernel module is loaded somehow. Otherwise the nvidia kernel module cannot be loaded because the graphics card is already in use by a driver.

Since nouveau only works with KMS enabled, there are those ways to prevent it from being loaded:
either

  • blacklist it (this is done by the nvidia driver packages)
    or
  • disable KMS

I hope this makes it clearer.