Nouveau - How to reverse from nvidia to nouveau


OS : leap 42.3
kernel : 4.4.103-36-default
Graphic driver : Nvidia
Install mode : The hard way (opensuse naming).

I run into problem when installing the recent nvidia driver. Then Following a suggestion from nvidia In try to return to nouveau and then re-install nvidia
I have manually reverse the configuration

1: remove nomodeset in command line kernel boot
2: remove /etc/modprobe.d/xxxxxx file that looks like disable nouveau.conf
3: remove line in 50-blacklist.conf that disable nouveau
4: reinstall drm-kmp-default
5: NO_KMS_IN_INITRD --> nothing to do because does not exists
6: do mkinitrd
7: reboot
8: black screen when login screen is supposed to come

Starting x from init 3, show an error, message

 Plasma is unable to start as it could not correctly use OpenGL 2.  Please check that your graphic drivers are set up correctly.

Other error :

Can't open display: 
XIO fatal IO error 13 (permission denied) on X server :0 from kinit
Could not start ksmserver
could not connect to d-bus server

So How could I do something that is like reinstalling nouveau.

From your procedure I see that the very first step is notably missing, e.g.:

# sh ./NVIDIA-Linux-x86_64-***.**.run --uninstall

Did you forget to mention it or did you forget to run it?

I have to admit that I have forgotten this very small detail :shame: .

Thank you very very much indeed.

Thread is closed

I encountered the same error during a 42.2=>42.3 upgrade (with DVD) with nvidia drivers installed from the nvidia repo. Fortunately I was on my test machine as I was not able to repair the problem from a rescue session; I was forced to do a clean install which I cannot do on my main workstation.

Do I follow the OP’s above procedure before I begin the upgrade, starting with uninstalling from the repo? Will that automatically bring back nouveau?

Also, I am currently using grub legacy; “nomodeset” is not in my kernel boot command; what should I do about that?

Thanks a lot!


No, the OP installed the nvidia driver via nvidia’s .run installer (aka “the hard way”).

If you installed from the repo, just uninstall the nvidia packages with YaST or zypper.

Will that automatically bring back nouveau?

Yes, unless you have an xorg.conf that forces nvidia, or manually added a nouveau blacklist somewhere.
If that’s the case, remove it.

Also, I am currently using grub legacy; “nomodeset” is not in my kernel boot command; what should I do about that?

“nomodeset” is not necessary if nouveau is properly blacklisted (which the nvidia rpm packages take care of anyway).

Also, “nomodeset” would actually disable nouveau, bad idea if you want to switch to it… :wink:

Thanks very much! Sorry, left out this question . . . according to 42.3 Release Notes, after removing the nvidia drivers (from the wording this seemed to apply either way, from the script or from the repo), then “drm-kmp-default” needs to be reinstalled. Yes?

Again, TIA.


EDIT: Btw, despite my sig, I am upgrading from 42.2. I haven’t been here for a good while, so apparently I can’t edit my sig. :slight_smile:

Well, you don’t need to install it per se.
It contains backported graphics drivers from Kernel 4.9 though, so probably good to have (especially if your graphics card/chip is quite new). Unless it gives you problems (which may be the case for older intel chips e.g.)…

It might even get pulled in automatically, I think, if you install updates.
ase it’s better to uninstall it.

EDIT: Btw, despite my sig, I am upgrading from 42.2. I haven’t been here for a good while, so apparently I can’t edit my sig. :slight_smile:

If you are logged in, you should be able to edit your sig in the “User Control Center” (top right of the page). There should be a link “Edit Signature” on the left side below “Settings”->“My Profile”.

I’m obliged. For safety sake, I’ll reinstall it after I’ve removed the nvidia drivers and cleaned up modprobe.d if necessary; apparently there is no xorg.conf any longer so no problem there.

Found the route to changing profile elements, so the sig is done, too.

Thx again!


Note that xorg settings can be set in two places /etc/X11.xorg.conf (old style) and in individual files in /etc/X11/xorg.conf.d directory (new style)

Unless you modified things manually, there shouldn’t be anything to clean up in modprobe.d though…

apparently there is no xorg.conf any longer so no problem there.

xorg.conf is not there by default (nor needed) anymore since about 10 years.

But you could have created one manually, e.g. by running nvidia-xconfig (which some people apparently still believe is necessary, it isn’t).
It is still used if it exists, and if the specified driver is not found, X will fail to start.

PS, Just to be sure: do not delete /etc/X11/xorg.conf.d/ or the files provided by the distribution in there!
This will break things.

Thanks! I didn’t know about the xorg.conf.d directory. I looked at the files there and found no reference to the graphics card or driver. Do I need to do something with that directory?

No if you made no changes leave it alone

Oops, didn’t see the posts above before I wrote my reply, and then too late to edit it away. Anyway, thanks a lot, and I’ll leave the directory alone. :wink:

Correct. The driver is determined automatically by default.

You can of course specify a driver explicitly (either in xorg.conf or in some file in xorg.conf.d), but it should not be necessary. (and it will break X if the driver cannot be loaded for some reason, e.g. if you change graphics cards)

I tried to remove Nvidia drivers and change to Nouveau.

Attempting to login at KDE graphical login page as normal user results in login page reloading.

I am able to login to KDE desktop using root credentials.

Suspect that there is something Nvidia specific in my normal user account that is stopping Nouveau. A preferences or config file, for example

I am using a desktop PC with two displays which may be a clue.

How to correct whatever is stopping my normal user login?

What exactly did you try?

Removed using zypper and following troubleshooting instructions in this thread.

cd /etc/modprobe.d

I’m not sure what the file is called with the opensuse package.
The installer from nvidia’s website creates:

If not, look for other files with ‘nvidia’ or ‘blacklist’ in the name.
Look for the content:

 blacklist nouveau
 options nouveau modeset=0

Although, if you are seeing the display manager, I think nouveau is already loaded.