Notifications widget not found

New install of 15.2

I was getting what seemed like random notification signals so tried to see what was set up.

Selected Notifications from System Settings and got “Notifications widget not found” message.

The only thing I found under downloads was a library which turned out to be already installed.

Where to get a widget?

Isn’t this about something in a Desktop Environment?
Then better explain which Desktop Environment you are using.

Ah yes, my apologies.

It’s KDE. whatever version ships with 15.2

Again, sorry

Using the definitions in the KDE Plasma Handbook: <> –

  • Right click on the System Tray and check that Notifications is enabled.
  • Right click on the Task Bar and select “Add Widgets” – other names for the “Widgets” are “Applets” and “Plasmoids” …
  • Check that the Notifications Widget has been added to the System Tray – if it has been added, there’ll be a green circle top left on the icon with a “r” – running - in it – or, whatever alphabet character the 1st character of the translation of “running” is in your language.
  • The Notifications Widget hasn’t been automatically added to the System Tray – it should have been – drag it over to the System Tray.

If the Notifications Widget doesn’t neither appears in the System Tray nor in the “Add Widgets” please check that the directory structure “/usr/share/plasma/plasmoids/org.kde.plasma.notifications/” is present – including the subdirectories.

  • If that ain’t there, you’ll have to forcibly reinstall the package “plasma5-workspace
    ” – then logout – then log back in again.

Yes, I see that too.

But, until recently, it was working. I could look for hidden tray items, and see a bell which told me there were no unread notification.

But now I do not see that bell.

I tried booting 15.2 in a virtual machine – and it wouldn’t boot. I will have to investigate that.

I also have 15.2 in another virtual machine. And that one did boot and notifications are working.

So this is a puzzle. Something broke. Maybe a bug report would be appropriate.


A forced update of all the plasma5 stuff gave me the widget.

Thanks to all who helped.

In my previous post, I said that the problem was resolved after a forced update.

Now, the problem has returned! No amount of forced updating resolves it.

The /usr/share/plasma/plasmoids stuff is there and the notifications dir is there also.

Just to be clear. The notifications I’m looking for are in the system settings and it’s the facility that lets me set sounds to be played when certain events occur, like log in, log out etc.

This is not the little pop-up thing that tells me when a usb stick is inserted or a dvd etc. That one is functioning fine.

(KDE) System Settings → Notifications → Configure … is working OK here:

Are you able to start it via an alternative method, for example, (KDE System Tray) Show Hidden Icons → Notifications → Configure Event Notifications and Actions…

A bug report at KDE probably wouldn’t go amiss…

and choose “Notifications” as the component.

“systemsettings5 → Personalization → Notifications” – at the bottom of the list: “Applications:” and a “Configure” button:

  • “System Services” → “Plasma Workspace
    ” … >:)

[HR][/HR]Yes, friends of the Spanish Opera … – it’s been changed and moved around – the login/logout sounds used to be in something related to “KWin” – they ain’t there no more …


When I select notifications, I get the message about widget not found. The applications and configure buttons are greyed out and inoperable.


I don’t see any “Show hidden icons” associated with the system tray.

It’s the “Triangle” Icon: (I suspect though you’ll still have the error…)

Also, if you’ve not done so, test with a new user, that would establish if it’s a user configuration or system-wide problem.

It seems that the KDE messaging bus is broken – at least for the affected user.

  • What happens for the case of a newly created test user?

Created a new user - the widget is found, apparently.

What part of the config needs changing?

What part indeed, good question…

OK we know its a problem at the user level, let’s first try to eliminate the desktop panel/widget setup:

Logout from the desktop, switch to a VT (ctrl-alt-F2), login as your normal user and temporarily disable the config file “plasma-org.kde.plasma.desktop-appletsrc”.

mv ~/.config/plasma-org.kde.plasma.desktop-appletsrc ~/.config/plasma-org.kde.plasma.desktop-appletsrc.old

That will result in a new default desktop layout the next time you login. (Switch back to the graphical terminal using ctrl-alt-F7).

If that has no effect the original “plasma-org.kde.plasma.desktop-appletsrc” can be restored.


Yes. If I move mt appletsrc out of the way and let a new one be created, the widget is found. Just like a new user.

It seems to be something in my appletsrc file but which bit?

There are a few appletsrc files in the directory, each having an extentsion like “iR2956”. I’ve tried using the contents of those but the widget remains unfound.

I might try changing my file’s contents bit by bit to the default file’s.

There should only be one “plasma-org.kde.plasma.desktop-appletsrc”, the others you have with the extension similar to that you quoted are, I believe, temporary versions created during a change to the layout (to allow a degree of “undo”) and should have been deleted after that change was accepted.

The “plasma-org.kde.plasma.desktop-appletsrc” configuration file is quite complex, and often contains redundant references to various widgets, see this bug report:

Rather than try to “repair/restore” your original file you would probably be better off accepting the new, default, and configuring the desktop/widgets afresh.

You’ll need to perform a recursive “diff” of the files in the problem user’s “~/.config/” directory against, the configuration files of the user who is not experiencing this difficulty.