Notifications from desktop calendar MineTime

I am running OpenSuse 42.3 with Plasma 5.3.7 and trying to get the desktop calendar MineTime to work. The event notifications and popup alerts won’t display. The Plasma Notification widget setting has Show application and system notifications turned on. None of the event notifications appear in the Notification widget. I looked at the Notifications under Configure Desktop but can’t find anything that applies. Can anyone suggest how to fix this?

Just a (wild) guess…

MineTime isn’t a native KDE/Qt/Gtk application. It uses “electron”

Perhaps it’s unable to integrate with the DE notification system?

Maybe raise an issue with developers

Electron sends notices through Libnotify and they should at least reach the Plasma notification system. I have tried a couple other desktop calendars and they have similar problems. Even KOrganizer doesn’t post popup notices correctly. I suspect a configuration issue on my computer more than a problem with MineTime.

Any other desktop calendar suggestions?

OK… As I said, just a wild guess.

Any other desktop calendar suggestions?

I’m not a great calendar user, Lightning as an extension to Thunderbird serves my needs, but they’re very basic :slight_smile:

Using kOrganizer here, and desktop notifications are working fine. JFYI.
Create a new user, login as that user and see if things work for that new user. If not, it’s a system issue.

Created a test user and logged in as the new user. Tried setting an event in KOrganizer and an alert 5 minutes before the event. Neither produces a popup. No notices posted to the Notification daemon.

I experimented with Gnome last spring for about a month before switching back to KDE. There could be some misconfiguration due to that experiment. Is there a way to make sure all the Display Manager and Windows Manager settings are set to their KDE defaults?

It’s my understanding that Gnome can co-exist with KDE, so that may not be the cause.

Again, rather guessing with the more obvious things… You’ve probably checked anyway :wink:

Are the “libnotify” packages installed?
libnotify4 - Notifications Library
libnotify-tools - Notifications Library – Tools
typelib-1_0-Notify-0_7 - Notifications Library – Introspection bindings
(Versions might not be exactly the same, these are from Tumbleweed)

System Tray Settings are correct?
General - Extra Items - Notifications (Enabled)
Entries - Notifications - Show

Does “notify-send” work?
From konsole execute (for example)

notify-send "Title" "Test Message"

Do any notifications work, or is it only some applications?

All the software is installed and notify-send works. It is the only thing I have found that creates a popup on the desktop. The Notification settings are set to allow application and system notifications.

I went to the etc/sysconfig editor last night trying find something that might look off. The Display Manager was set to sddm but even though I am running KDE the default Window Manager was set to Gnome. Changed it to default and logged off and back on but it didn’t fix the problems. I am wondering what else might be messed up.

Gnome and KDE coexist just fine. I still have all the Gnome and KDE desktop software installed on the computer. Reasonably sure the problem is with the operator and not the software.

Thanks to all who tried to help. Not a very elegant solution but reinstalling 42.3 fixed the problem.