Notice to update MozillaFirefox 3.0.x when 3.5.x installed

Hi All,

I installed FF 3.5 via mozilla repo and removed FF 3.0.x but I keep getting nagged to update to FF 3.0.12.

I can deselect that particular update when updating the system but it’s rather annoying and I don’t know how to get rid of it.

Anyone else have this problem? How’d you solve it?

Is it because the Update repo has a higher priority? But I don’t see how that should matter if FF 3.0.x is removed from the system.

laptop:~ # rpm -qa | grep -i firefox




Could you please open a terminal and provide the output of typing:

zypper lr --details

Take Care,


Hey blender1968,

I hope this helps any. Those are the packages that I’ve currently installed - and with this configuration everything works perfectly. :slight_smile:

TheMask@Superpussy:~> rpm -qa | grep -i firefox

Good luck!


The thing is, if his update repo has higher priority, Yast will tell him to upgrade his packages to that of the update repository, even if the packages from a different repository are newer. I just checked and the update repo does have the lower version of firefox. So it’s very likely the update repository priority is the cause.

Take Care,


I have had the same & did the update. It will not touch firefox,just xulrunner,nsprr & one other ( can’t remember which atm) I updated 3 days ago with no ill effects.Personally i prefer Seamonkey browser.


Strangely, I had this update come via the official repo to a 10.3 system I retained. The distributed (updated) FF version for 10.3 is I tried to install it, but it failed with dependency errors on xulrunner etc. Hmm, it couldn’t satisfy them from the normal distribution repo. I guess someone screwed up.

BTW, do you prefer Seamonkey (on 11.1) for ease of use, or is it faster than FF?? I haven’t tried it yet. :slight_smile:

I had the same dependency errors on xulrunner etc. until a few days ago. Apperently something has been done. It now updates and installs a new xulrunner, the old one is still there.

I prefer it as it is an all in one piece of software. It has email,chat,web & web-page creator ( wysiwyg ) all integrated & to me is faster than firefox,as once you use one component,all the rest can be accessed from that component,instead of firing up another prog to take up resources.That’s MHO, try it & see what you think


Thanks Andy, your comments particularly on performance are encouraging. I will definitely try it out. Any performance gains are worth considering, given the growing trend for resource hungry software releases these days.

Someone else posted with the same problem. The solution was given here (I think):

Running Mozilla 3.5 updater wants to update/rollback to 3.0 - Page 2 - openSUSE Forums

but I guess that is for KDE environment. I don’t have the same menu structure in Gnome. Particularly the “Update all in this list unconditionally”.

Any other ideas?


You can use the qt interface in gnome over time many have preferred if over the gtk one.

iirc you should have yast-qt some thing like so, then /etc/sysconfig and change the preferred to qt sorry for the vagueness but never done it and have not looked for a long time.

Search in software for something like yast-qt worse case ,try yast or is it yast2, then search sysconfig iirc gui or browse the tree to yast.



I edited /etc/sysconfig/yast2 and changed


I was able to follow the procedure mentioned before and I have gotten rid of the annoying prompt to update FF 3.0.x.