Nothing provides rubygem Problem whel installing Vagrant

Hopefully someone can help with this:

LC_ALL=C sudo zypper install -f vagrant
Loading repository data...
Reading installed packages...
Forcing installation of 'vagrant-2.2.2-lp150.1.1.x86_64' from repository 'Virtualization:vagrant'.
Resolving package dependencies...

Problem: nothing provides rubygem(ruby:2.5.0:i18n:1.1) >= 1.1.1 needed by vagrant-2.2.2-lp150.1.1.x86_64
 Solution 1: do not install vagrant-2.2.2-lp150.1.1.x86_64
 Solution 2: break vagrant-2.2.2-lp150.1.1.x86_64 by ignoring some of its dependencies

Choose from above solutions by number or cancel [1/2/c] (c):

my repos are:


LC_ALL=C zypper lr -u -E
Repository priorities in effect:                                                                                                                                                   (See 'zypper lr -P' for details)
      90 (raised priority)  :  1 repository  
      99 (default priority) : 10 repositories

#  | Alias                               | Name                                                                                  | Enabled | GPG Check | Refresh | URI                                                                                             
---+-------------------------------------+---------------------------------------------------------------------------------------+---------+-----------+---------+-------------------------------------------------------------------------------------------------
 1 | Education                           | Applications for education users (openSUSE_Leap_15.0)                                 | Yes     | (r ) Yes  | No      | http://download.opensuse.org/repositories/Education/openSUSE_Leap_15.0/                         
 2 | Virtualization_containers           | Virtualization:containers (openSUSE_Leap_15.0)                                        | Yes     | (r ) Yes  | Yes     | http://download.opensuse.org/repositories/Virtualization:/containers/openSUSE_Leap_15.0/        
 3 | devel_CaaSP_Head_ControllerNode     | "master branch" project for SUSE Container as a Service Platform (openSUSE_Leap_15.0) | Yes     | (r ) Yes  | Yes     | http://download.opensuse.org/repositories/devel:/CaaSP:/Head:/ControllerNode/openSUSE_Leap_15.0/
 4 | http-download.opensuse.org-56021284 | Virtualization:vagrant                                                                | Yes     | (r ) Yes  | Yes     | http://download.opensuse.org/repositories/Virtualization:/vagrant/openSUSE_Leap_15.0/           
 5 | packman-essentials                  | packman-essentials                                                                    | Yes     | (r ) Yes  | Yes     | http://ftp.gwdg.de/pub/linux/misc/packman/suse/openSUSE_Leap_15.0/Essentials                    
10 | repo-non-oss                        | openSUSE-Leap-15.0-Non-Oss                                                            | Yes     | (r ) Yes  | Yes     | http://download.opensuse.org/distribution/leap/15.0/repo/non-oss/                               
11 | repo-oss                            | openSUSE-Leap-15.0-Oss                                                                | Yes     | (r ) Yes  | Yes     | http://download.opensuse.org/distribution/leap/15.0/repo/oss/                                   
14 | repo-update                         | openSUSE-Leap-15.0-Update                                                             | Yes     | (r ) Yes  | Yes     | http://download.opensuse.org/update/leap/15.0/oss/                                              
15 | repo-update-non-oss                 | openSUSE-Leap-15.0-Update-Non-Oss                                                     | Yes     | (r ) Yes  | Yes     | http://download.opensuse.org/update/leap/15.0/non-oss/                                          
16 | science                             | Software for Scientists and Engineers (openSUSE_Leap_15.0)                            | Yes     | (r ) Yes  | Yes     | http://download.opensuse.org/repositories/science/openSUSE_Leap_15.0/                           
17 | systemsmanagement_terraform         | systemsmanagement:terraform (openSUSE_Leap_15.0)                                      | Yes     | (r ) Yes  | Yes     | http://download.opensuse.org/repositories/systemsmanagement:/terraform/openSUSE_Leap_15.0/ 

how do I get out of this dependency predicament? It may be related to https://forums.opensuse.org/showthread.php/534676-Ruby-update-problem

thanks!
Reinhard

It looks like the dependency isn’t provided at the moment, even in the Ruby repo.

i18n components provide translations and multi-language support.
I assume that if you install using option 2 which is to ignore the dependency, it shouldn’t affect functionality using the default English language.

Recommend you install that way and also submit a bug to https://bugzilla.opensuse.org so that the issue can be addressed, I’d expect that this bug should affect many more uses than just in Vagrant.

TSU