i have installed opensuse 11.2 only a few days before only and initially the keyboard and wifi was not working …but now venver i start it only the background screen comes and nothng responds…
Should i do a fresh install or Is there any solution…

Before doing that, boot in runlevel 3, log in and initiate the graphic mode form the console with : startx .
Any error messages?

How do i do that :by specifiying 3 in the boot options???

Yes, when the boot menu appears, if you press 3 it will appear in the options line and it will boot to a full screen terminal mode, called run level 3.

Here is some basic graphic driver practical “theory” that may help you, dependant on the recommendations you get: openSUSE Graphic Card Practical Theory Guide for Users - openSUSE Forums

Do you know what graphic driver and what graphic hardware you are using?

that thing worked like a spell…BUt i Hope This does not mean Always i have to boot Through a terminal:(…ANd Why did this thing happen abruplty…even when i didnt have my wifi wrking?

And about gRaphics…i have no graphics card… nd i just have intel onboard graphics…Ny other details ya need?

Only when I resolve this issue of booting…i can go to others like keyboard touch pad and wifi,…help me folks:’(:’(:’(

There are many different intel devices. Is it possible for you to be more specific? ie open a terminal (you can do that by pressing <alt><f2> and type xterm) and in that terminal type:

su -c 'sax2 -p'

and enter root password when prompted for a password. What does that tell you for your Intel device?

Also, to see what driver go to /var/log/Xorg.0.log and open it with a text editor, and look for entries like (==) VESA or () VESA or (==)Intel or ()Intel so we can tell if your PC has a VESA or Intel driver in use.

These are my observations

  1. for su -c ‘sax2 -p’
    i got
    chip:0 is -> intel 965GM0 00:02:0 0x8086 0x2902 PCI intel
  2. in /var/log/xorg.o.log
    i didnt get those exact strings but saw a few things:
    section “DEVICE”
    identifer “nuilt in default intel device”
    section “SCREEN”
    identifier"built in default vesa screen 0"

and yeah one place i did fine
(==)intel(0):depth 24;


Do this:

su -c ‘mv /etc/X11/xorg.conf /etc/X11/xorg.conf.removed’

That would avoid the system to use the (obsolete) xorg.conf and let it detect and configure all devices without settings from the xorg.conf

From what I’ve read, I suspect that’s where the problem is.

I think u missed something there …there wasno destination for the move command

Noks28, the intent of that is to rename that file. And yes there IS a destination for the command. Look again.

ohk got it dint c it well…
Thnaks…lemme try it…
Hope it wrks:(

Well on my distro there is no file at the path /etc.x11/xorg.conf
and hence the command resulted in an error…
Cant a linux installation go wid a chill?:’(:’(:’(:’(

Noks28. Look again. You were not given /etc.x11/xorg.conf

You were given: /etc/X11/xorg.conf

note there is a “/” instead of a “.” and it is a capital “X” instead of an “x”.

Please try to pay more attention.

HEy i just typed it…actually i copied the command and also did try to see if there was a file by this nam using the gui but it wasnt there:(