Not using mode "1440x900" (exceeds panel dimensions)

Hi All!

I’ve been using a 4:3 monitor for my 11.3 and Xorg 1.8.0 and it works fine with the resolution 1280x1024. This resolution was detected by the installation process so I did not changed. The /etc/X11/xorg.conf.d directory has all the files the installer created.

Nowadays I changed my monitor to a 16:9 display and I wanted to change the resolution to 1600x900, later 1440x900 but both are failed. There’s a message above in the Xorg.0.log file…What does this mean? I googled the world and I found a lot of “clever” “experts” with a lot of different and useless opinions that won’t help.

I tried to use the Intel driver downloaded and compiled from source. The driver works well but also does not want to use the modes I want. The same message oin the log. It only changes to 1280x800. The monitor is capable for 1600x900 and 1440x900 we tested on a Windows 7 machine.

Log: intel(0): Allocated new frame buffer 1280x800 stride 8192, tiled

Next I tried to use to get the modelines for these resolutions with cvt and gtf. The same happened: “Not using mode…”. Next I tried to use vesa and other drivers found by google but nothing helped. I tried xorg.conf in many ways but I haven’t gone far.

How can I explicitly tell Xorg to use the resolution I WANT not the one it finds? Years before I could set up any resolution and in the worst case the monitor stays black or went stand-by mode due to the unknown resolution.

There’s no DVI connector on the Intel VGA. Just the normal VGA DSUB. EDID on VGA1 lists the modes I want but LVDS1 doesn’t. xrandr also lists the modes on VGA1 but LVDS1 doesn’t.

Any help would be highly appreciated!