Not open kwalletd5!!

Hi
when open kwalletd5 in the konsole
show log

kwalletd5
kwalletd5: error while loading shared libraries: libKF5Gpgmepp.so.5: cannot ope
n shared object file: No such file or directory

I not found lib “libKF5Gpgmepp”
how to fix?
Thanks

(Re)install the package gpgmepp5.

sudo zypper in -f gpgmepp5

Btw, there should be no need to run kwalletd5 manually…

Thanks fix the problem.
but,kwallet not starting, kwallets not asked to authenticate before saving. i must etch time enter password for wifi connection
kwallet not used for WiFi Password

Sorry wrong
i reinstall gpgmepp5

> sudo zypper in -f gpgmepp5
Loading repository data...
Reading installed packages...
Forcing installation of 'gpgmepp5-16.04.0-34.1.x86_64' from repository 'home:wo
lfi323'.
Resolving package dependencies...

The following package is going to be reinstalled:
  gpgmepp5

1 package to reinstall.
Overall download size: 0 B. Already cached: 101.5 KiB. No additional space will
be used or freed after the operation.
**Continue? [y/n/? shows all options] (y): **y
In cache gpgmepp5-16.04.0-34.1.x86_64.rpm (1/1), 101.5 KiB (636.7 KiB unpacked)
Checking for file conflicts: ............................................[done]
(1/1) Installing: gpgmepp5-16.04.0-34.1.x86_64 ..........................[done]

but,There’s still the problem

kwalletd5
kwalletd5: error while loading shared libraries: libKF5Gpgmepp.so.5: cannot ope n shared object file: No such file or directory

I’m not having that problem here.

Opensuse Leap 42.1; Plasma 5.6.x

I’m pretty sure that I’m still on Plasma 5.5.

I’m guessing that, in going to 5.6, you somehow managed to have some incompatible libraries.

Yes you are correct
I got to go to the plasma 5.6, I full switched to repos “Frameworks5,QT5”
but. i have two version kwallt “kwalletd5” and “kwalletd”
If I remove kwalleted5 was correct. or should have both versions

“kwalletd5” is the kdewallet application for Plasma 5.
“kwalletd” is the kdewallet application for Plasma 4.

As long as you have some older Plasma 4 software (such as “konqueror”), you will need both.

Is there a way to get kwallet to correct? since kwallet still does not work for me

After updating the system works now kwallet
But I do not know why when I enter the kwallet password opens window “kwallet manager”?

You probably left it running when logging out/shutting down?
KDE’s session management will then restart it on login.

Yes, I left …
After doing it now works fine
Thank you

I have a question
I downloaded themes splash screen and copy (user/share/ksplash) but not show my splashs screen in the workspace them–> Splash screen
why?

They are probably intended for KDE4.
Plasma5 uses different directories and probably doesn’t support old-style splash themes any more, only QML ones.
It may work by just copying the files accordingly or not, no idea.
The directory would be /usr/share/plasma/look-and-feel/themename/contents/splash/ though, there is no user/share/ksplash…

But how is this related to kwalletd5? :wink:

my kwalltmanager5 and gpgmepp5 was your home:wolf323
After I downloaded the library gpgmepp5 from the repo KDE ,kwallet5 problem was solved and worked
but using kwalletmanager5 in your home:wolf323
and for the problem opens window (kwallet manager)
I enabled check box (show manager in system tray)

Please don’t mix repos like that, and please also tell that you are using non-standard (KDE) repos when asking a question like this.

If you use my repo, make sure that all packages are actually coming from my repo, i.e. do a full switch to my repo.
Also you need to have KDE:Frameworks5 and KDE:Qt5 as well.

The standard kwalletmanager5 package will not find the libraries from my repo (as they are installed to /opt/kf5/), and the versions might not fit together anyway.

but using kwalletmanager5 in your home:wolf323
and for the problem opens window (kwallet manager)
I enabled check box (show manager in system tray)

That checkbox means that kwalletmanager will continue running in the system tray if you close the window.

But it should not be necessary to enable it to prevent that “problem”. kwalletmanager(5) will not be started by default, unless it was still running on logout (like any other application).

And still: the splash screen’s theme doesn’t have any relation at all to kwalletd5… :wink:

I’m sorry
i means.for path configure desktop–>workspace Theme–>splash screen
not for splash kwallet

Thank you very much for help me

Yes, that was clear.
But my point was that this is completely unrelated to this thread’s topic… :wink:

But again, /usr/share/ksplash/ is not used at all (according to my knowledge), copying files there won’t help.
Splash themes are looked for in /usr/share/plasma/look-and-feel/themename/contents/splash/ only AFAIK (and ~/.local/share/plasma/look-and-feel/themename/contents/splash/ for the current user), but whether the ones you downloaded would work or not I cannot tell (especially without even knowing what you downloaded from where…).

Though for a new theme it’s not sufficient to just copy the splash theme files to share/plasma/look-and-feel/newtheme/contents/splash/, you also need some other things.

As I said, I don’t know whether it’s possible to get a KDE4 splash to work, but it’s definitely not straight-forward and you should know what you are doing. And I can’t help you with that either.

It’s likely much easier to just download a look&feel package designed for Plasma5, this is supposed to include a fitting splash theme as well…
I’m not sure where to get some or whether they even exist.

As this is highly KDE specific and has no connection to openSUSE at all (other than that we ship Plasma5), you’re probably better off asking in the KDE forums though:

not for splash kwallet

What’s a “splash kwallet”?

Thank you very much for help me

You’re welcome.

Thanks
I fully understand
I’m sorry for unrelated to the thread’s topic.