not initialiazing when i install LEAP 42.1 on my desktop

i already installed opensuse leap 42.1 on my laptop and i became an instant fan, but when i try to install it also in my desktop, using the same installer ( usb flashdrive ), it’s not initializing after i choose ‘Install’ it’s just a "BlackScreen’

Video card?

i don’t have video card, i only have APU ( AMD A6 5400K Radeon HD 7540D ) …is it a hardware conflict?! or is it necessary to have a video card installed?!

APU ( AMD A6 5400K Radeon HD 7540D )
4GB Ram

No a video card or a GPU on the CPU it is all the same.

At the boot screen try pressing e then find line starting linux go to true end (it wraps) add a space and nomodeset this should force use of generic fall back drivers that should work. If you can install this way you can add the AMD proprietary driver which should deal with the problem. Also there a ton of updates that may fix it on the running system

PROBLEM SOLVED! " nomodeset " really worked! thanks so much!

… yes, i’ve succesfully installed Leap 42.1, but after i’ve installed the FGLRX, it’s just a blackscreen ( after that Leap loading logo )?!? …is it a bug?!?

Have you done the update. lots of early bugs have been fixed.

At what point does it fail, before or after login?

KDE5.5 has fixed some of these problems but you have to change to it by adding the 5.5 repos and doing a zypper dup

Before the Log.In… i’ve never done a full update yet …i dont know :’( …do you have any link/s that you recommend?

Does the network work??

You should see a notice

or from command line as root do

zypper up

network is working fine… uhmm, what should be the first thing/s to do, Update the system or installing driver?! …im a bit confused… ( because when i use MS Windows, installing Driver/s the first thing i do, is it the same?! )

Update system first then worry about driver. Who knows the update may correct the problem there have been lots of fixes since the 42.1 image was released. Though it is not written in stone. But there has been several kernel updates I believe and it may fix things

DONE! Working fine now! ( i force myself to re.install Leap > Update first > FGLRX > and so on… )
by the way, Thanks so much for your time and given ideas!