Not getting anywhere with Macbook

I have been trying to install either OpenSUSE or Ubuntu on my Macbook for 3 days now. Oh, how close I have gotten, only to be set back. Ill start by describing my experience with Linux and the specs of the Macbook.
i used Unetbootin on a very old IBM running XP, and had the laptop dual booting XP and Ubuntu in 5 minutes. So i figured the newer Mcbook would be even easier, right? No.
The Macbook is running OS X 10.5.8, with a 1.83 GHz Intel Dual Core, 1GB of RAM, and a nearly empty hard drive.
first, I am not interested in dual booting, i just want to run straight Linux, preferbally OpenSUSE, but Ill settle for Ubuntu. I got very close with Ubuntu twice, both times setup froze for over 10 hours on “waiting for network configuaration” this was using a LiveCD burned at max speed. Then OpenSUSE froze up the first time, then got through downloading the Kernal and installing some of the software before getting the “no repository found.” this was also working with a live cd. This happened twice. Now, it’s gotten way worse. Upon startup, after holding down alt and inserting either live cd, the cd reader whines loudly and spits the cd back out about 15 seconds later, and it never shows up as a boot option. ANY HELP PLEASE!!! I can use a usb stick if i must!

On 07/15/2012 06:16 AM, wemaxey wrote:
>
> i figured the newer Mcbook would be even easier . . . ANY HELP PLEASE!!!

first: -=WELCOME=-

there have been quite a large number of folks through these forums with
Macbooks…some very successful, some not so…unfortunately, not many
hang around waiting to provide the expertise to the newer folks like you…

fortunately, many left bread crumbs to mark your trail (i can’t help you
at all, except to try to aim you at what resources are available…which
you might find useful while waiting for an install-Linux-on-a-Macbook
guru to help)…

hmmmm…you didn’t say, so since a faulty install disk could be the
problem: did you md5 checksum test the iso prior to burning the disk?
you didn’t burn at the slowest possible speed (as you should) on high
quality media and then do this http://tinyurl.com/2ebcf27 before
attempting install (lots of hints on how to get a perfect install disk
here: http://en.opensuse.org/SDB:Download_help

if you have good install media, then i think i would start with
http://en.opensuse.org/HCL:Apple_laptops to see if there is hope…

and then, these five google hits in our how-to forums:

https://www.google.com/search?q=site:forums.opensuse.org/english/get-technical-help-here/how-faq-forums/
macbook

and also a wider look into all the forums:

https://www.google.com/search?q=site:forums.opensuse.org+install+macbook

a review of bugs:

https://www.google.com/search?q=site%3Aopensuse.org%2F+install+macbook+bugzilla

come back with more questions…as eventually a Macbook guru might
wander through…

when you are successful maybe you would contribute to the how-to forum,
and/or wiki, and/or hardware compatibility list…and hang around here
some to share . . .

again, welcome…good luck…i think with persistence you will be
successful (but, remember that Steve probably didn’t make it easy for you)…


dd

No, indeed. Apple hardware is different. It doesn’t have a BIOS like your very old IBM.

That’s quite irrelevant. I mean that’s not the problem. Dualbooting with rEFIT normally always work - you’ll find a several threads explaining how. If you don’t want to dualboot, you have to boot Linux he right way, meaning in UEFI mode and not in legacy BIOS compatible mode. I don’t know if you’re going to get an answer - probably you will - but you could provide one. OK, I’m aware that it sounds complicated - and it might be complicated in fact. When you tried to install openSUSE, did you see the word “grub” appearing somewhere during setup or did you see the word ‘elilo’? It is very important, because these are the 2 different setups, the one with Grub is the legacy setup (the one you don’t want). It is not appropriate on EFI/UEFI machines such as Apple’s - unless you use a trick à la bootcamp. This is used to boot non UEFI aware systems such as Windows XP and - unfortunately - openSUSE with legacy Grub (Ubuntu is easier because it uses Grub2 - although grub2 is not what you need either. What you need is grub2-efi.). For a year or so, PC mainboards also use UEFI. Apple has been using EFI - an older version - for years. All right, I’ll stop now, before it gets too complicated. But please, tell me if you see ‘Grub’ or ‘elilo’ and on which model of MacBook. It would tell me which kind of setup is started, and I would like to know that. I’m afraid, it’s the wrong setup though.

One more thing: you can not use openSUSE live CD, because it doesn’t include the UEFI setup (unlike Ubuntu live CD). You would need openSUSE install dvd if you want to install openSUSE on Apple hardware the right way … although one can always do it the “wrong” way (rEFIT + hybrid MBR). I’m afraid the vast majority of people here (including myself) have done it the wrong way with openSUSE - and that’s exactly what I would like to avoid in the future.

Another thing. When installed on a blank hard disk (wipe out the first track!) , Fedora setup creates a GUID parition table by default. It might help, because that’s what you need. You don’t want to write a DOS MBR (what openSUSE does) on Apple hardware. That’s silly and doesn’t work.

And finally , Linus Torvalds used openSUSE for a while on his MacBook. If he got it installed … you might get it installed too … or maybe not. lol!
(Sorry, I’m kidding. I just mean that it’s possible).

Thank you both for replying. Also both with very helpful information. From what please_try_again told me, I think i might try to dual boot it, since if that works I would have confidence in doing on my new Mac Mini. So, i have downloaded the rEFIT .dmg, not installed it yet though. So what would be the best source for the .iso? Live DVD, flash drive, just leave it on the hard drive, etc?

Oh, and I did try both OpenSUSE and Ubuntu installs with Live DVDs burned at slowest speed and verified during burn. I read in one forum that that often fixed the no repository problem. Still the same thing. I didn’t do the media verify, so I’ll have to do that. If i manage to get it installed, solo or dual boot, I will be sure to post a how-to immediately!

One last thing before i continue with rEFIT: here was the initial Patition Inspector: *** Report for internal hard disk ***

Current GPT partition table:

Start LBA End LBA Type

1 40 409639 EFI System (FAT)
2 409640 195109383 Mac OS X HFS+

Current MBR partition table:

A Start LBA End LBA Type

1 1 409639 ee EFI Protective
2 * 409640 195109383 af Mac OS X HFS+

MBR contents:
Boot Code: Unknown, but bootable

Partition at LBA 40:
Boot Code: None (Non-system disk message)
File System: FAT32
Listed in GPT as partition 1, type EFI System (FAT)

Partition at LBA 409640:
Boot Code: None
File System: HFS Extended (HFS+)
Listed in GPT as partition 2, type Mac OS X HFS+
Listed in MBR as partition 2, type af Mac OS X HFS+, active

so with that, do i just make one more partition in disk utility?

Yes. You’re limited to 4 partitions when you used hybrid MBR. Thus you can only create 2 partitions with Leopard/Snow Leopard and only 1 with Lion ( http://forums.opensuse.org/english/get-technical-help-here/how-faq-forums/unreviewed-how-faq/473532-upgrading-lion-osx-opensuse-dualboot-using-refit-hybrid-mbr.html). You’ll use a swap file instead of a swap partition under Linux. It works fine.

Last time someone succeeded, I asked him to write a howto. See this thread: http://forums.opensuse.org/english/get-technical-help-here/how-faq-forums/unreviewed-how-faq/464065-triple-booting-mac-os-x-6-opensuse-windows-xp-macbook-pro-7-1-a.html. It also includes some links to other threads with valuable info. It’s about triple booting, but dual-booting is even easier.

With this setup, you can use either live CD or install DVD, since you’re performing a legacy installation. Remember NOT to write anything in MBR during Linux setup, neither Grub nor generic boot code. It’s the only really tricky part because you have to click 3 times to reach the dialog where you can uncheck this stupid (hidden) default option (more precisely it is - or not - helpful for Windows users only). I have posted pictures which show how to disable this option hundreds of times. You’ll find some if you search the forum. (I don’t have time to look right now).

Alright the howto looks great, but I have hit a major roadblock early on. As with earlier, macbook still spits out any live dvds i put in, but i do have a firewire external drive. So, I followed the steps and got to the option boot step, which i think is step 8, but no matter which live dvd i put in, i get the message “missing operating system” any ideas?

Have a look at this post: http://forums.opensuse.org/english/get-technical-help-here/install-boot-login/444947-installing-opensuse-11-3-macbook-pro.html#post2410667

Maybe that’s the problem. I still don’t know which kind of setup the MacBook is running from DVD - when you don’t use rEFIT and BIOS emulation. I read that in oder to install Windows in UEFI mode, people had to completely remove the MBR setup from Windows install DVD and burn a new DVD…It sounds like a hacker job. We should do the same with Linux: create a boot disk that will boot ONLY in UEFI mode and just remove the legacy Grub setup. Linux installation DVDs (actually not just Linux) have a lot of problems with the firmware of modern computers (not only from Apple). In 99% of the cases, the DVD will boot in BIOS compatibility mode and the setup will create a MBR - whether or not it is appropriate (except Fedora, which I read creates a GPT by default - even on legacy BIOS machines - , but I haven’t tested it so far.)

Maybe you can put the net.iso on a bootable USB stick (Don’t ask me how, but some people here will know) and perform a net install. It looks like it could work IMO.

  • I don’t have Macbooks, I only have iMacs and never had this problem with the CD/DVD drive.

hi there… i recently got 12.1 running on my macbook 7,1 and have kept some relatively decent notes for install and postinstall configuration. i’d be happy to help if you’re still hitting roadblocks?