not booting into GUI - I messed up something

I was removing things installed with ‘dkms’, and now this laptop boots to terminal mode instead of into the GUI.
It is also not booting to user auto login. I can login, enter password and then type ‘startx’ to get back to the GUI

These are what I was removing in YaST from the bottom up.
I pretty sure it was the gcc that cause this but not sure, but what ever it was caused a reboot, and that is when it stopped at the terminal input.

Downloading fipscheck (download size 18.4 KiB)Downloading libasan4 (download size 355 KiB)
Downloading libatomic1 (download size 20.5 KiB)
Downloading libcilkrts5 (download size 58.2 KiB)
Downloading libitm1 (download size 39 KiB)
Downloading liblsan0 (download size 139 KiB)
Downloading libmpx2 (download size 19.1 KiB)
Downloading libmpxwrappers2 (download size 17.8 KiB)
Downloading libtsan0 (download size 285.3 KiB)
Downloading libubsan0 (download size 131.5 KiB)
Downloading linux-glibc-devel (download size 1.30 MiB)
Downloading libfipscheck1 (download size 15.4 KiB)
Downloading glibc-devel (download size 751.2 KiB)
Downloading zlib-devel (download size 109 KiB)
Downloading gcc7 (download size 19.70 MiB)
Downloading gcc (download size 10 KiB)
Downloading kernel-macros (download size 5.21 MiB)
Downloading mozilla-nss-tools (download size 412.5 KiB)
Downloading libelf-devel (download size 727 KiB)
Downloading kernel-devel (download size 17.00 MiB)
Downloading kernel-default-devel (download size 8.09 MiB)
Downloading pesign-obs-integration (download size 35.8 KiB)
Downloading kernel-syms (download size 5.20 MiB)
Downloading dkms (download size 75.4 KiB)

I have since, put them back in, but no luck booting to the GUI

To see if something is up with this thread.

I posted an answer I’d hate to have to recreate…

Login and test with


If that works, then modify the Unit file

Fix options

zypper dup

DVD repair followed by update


unknown operation

Where is the ‘’ Unit file?

zypper dup just updated Chrome, and added a few other things I didn’t capture.
Still boots to the login prompt for a terminal response.

I found some more systemctl commands for this in this thread;

none of them got me back to a GUI boot.
I don’t know what I did, but am beginning to think about sticking the USB stick back in and doing another upgrade!

So what was the output…??? It helps :wink:

systemctl get-default

If it’s multi-user, then you need to set it to the graphical target;

systemctl set-default graphical
systemctl reboot

Tsu2 might have meant systemctl isolate If it doesn’t work, susepaste /var/log/Xorg.0.log so we can look for clues. Clues might also be found by output from ‘journalctl -b | grep ailed’.


Is NVIDIA involved, the hard way installed with --dkms option?
For dkms you’d have to enable and start the dkms.service.
Any backups of /etc ?

EDIT: Just wondering, why would you remove stuff? If you want to experiment, and rollback to stable … btrfs is your friend :slight_smile:

No, my wife’s laptop only has the onboard intel graphics, and it is not nVidia. And nothing in the list in my OP indicates nVidia.
I wish I had known about that dkms.service thing needing to be started. May have saved this headache.
And AFAIK, no /etc backups.

Short story longer, I was removing the dkms service and all that was installed with it(individually because they don’t come out when removing dkms).
And I apparently screwed up something, don’t know what!

I had it there for her WiFi dongle(I have that in another thread in Wireless section), but it didn’t update with the next kernel like I thought it would/should.
I got user Sauerland’s repo, and installed the WiFi driver for the dongle from it.

I will look to see if the /var/log/Xorg.0.log file is still there from when I fubar’d it. I didn’t make a copy.
I think it keeps a backup, but the machine has been started several times since the I did another upgrade.

It was easier for me to just grab the install USB stick and do an upgrade, than to beat my head against a wall I didn’t know how to get around.

I still would like to get rid of all that heavy duty stuff that came in with dkms without another problem like this one.

output was

Tried those and still got the terminal login prompt, no GUI.

At any rate, I put the USB stick in and did an upgrade. So far that has taken care of the problem.

I figured that was Tsu2’s meaning after doing some reading in that other post I found. It didn’t work either.
If the files contain information from before the ‘upgrade’ I will put them in susepaste. I would like to know what I did wrong!

So it’s not a GPU issue, rather a missing software issue. You might check yast > System > Services, It should state ‘graphical target’, If it doesn’t set it. Another thing might be to force a reinstall of you DE

No, it was always a ‘user’ problem. It was something I did in YaST while trying to remove the list of files in my OP above that were put in with ‘dkms’.
I will likely never know what I did.

I don’t think so, after issuing the ‘startx’ command everything was there.

I did that in ncurses YaST and it still would not boot into the users graphical interface. It just kept on stopping at the Login prompt like it was multi-user, but it wasn’t.

I looked at finding out how to do that and couldn’t. As I stated earlier, it was just easier for me to put in the USB stick and do an ‘upgrade’.