Not any launcher can be pinned to icons-only taskbar


I’m running up-to-dated tumbleweed with KDE environment.
Sometimes I need aplications which not available in the repo. And usually I (it’s abstract sequence)

cd ~/Downloads
tar -xf app-arch.tar ./app/
mv app ~/.app

So I have ~/.app/bin/smth-app executable.

I want to run this executable with additional options, so I go to KDE Menu Editor (right click on main menu → Edit applications) and create new menu item there, specifying /home/user/.app/bin/smth-app -opt1 --option-2 as command. It’s appears in main menu, I can add it to favorites, when I click on it, options are applying, all goes fine.

Problem is that I cannot pin it to my icons-only taskbar: in main menu item’s (just created one) context menu this action avaiable but has no effect. Same with taskbar item, which normally appears, when I launch it from main menu, but option “pin on taskbar” has no effect.

What should I try? Maybe I should show some logs or configs?

P.S. Before post it, I’ve tried this as another user, and faced same problems.

Try to crate a icon with .desktop extension in usr/share/applications

Thank you. I’ve made it at two machines: desktop at work and personal laptop (both with Tumbleweed). It seems works now, but I wonder what exact action was necessary.
If someone faced with similar problem I recommend first create .desktop for running your app without additional options, then pin it to taskbar and last — add execution options you need.
I still have uncomfortable feeling like you did something but you don’t know how…

The .desktop file should be in ~/.local/share/applications, since it’s owned by the user ( app is also in the user’s homedir ).