Not allowed to change image.

I installed OpenSUSE 11.2-KDE about 2 weeks ago, and have been pretty satisfied with it so far.:slight_smile:
Apart from one niggling little problem.>:(
When I went to the ‘Password and User Account’ page (Configure Desktop>About Me) and tried to change from the default image to something more personal, I got a message box saying “Your administrator has disallowed changing your image.” However, on the same page I was allowed to enter personal details and could, if I wished, have changed my password.
I logged in as root to see if I could change it from there, but I got the same message. As this is a single-user machine, where I am effectively root/administrator, it would appear I am banning myself from changing my image. So far, I’ve been allowed to change anything else.
Would be grateful for anyone’s help.

There’s a bugreport on this, see → here. The fix provided there worked for me:

Launch systemsettings as root:

kdesu systemsettings

In the second tab choose to configure the ‘Login Manager’ and switch to the ‘Users’-tab, then change ‘User Image Source’ to ‘User, system’ (instead of ‘System’).

But please, in whatever case; DO NOT LOG IN AS ROOT!

SDB:Login as root - openSUSE

…As this is a single-user machine, where I am effectively root/administrator, …

Try to get used to the fact that you as a user and you as an administrator are two very different roles. Make a deep divide between them. there should be no difference in behaviour if you as a user are one of twenty other users, or if you are the only one.

Whe you think about this it must be clear that changing the login page is not in the domain of the user (because he is not even loged in at that moment the login page is displayed by the system), but something in the domain of root, it simply is not ‘your’ picture. Your password and other personal data is of course your own and you may change it.

The fact that the configuration tools do not let you do this as root is an omission at least and gropiuskalle gave you a solution.

Many thanks gropiuskalle. The guy on the bugzilla site had the exact same problem and tried the exact same ways to fix it.:slight_smile:
Thankfully I tried the fix suggested in Comments #5 and #18 and everything’s working perfectly now. Once again, many thanks.

hcw, you obviously misunderstand the situation.
I was talking about MY computer, paid for with MY money. I certainly would never mess about with anyone else’s computer and resent the implication that I would.

I do not think I misunderstood you:

  1. I have no doubt you (as an individual) owns the system.
  2. I have no doubt that the owner may decide that he wants a different picture on the login page.
  3. What I try to tell you is that the owner for this goes to the systems manager/administrator.
  4. What I try to tell you is that doing this is not in the domain of the any user (even if you think there is only one user that ever will access the system).
  5. I try to make it clear to you that these different roles. even when executed by the same person, are different, the Unix/Linux operating system is very much based on this principle.
  6. I try to make it clear that understanding where the divide is between these roles will help you in understanding why some things must be done by root and other by the user. When you would have understood this, you would not have tried to change the general available login page as an end-user, but as root. But I admit, that because of the system’s failure to honour any changing, you might have lost your confidence in understanding this.

And in the end, it is you and only you that has the right to use, brake or throw out of the window your system with or without any OS.