Not able to corectly connet to wireless network

Today, I ran the dup command to update the system. But then, it was not able to connect correctly to my Wifi. It seems connected but with no internet connection. Here is screenshot

Any help how to solve it please?
Thank you.

PS: I have Gnome and my wireless card is: Qualcomm Atheros

I’m in the exact same boat, I submitted a thread just now, but I will remember this one as well because it could be related.

Me too :slight_smile:
I hope we will get help soon ^^

Same here. I am able to ping my router (, and the command ip address yields valid ipv4 and ipv6 addresses.

But everything else is completely dead. I’m using Plasma 5 and just as Marouane87 describes with GNOME, the KDE network icon is light gray as well. It shows that I am connected (and I am, because I can access the router), but there is no traffic to (or from) the internet itself.

I also connected my smartphone to the notebook via USB tethering (which usually works fine), but I still have no internet – no matter if the smartphone itself gets its internet from WiFi or from mobile data. Same when connecting it to a LAN cable. So it might well be some broken security measure blocking internet access or something like that.

I lost connection to the internet instantly after updating. Here are the updated packages:

bundle-lang-common-de bundle-lang-common-en bundle-lang-gnome-de bundle-lang-gnome-en kernel-firmware perl-CGI timezone-java ucode-amd at-spi2-atk-common diffutils gdb hwinfo libglib-2_0-0 libinput-udev libinput10 libjansson4 libnma-data libproxy1 libsigc-2_0-0 openSUSE-release-ftp timezone polkit-default-privs diffutils-lang libharfbuzz0 libgthread-2_0-0 libgobject-2_0-0 libgmodule-2_0-0 libproxy1-networkmanager libproxy1-config-kde openSUSE-release libharfbuzz-icu0 libjavascriptcoregtk-4_0-18 libatspi0 libatk-1_0-0 libglibmm-2_4-1 libgio-2_0-0 gdk-pixbuf-query-loaders aaa_base libproxy1-pacrunner-webkit glib2-tools aaa_base-extras gio-branding-openSUSE libpackagekit-glib2-18 libnm0 libnm-util2 libgoa-1_0-0 libgiomm-2_4-1 libgdk_pixbuf-2_0-0 libcolord2 gsettings-desktop-schemas girepository-1_0 at-spi2-core accountsservice PackageKit-gtk3-module gtk3-data PackageKit-backend-zypp libnm-glib4 libnm-glib-vpn1 libgtkmm-2_4-1 glib-networking libgirepository-1_0-1 libatk-bridge-2_0-0 PackageKit libsoup-2_4-1 typelib-1_0-GdkPixbuf-2_0 typelib-1_0-Atk-1_0 python3-gobject python-gobject gtk3-tools at-spi2-atk-gtk2 typelib-1_0-PackageKitGlib-1_0 PackageKit-gstreamer-plugin PackageKit-branding-openSUSE libgssdp-1_0-3 libgdata22 NetworkManager-branding-openSUSE python3-gobject-cairo python-gobject-cairo adwaita-icon-theme libgupnp-1_0-4 NetworkManager libgtk-3-0 gtk3-immodule-amharic gtk3-immodule-inuktitut gtk3-immodule-thai gtk3-immodule-vietnamese typelib-1_0-Gtk-3_0 libwebkit2gtk-4_0-37 libnma0 gvfs gtk3-branding-openSUSE python3-gobject-Gdk python-gobject-Gdk webkit2gtk-4_0-injected-bundles NetworkManager-vpnc NetworkManager-pptp gvfs-backends libgoa-backend-1_0-1 gvfs-backend-samba gnome-online-accounts gvfs-fuse gvfs-backend-afc

(I pretty much only have the default repos enabled, plus the packman codecs.)

Same here.

After upgrading Tumbleweed, can connect to internet.
Can not even connect to the router.
I see the router/network, but can not connect anymore

Put your Router IP to /etc/resolv.conf:

nameserver is my Router IP.

My router IP is already in resolv.conf
Still can not connect…

That actually did the job for me, I’m connected to the internet again. Thank you!

So, could you explain what was going on there? Did the update trash some important config files?

EDIT: To other users struggling with the problem, I did reboot after changing the resolv.conf file.

(Got my profiles confused after logging in on my openSUSE machine, sorry – I posted as SirErichBikendom before.)

Adding the ‘nameserver’ line to my /etc/resolv.conf file solved the issue for me as well. Strange that it so randomly works now… I’m also curious why that happened and how to anticipate that in the future.

Correction, it did work, network is back
many thanks!

Adding “nameserver” to my /etc/resolv.conf also solved the issue. Only had to restart the NetworkManager.

I’ll state that it ain’t cool this thing broke. Had I not had access to another computer I most likely would not have been able to solve this issue quickly.

Thank you so much for your quick help - amazing how fast :slight_smile:

I had the same issue here, but strangely the Tor Browser was still able to connect to the internet. Dunno if that fact might be interesting to anyone, if not just ignore it.

This solution isn’t working for me. I tried both and in /etc/resolv.conf and my browser said “server dns address could not be found”. Also I’m still getting “ping: socket: Permission denied”.

Am I missing some small detail?

I’m connected both wired and wireless and I have ip addresses for both connections but unable to get out on the internet. NetworkManager isn’t showing any errors.

Well, as soon as I posted above, I decided to delete /etc/resolv.conf and reboot. I examined the file and it had changed, with many more commented lines and instructions. The nameserver was and now my internet is working again.

I decided the easiest path was to just delete my /etc/resolv.conf file and reboot. After this, everything was working again. Seems the system created a new /etc/resolv.conf file for me. It looks like it gets the info from the /etc/resolv.conf.netconfig file. Thank you to everyone who pointed me in the right direction to fix this. I wouldn’t have been able to solve this otherwise! Thank You!

This trick also works for me. When i updated tumbleweed my name-server didnot work. rm etc/resolv.conf file and a reboot works Thanks

I’m still having some odd behavior after the update but my internet is still working. My NetworkManager icon in the panel is grayed out with an orange question mark beside it, but if I click on it, it shows my wireless adapter is connected.

Anyone else getting anything like this?

Dear pilotgi,
I’m experiencing the exact same issue. I can connect to my network (to my router) but I only see the grey WiFi symbol with an orange/yellow question mark. I am offline and can not connect to the internet.

I just installed Tumbleweed last week after having used Ubuntu for the last 6 years and had the fear that I broke something by being stupid and running zipper -dup, but apparently this issue applies to more users.
I tried to follow the advice, suggesting to edit or remove /etc/resolv.conf, but it did not work for me or I did it wrong. I would very much appreciate, if a possible solution could be explained, such that a newbie like me can follow the steps.


After aplying Tumbleweed update last sunday september the 25th on my Tumbleweed laptop with Plasma 5, I have the same behaviour: a message that wifi was connected, but a grayed out wifi-icon with a question mark, and no connection to the internet or my network. Both wireless and wired for that matter (also a questionmark): no response at all on


And I had to give the wifi password over and over again. However, after editing /etc/resolv.conf as described above my internet works again, both wired and wireless.
Odly enough, the network icon is not properly refreshed: the wifi - icon was still gray with an orange question mark, while connected. And after plugging in the network cable and then plugging it out, the icon for wired network keeps sitting in the system tray. When hovering with the mouse over it, it says “wifi connected.”

But hack, it works. :sarcastic: