Not able to connect to wifi-access point

In

https://forums.opensuse.org/showthread.php/523846-Broadcom-BCM4352/page4

(which I shouldn’t have used, since the problem is not with Tumbleweed, as as this thread, but with Leap 15.1),
I was advised to install broadcom-wl and broadcom-wl-kmp-default packages to get the ASUS PCE-AC56 wordking with Leap 15.1.

A good advice, because now the card is seen, and the hardware sees the wifi-networks available in the environment.

But when I enter the credentials for the wifi-point I want to use (the wifi-point as such is detected correctly), it is some seconds apparently trying to connect to the access point, but then keeps asking for the WPA2 passwd. The passwd is correct, our mobile phones connect to the same access point with the same password, and I checked it in the router settings.

The network is managed by Networkmanager. The settings for this wifi-connection gives all users access to the network, and the WPA2-key is given there too.

hwinfo --netcard says

18: PCI 300.0: 0282 WLAN controller                             
  [Created at pci.386]
  Unique ID: y9sn.fkUtWxV49cB
  Parent ID: gZD2.Gxy18Qr5+gA
  SysFS ID: /devices/pci0000:00/0000:00:0b.0/0000:03:00.0
  SysFS BusID: 0000:03:00.0
  Hardware Class: network
  Model: "Broadcom BCM4352 802.11ac Wireless Network Adapter"
  Vendor: pci 0x14e4 "Broadcom"
  Device: pci 0x43b1 "BCM4352 802.11ac Wireless Network Adapter"
  SubVendor: pci 0x1043 "ASUSTeK Computer Inc."
  SubDevice: pci 0x85ba 
  Revision: 0x03
  Driver: "wl"
  Driver Modules: "wl"
  Device File: wlan0
  Features: WLAN
  Memory Range: 0xdfff8000-0xdfffffff (rw,non-prefetchable)
  Memory Range: 0xdfc00000-0xdfdfffff (rw,non-prefetchable)
  IRQ: 19 (30359 events)
  HW Address: a2:5f:9c:c2:7b:4d
  Permanent HW Address: 04:d9:f5:7a:cb:d0
  Link detected: yes
  WLAN channels: 1 2 3 4 5 6 7 8 9 10 11 12 13 14 36 38 40 42 44 46 48 52 54 56 58 60 62 64 100 102 104 106
  WLAN frequencies: 2.412 2.417 2.422 2.427 2.432 2.437 2.442 2.447 2.452 2.457 2.462 2.467 2.472 2.484 5.18 5.19 5.2 5.21 5.22 5.23 5.24 5.26 5.27 5.28 5.29 5.3 5.31 5.32 5.5 5.51 5.52 5.53
  WLAN encryption modes: WEP40 WEP104 TKIP CCMP
  WLAN authentication modes: open sharedkey wpa-psk wpa-eap
  Module Alias: "pci:v000014E4d000043B1sv00001043sd000085BAbc02sc80i00"
  Driver Info #0:
    Driver Status: bcma is not active
    Driver Activation Cmd: "modprobe bcma"
  Driver Info #1:
    Driver Status: wl is active
    Driver Activation Cmd: "modprobe wl"
  Config Status: cfg=no, avail=yes, need=no, active=unknown
  Attached to: #13 (PCI bridge)

Modprobe bcma doesn’t change anything, and is revoked on reboot.

ip address says

3: wlan0: <NO-CARRIER,BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state DORMANT group default qlen 1000
    link/ether aa:e8:50:f5:4f:ee brd ff:ff:ff:ff:ff:ff

and in journalctl these messages show after trying to connect:

mrt 15 17:08:30 linux-vffq kernel: WARNING: CPU: 0 PID: 545 at ../net/wireless/sme.c:948 cfg80211_roamed+0x23e/0x270 [cfg80211]
mrt 15 17:08:30 linux-vffq kernel: Modules linked in: fuse xt_tcpudp ip6t_rpfilter ip6t_REJECT ipt_REJECT xt_conntrack ip_set nfnetlink ebtable_nat ebtable_broute br_netfilter bridge stp llc af_packet ip6table_nat nf_conntra>
mrt 15 17:08:30 linux-vffq kernel:  soundcore btrfs xor zstd_decompress zstd_compress xxhash raid6_pq sr_mod cdrom hid_generic usbhid ata_generic nouveau video mxm_wmi wmi i2c_algo_bit drm_kms_helper syscopyarea sysfillrect >
mrt 15 17:08:30 linux-vffq kernel: CPU: 0 PID: 545 Comm: wl_event_handle Tainted: P        W  O     4.12.14-lp151.28.36-default #1 openSUSE Leap 15.1
mrt 15 17:08:30 linux-vffq kernel: Hardware name: System manufacturer System Product Name/M2N68-AM Plus, BIOS 1804    08/23/2010
mrt 15 17:08:30 linux-vffq kernel: task: ffff8801376ea200 task.stack: ffffc90000b3c000
mrt 15 17:08:30 linux-vffq kernel: RIP: 0010:cfg80211_roamed+0x23e/0x270 [cfg80211]
mrt 15 17:08:30 linux-vffq kernel: RSP: 0018:ffffc90000b3fde8 EFLAGS: 00010246
mrt 15 17:08:30 linux-vffq kernel: RAX: 0000000000000000 RBX: ffffc90000b3fe20 RCX: 0000000000000012
mrt 15 17:08:30 linux-vffq kernel: RDX: 0000000000000002 RSI: 00000000fffffe01 RDI: ffffffffa06d0bf7
mrt 15 17:08:30 linux-vffq kernel: RBP: ffffc90000b3fe10 R08: 0000000000000000 R09: 0000000000000000
mrt 15 17:08:30 linux-vffq kernel: R10: ffffc90000b3fd50 R11: 0000000000000064 R12: 00000000014000c0
mrt 15 17:08:30 linux-vffq kernel: R13: ffff880139d4d000 R14: ffff880137054300 R15: dead000000000100
mrt 15 17:08:30 linux-vffq kernel: FS:  0000000000000000(0000) GS:ffff88013fc00000(0000) knlGS:0000000000000000
mrt 15 17:08:30 linux-vffq kernel: CS:  0010 DS: 0000 ES: 0000 CR0: 0000000080050033
mrt 15 17:08:30 linux-vffq kernel: CR2: 00007fd706b374c4 CR3: 000000008546c000 CR4: 00000000000006f0
mrt 15 17:08:30 linux-vffq kernel: Call Trace:
mrt 15 17:08:30 linux-vffq kernel:  wl_bss_roaming_done.isra.26+0xb5/0x100 [wl]
mrt 15 17:08:30 linux-vffq kernel:  wl_notify_roaming_status+0x30/0x70 [wl]
mrt 15 17:08:30 linux-vffq kernel:  ? down_interruptible+0x2d/0x50
mrt 15 17:08:30 linux-vffq kernel:  wl_event_handler+0x73/0x1e0 [wl]
mrt 15 17:08:30 linux-vffq kernel:  ? wl_notify_scan_status+0x300/0x300 [wl]
mrt 15 17:08:30 linux-vffq kernel:  kthread+0x10d/0x130
mrt 15 17:08:30 linux-vffq kernel:  ? kthread_create_worker_on_cpu+0x50/0x50
mrt 15 17:08:30 linux-vffq kernel:  ret_from_fork+0x22/0x40
mrt 15 17:08:30 linux-vffq kernel: Code: 8d 4d 70 45 0f b6 85 90 00 00 00 45 8b 8d a8 00 00 00 4c 89 f7 48 8b 36 e8 10 a4 fd ff 48 85 c0 48 89 43 08 5a 0f 85 f9 fd ff ff <0f> 0b 48 8d 65 d8 5b 41 5c 41 5d 41 5e 41 5f 5d c3 4>
mrt 15 17:08:30 linux-vffq kernel: --- end trace 63e68e12822c9ad6 ]---

Any one with an idea how I can establish the connection? Preferable without having to enter the root passwd…

Many thanks in advance!

Post:

zypper se -si broadcom
uname -a

I’m not at the system (which is my father-in-law’s) now, but I’m not sure what the info you apparently ask for adds to what I reported already?

zypper se -si broadcom

would show the broadcom packages installed - these are broadcom-wl and broadcom-wl-kmp-default, which per default are from Packman

uname -a

[/QUOTE]

Again, not at the system now, but it is x86_64, latest Leap 15.1 kernel.

Post it to see if it match.

zypper se -si broadcom gives

S  | Naam                    | Type   |  Versie                                        | Arch   | Opslagruimte 
---+-------------------------+--------+-----------------------------------------------+--------+------------------- 
i+ | broadcom-wl             | pakket |  6.30.223.271-pm151.11.68                      | x86_64 | Packman Repository 
i  | broadcom-wl-kmp-default | pakket |  6.30.223.271_k4.12.14_lp151.28.40-pm151.11.68 | x86_64 | Packman Repository  

uname -a gives

Linux linux-vffq 4.12.14-lp151.28.36-default #1 SMP Fri Dec 6 13:50:27  UTC 2019 (8f4a495) x86_64 x86_64 x86_64 GNU/Linux 

I’m still somewhat puzzled by your questions, because the wifi-hardware is seen by the system, and all wifi networks(including the one I want to connect to) are visible by the wifi hardware.
So I would say this is not a driver problem, but of configuration of the connection with the desired wifi network.

But maybe I’m wrong, and is it my lack of understanding the issue?

Thanks for your reaction, anyway!

You are running an older kernel as the broadcom-wl is build for…

Ah, now I see what your questions were about…

The kernel comes from the zypper dup from 15.0 to 15.1, and the broadcom drivers are from the Packman 15.1 repo, and are presented by Yast as part of the 15.1 distro…
I can do a zypper up, to see if the kernal then matches the broadcom build.

But do you think that that makes a difference here? After all, as I said, the hardware is seen by the system, and the wifi-hardware sees the wifi-access points in hte environment…

I 'll do a zypper up, and repport back.

Thanks again!

What do you mean by this?

YaST presents to you all repos you have in your repo list and that are enabled. No matter what the repo provider thinks they are for. And in fact the distributions is only four (4) repos: OSS, non-OSS and their Update ones (well, also the Debug and Source repos belong to the distro, but I guess you do not need them). All other repos, inclusdng Packman, are not official part of the distro.

This is what Yast presents me if I search for broadcom in the software manager. I didn’t add repos for the case we’re discussing right now, but it will be from some earlier version.

Did a zypper dup, and now the kernel versions match, I would say:

S  | Naam                    | Type   |  Versie                                        | Arch   | Opslagruimte 
---+-------------------------+--------+-----------------------------------------------+--------+------------------- 
i+ | broadcom-wl             | pakket |  6.30.223.271-pm151.11.68                      | x86_64 | Packman Repository 
i  | broadcom-wl-kmp-default | pakket |  6.30.223.271_k4.12.14_lp151.28.40-pm151.11.68 | x86_64 | Packman Repository 
ale@linux-vffq:~> uname -a 
Linux linux-vffq 4.12.14-lp151.28.40-default #1 SMP Fri Mar 6 13:48:15  UTC 2020 (f0f1262) x86_64 x86_64 x86_64 GNU/Lin

But, as I had expected, for the problem at hand it makes no difference, still the behaviour I explained in my OP.

Any ideas further?

Post:

ping -c1 8.8.8.8
systemctl status network.service

I added -I wlan0, because otherwise the ping is sent trough cabled Ethernet (that cabled connection is lost by hte end of March, that’s why it it rather urgent to have the wifi connection working by that time…).

ping -I wlan0 8.8.8.8 
ping: Warning: source address might be selected on device other than wlan0. 
PING 8.8.8.8 (8.8.8.8) from 192.168.2.2 wlan0: 56(84) bytes of data. 
^C 
--- 8.8.8.8 ping statistics --- 
13 packets transmitted, 0 received, 100% packet loss, time 12277ms 

No connection.

This looks not good to me:


systemctl status network.service 
● NetworkManager.service - Network Manager 
   Loaded: loaded (/usr/lib/systemd/system/NetworkManager.service;  enabled; vendor preset: disabled) 
  Drop-In: /usr/lib/systemd/system/NetworkManager.service.d 
           └─NetworkManager-ovs.conf 
   Active: active (running) since Mon 2020-03-16 14:54:38 CET; 1h 9min ago 
     Docs: man:NetworkManager(8) 
 Main PID: 879 (NetworkManager) 
    Tasks: 5 
   CGroup: /system.slice/NetworkManager.service 
           ├─ 879 /usr/sbin/NetworkManager --no-daemon 
           └─1325 /sbin/dhclient -d -q -sf /usr/lib/nm-dhcp-helper -pf  /var/run/dhclient-eth0.pid -lf  /var/lib/NetworkManager/dhclient-8192b5b6-a771-36f8-a183-eae70234b1e1-eth0.lease  -cf /var/lib/NetworkManager/dhclient-eth0> 

mrt 16 15:34:19 linux-vffq NetworkManager[879]: <info> [1584369259.3203]  device (wlan0): set-hw-addr: set MAC address to FE:98:EE:C2:9B:91 (scanning) 
mrt 16 15:39:34 linux-vffq NetworkManager[879]: <info> [1584369574.3220]  device (wlan0): set-hw-addr: set MAC address to F6:9B:EF:7B:5A:7F (scanning) 
mrt 16 15:44:49 linux-vffq NetworkManager[879]: <info> [1584369889.3193]  device (wlan0): set-hw-addr: set MAC address to 2E:7E:59:8F:08:2C (scanning) 
mrt 16 15:50:04 linux-vffq NetworkManager[879]: <info> [1584370204.3219]  device (wlan0): set-hw-addr: set MAC address to 0A:0A:0E:8F:34:99 (scanning) 
mrt 16 15:55:19 linux-vffq NetworkManager[879]: <info> [1584370519.3259]  device (wlan0): set-hw-addr: set MAC address to 82:07:58:63:A9:49 (scanning) 
mrt 16 16:00:34 linux-vffq NetworkManager[879]: <info> [1584370834.3189]  device (wlan0): set-hw-addr: set MAC address to D2:8A:F4:AA:8B:17 (scanning) 
mrt 16 16:00:34 linux-vffq NetworkManager[879]: <info> [1584370834.3238]  device (wlan0): supplicant interface state: disconnected -> disabled 
mrt 16 16:00:34 linux-vffq NetworkManager[879]: <info> [1584370834.3551]  device (wlan0): supplicant interface state: disabled -> disconnected 
mrt 16 16:00:36 linux-vffq NetworkManager[879]: <info> [1584370836.3557]  device (wlan0): supplicant interface state: disconnected -> inactive 
mrt 16 16:00:41 linux-vffq NetworkManager[879]: <info> [1584370841.3113]  device (wlan0): supplicant interface state: inactive -> disconnected 

Post as root:

systemctl list-unit-files --state=enabled

Is quite a list of course:

UNIT FILE                                  STATE  
btrfsmaintenance-refresh.path              enabled
ca-certificates.path                       enabled
cups.path                                  enabled
apparmor.service                           enabled
appstream-sync-cache.service               enabled
auditd.service                             enabled
autovt@.service                            enabled
avahi-daemon.service                       enabled
bluetooth.service                          enabled
bootmsg.service                            enabled
btrfsmaintenance-refresh.service           enabled
ca-certificates.service                    enabled
chronyd.service                            enabled
cron.service                               enabled
cups.service                               enabled
dbus-org.bluez.service                     enabled
dbus-org.fedoraproject.FirewallD1.service  enabled
dbus-org.freedesktop.Avahi.service         enabled
dbus-org.freedesktop.ModemManager1.service enabled
dbus-org.freedesktop.nm-dispatcher.service enabled
display-manager.service                    enabled
firewalld.service                          enabled
getty@.service                             enabled
haveged.service                            enabled
irqbalance.service                         enabled
iscsi.service                              enabled
kbdsettings.service                        enabled
klog.service                               enabled
lvm2-monitor.service                       enabled
mcelog.service                             enabled
ModemManager.service                       enabled
network.service                            enabled
NetworkManager-dispatcher.service          enabled
NetworkManager-wait-online.service         enabled
NetworkManager.service                     enabled
nscd.service                               enabled
postfix.service                            enabled
pullin-bcm43xx-firmware.service            enabled
purge-kernels.service                      enabled
rsyslog.service                            enabled
smartd.service                             enabled
syslog.service                             enabled
teamviewerd.service                        enabled
xdm.service                                enabled
YaST2-Firstboot.service                    enabled
YaST2-Second-Stage.service                 enabled
avahi-daemon.socket                        enabled
cups.socket                                enabled
dm-event.socket                            enabled
iscsid.socket                              enabled
lvm2-lvmetad.socket                        enabled
lvm2-lvmpolld.socket                       enabled
pcscd.socket                               enabled
remote-fs.target                           enabled
backup-rpmdb.timer                         enabled
backup-sysconfig.timer                     enabled
btrfs-balance.timer                        enabled
btrfs-scrub.timer                          enabled
check-battery.timer                        enabled
fstrim.timer                               enabled
logrotate.timer                            enabled
mandb.timer                                enabled
snapper-cleanup.timer                      enabled
snapper-timeline.timer                     enabled

64 unit files listed.

As User:

nmcli
nmcli device show

nmcli:

eth0: connected to Wired connection 1
    "NVIDIA MCP61 Ethernet (M4N68T series motherboard)"
    ethernet (forcedeth), BC:AE:C5:AE:AE:C1, hw, mtu 1500
    ip4 default, ip6 default
    inet4 192.168.2.2/24
    route4 0.0.0.0/0
    route4 192.168.2.0/24
    inet6 2a02:a456:44f8:1:b2d7:3c31:5a68:c032/64
    inet6 2a02:a456:44f8:1:901e:1cea:f17e:f7a1/64
    inet6 fe80::c870:7b1d:b0e9:5fef/64
    route6 2a02:a456:44f8:1::/64
    route6 ::/0
    route6 ff00::/8
    route6 fe80::/64
    route6 fe80::/64

wlan0: disconnected
    "Broadcom Limited BCM4352 802.11ac Wireless Network Adapter"
    1 connection available
    wifi (wl), B6:81:D3:5C:76:08, hw, mtu 1500

lo: unmanaged
    "lo"
    loopback (unknown), 00:00:00:00:00:00, sw, mtu 65536

DNS configuration:
    servers: 192.168.2.254
    domains: home
    interface: eth0

    servers: fe80::ae64:62ff:fe6e:4049
    interface: eth0

Use "nmcli device show" to get complete information about known devices and
"nmcli connection show" to get an overview on active connection profiles.

Consult nmcli(1) and nmcli-examples(5) manual pages for complete usage details.

nmcli device show:

GENERAL.DEVICE:                         eth0
GENERAL.TYPE:                           ethernet
GENERAL.HWADDR:                         BC:AE:C5:AE:AE:C1
GENERAL.MTU:                            1500
GENERAL.STATE:                          100 (connected)
GENERAL.CONNECTION:                     Wired connection 1
GENERAL.CON-PATH:                       /org/freedesktop/NetworkManager/ActiveConnection/1
WIRED-PROPERTIES.CARRIER:               on
IP4.ADDRESS[1]:                         192.168.2.2/24
IP4.GATEWAY:                            192.168.2.254
IP4.ROUTE[1]:                           dst = 0.0.0.0/0, nh = 192.168.2.254, mt = 100
IP4.ROUTE[2]:                           dst = 192.168.2.0/24, nh = 0.0.0.0, mt = 100
IP4.DNS[1]:                             192.168.2.254
IP4.DOMAIN[1]:                          home
IP6.ADDRESS[1]:                         2a02:a456:44f8:1:b2d7:3c31:5a68:c032/64
IP6.ADDRESS[2]:                         2a02:a456:44f8:1:901e:1cea:f17e:f7a1/64
IP6.ADDRESS[3]:                         fe80::c870:7b1d:b0e9:5fef/64
IP6.GATEWAY:                            fe80::ae64:62ff:fe6e:4049
IP6.ROUTE[1]:                           dst = 2a02:a456:44f8:1::/64, nh = ::, mt = 100
IP6.ROUTE[2]:                           dst = ::/0, nh = fe80::ae64:62ff:fe6e:4049, mt = 100
IP6.ROUTE[3]:                           dst = ff00::/8, nh = ::, mt = 256, table=255
IP6.ROUTE[4]:                           dst = fe80::/64, nh = ::, mt = 256
IP6.ROUTE[5]:                           dst = fe80::/64, nh = ::, mt = 100
IP6.DNS[1]:                             fe80::ae64:62ff:fe6e:4049

GENERAL.DEVICE:                         wlan0
GENERAL.TYPE:                           wifi
GENERAL.HWADDR:                         B6:81:D3:5C:76:08
GENERAL.MTU:                            1500
GENERAL.STATE:                          30 (disconnected)
GENERAL.CONNECTION:                     --
GENERAL.CON-PATH:                       --

GENERAL.DEVICE:                         lo
GENERAL.TYPE:                           loopback
GENERAL.HWADDR:                         00:00:00:00:00:00
GENERAL.MTU:                            65536
GENERAL.STATE:                          10 (unmanaged)
GENERAL.CONNECTION:                     --
GENERAL.CON-PATH:                       --
IP4.ADDRESS[1]:                         127.0.0.1/8
IP4.GATEWAY:                            --
IP6.ADDRESS[1]:                         ::1/128
IP6.GATEWAY:                            --

Plug off Ethernet and configure wlan, then show us the same once more.

I will try to arrange that, but it will take some time: up till now I give the commands remote, using Teamviewer (I live in another town than my father-in-law). But if I disconnect Ethernet, off course there’s no connection to go that way.
Letting my father-in-law do the procedure is not a real possibility, him being far over eighty and not very computer savvy.

I’ll try to go there tomorrow. It would be nice it you then can react as quickly as you did today! Is there a time that is more/less convenient for you?

Thanks a lot so far!