Not able to configure the network card because the kernel device is not present

Hello;

From yast lan, I am getting the below message related to the network card which is given not configured:

Unable to configure the network card because the kernel device (eth0, wlan0) is not present. This is mostly caused by missing firmware (for wlan devices) .

I checked the Global Options → Network Setup Method and I found only two options to select: Wicked Service and Network Service Disabled (Only these two options).

By the way: IPv6 is enabled.

And the result of lspci -nnk is:

Ethernet controller [0200]: Intel Corporation Ethernet Connection (7) 1219-LM [8886:15bb] (rev 10)
Subsystem: Dell Devices [1028:885a]

The result of systemctl status network.service is:

.jpg

And and you see in the image:

eth0 no-device

Note: I do not have wireless card, the network card is wired (to be connected with the network cable).

What could be the reason for the problem?

Regards
Bilal

Hi
That should be using the e1000e driver, which based on you output isn’t shown…


/sbin/modinfo e1000e | grep 15BB

alias:          pci:v00008086d000015BBsv*sd*bc*sc*i*

uname -a
Linux T-KGLH3 4.4.180-102-default #1 SMP Mon Jun 17 13:11:23 UTC 2019 (7cfa20a) x86_64 x86_64 x86_64 GNU/Linux

cat /etc/os-release 
NAME="openSUSE Leap"
VERSION="42.3"
ID=opensuse
ID_LIKE="suse"
VERSION_ID="42.3"
PRETTY_NAME="openSUSE Leap 42.3"
ANSI_COLOR="0;32"
CPE_NAME="cpe:/o:opensuse:leap:42.3"
BUG_REPORT_URL="https://bugs.opensuse.org"
HOME_URL="https://www.opensuse.org/"

Can you see anything in the output from dmesg about the network card?

Are lights flashing on the ethernet port, is the ethernet cable ok?

If you try loading the module manually, what happens… does lspci output change, messages in dmesg?


modprobe e1000e

Thank you for your kindly reply.

Actually I tried to load the modprobe manually using modprobe e1000e and it shows messages and below image is showing the difference for the dmesg before typing modprobe e1000e and after:

http://ghayad.com/IMG-20190702-WA0043.jpg

The only thing is appearing (before type the modprobe and after type it) is the lspci -nnk which is showing the below:

Ethernet controller [0200]: Intel Corporation Ethernet Connection (7) 1219-LM [8886:15bb] (rev 10)

sbin/modinfo e1000e | grep 15B (there is not 15BB but there is 15B8) as you can see below (with the output for uname -a):

http://ghayad.com/IMG-20190702-WA0021.jpg

cat /etc/os-release:

http://ghayad.com/IMG-20190702-WA0022.jpg

Also same result when typed systemctl status network-service after I manually loaded the modprobe e1000e

And still the same problem when going to yast lan as you can see below:

http://ghayad.com/IMG-20190702-WA0036.jpg

Appreciate the kindly help.
Why after I applied modprobe e1000e, still no change in the yast lan?

Regards
Bilal

Hi
The system is not up to date, you need the later kernel (4.4.180-102-default) as indicated in my post…


/sbin/modinfo e1000e | grep 15B
alias:          pci:v00008086d000015BCsv*sd*bc*sc*i*
alias:          pci:v00008086d000015BBsv*sd*bc*sc*i*
alias:          pci:v00008086d000015BEsv*sd*bc*sc*i*
alias:          pci:v00008086d000015BDsv*sd*bc*sc*i*
alias:          pci:v00008086d000015B9sv*sd*bc*sc*i*
alias:          pci:v00008086d000015B8sv*sd*bc*sc*i*
alias:          pci:v00008086d000015B7sv*sd*bc*sc

Hello;

How to update the kernel as I do not have network card and can not connect the computer to the Internet.
Can I download it and move it by USB and copy it and then install it? How?

Regards
Bilal

Hi
Yes, you need to copy down the update repository to a USB device (or just the noarch and x86_64);

http://download.opensuse.org/update/leap/42.3/oss/

Add the directories as plain rpm repositories and update the system via zypper up.

Hi;

Yes, you need to copy down the update repository to a USB device (or just the noarch and x86_64);

http://download.opensuse.org/update/leap/42.3/oss/

Can u please explain?
You mean by update repository is the: openSUSE:Leap:42.3:Update.repo? Because this is only contains the below (and I do not know where to place it?)

[openSUSE_Leap_42.3_Update]
name=Online updates for openSUSE Leap:42.3 (standard)
type=rpm-md
baseurl=http://download.opensuse.org/update/leap/42.3/oss/
gpgcheck=1
gpgkey=http://download.opensuse.org/update/leap/42.3/oss/repodata/repomd.xml.key
enabled=1

or just the noarch and x86_64

There is not a way to download them? Because they are too much files, and not possible to download them one by one.

Add the directories as plain rpm repositories and update the system via zypper up.

Can u please explain for me how to add them as plain rpm?

The steps are not clear for me, can please help by giving me some details?

Regards
Bilal

Hi
If you run the following command on your system;


zypper se -si kernel

Then browse the repository x86_64 and norch directory and grab the corresponding latest rpms, likely kernel-default (4.4.180-102.1) and kernel-firmware (20170530-26.1)

In that case, you can just install those two rpms manually with zypper to start with as there may be other files needed, at least the zypper output will tell you what it needs.

On the target system, create a directory somewhere for the files (suggest a user location to make it easier to access), eg your home directory


mkdir -p ~/Updates

Then fire up YaST->Software Repositories and tab to the “Add”, arrow down to “Local Directory” press the space bar to select, then tab to Next. Give your repository a name, add the path to the directory with a trailing / (eg /home/user/Updates/) then select the ‘Plain RPM Directory’, tab to next and you should be good to go.

You can now place any rpm’s in this directory as required, as root run zypper ref and then you should be good to go running zypper up…

An alternative is to try to install only an updated driver, then update later when you have a network connection.

You can download just the NIC driver from the following page
https://downloadcenter.intel.com/download/26012/Intel-Network-Adapter-Gigabit-Base-Driver-for-FreeBSD-?product=82185

Then,
As described you should follow the instructions in the INSTALL file.
Or,
The following is an article describing installing on CentOS, the instructions should work for openSUSE if you substitute our zypper for the CentOS yum
https://blog.exxactcorp.com/how-to-installconfigure-intel-i219-network-adapter-in-centos-6/

A general search on your NIC and e1000 returns a number of performance issues people have had, but I don’t see any where a driver wasn’t installed.

HTH,
TSU

:wink:
thank you. that was a very useful piece of information. that really helped me.