not able to access secure web sites https

Hi, I am only having problem in accessing all the secure web sites like the following:
https://internet-banking.dbs.com.sg/IB/Welcome

Firefox 3.0.7 just take forever and never allow me to login.

I have install OpenSuSe 11.1 (64 bits version) with Gnome.
Also tried OSS 11.1 (both 32 and 64 bits version) with KDE4.0, KDE4.2 but still encountered the same problem.

I looked up the past posting in this forum, but it didn’t help.

My machine is dual booted with Window XP, and there is no problem in accessing https from WinXP at all.

I am using Microstar mother board K9A2GM-FIH with AMD Phenom quad cores processor.

Thanks in advance.

i do not know if this will help you…but, i live in Denmark and a
linux using friend was having huge problems entering her netbank…i
worked one day then suddenly didn’t…

however, she now has no problems because we followed the advice found
in a local linux users group (you might ought to check with your local
group, see http://www.linux.org/groups/hongkong.html)…

i THINK the below might help since i note that both banks are using an
“IBM_HTTP_SERVER”…

oh, and don’t forget to follow your nose: on the opening page (at the
URL you gave) i see a link to “Login Assistance” which pops up a new
window where i find WORDS to read like “I encounter problems when I
try to log in. What should I do?”…and in that section that says “If
the message “Applet DBSlogin started” does not appear after login a
few times, please click here to check your computer configurations
before attempting again”

where i see that you MUST have both Java and Java Script
activated…and, of course (as normal) if you click to learn the
supported browser and operating system, you should not be surprised to
see that Linux is NOT a listed operating system…i’d advise you to
call your bank and kindly ask them to please begin supporting
Linux…(by the way, that site loads VERY slowly here also)

BUT, maybe the below works for you too:

FIRST: (this may or may NOT be required for you bank…if you wish
skip it for now and see if your current Java works with your bank)
Roll back from Sun Java 1_6_0 to Sun Java 1_5_0.something in YaST,
make sure you install the java-1_5_0-sun AND the
java-1_5_0-sun-plugin, as far as i know those are the only two required…

SECOND: Run this checklist
[danish bank info removed and replaced with your bank’s info]:

  1. Delete DBS cookies

Menu > Edit > Preferences > Privacy > Show Cookies

In search box type “dbs.com.sg” (without the quotes)

Press “Remove Cookie” button (at bottom) as required to delete all

  1. Clean Firefox’s internal cache

Menu > Edit > Preferences > Advanced > Network

Press “Clear Now” button next to “Use up to xx MB space for the cache”

  1. Disable NoScript Add-on in Firefox (if you have it installed)

Menu > Tools > Add-ons > NoScript > Disable

  1. Shutdown Firefox

  2. Clean Java cache

Open Konqueror

Find folder named .java in your /home directory

Single right click on .java directory, and select “Move to trash”

  1. Start Firefox

  2. Try logging in again

Expect to have to do all of the above numbered items EACH time you
want to use net banking. However, you may try:

a. Disable NoScript (if you normally use it, if not skip to c.)

b. Shutdown/restart Firefox

c. Logon to net banking.

Maybe it will work, maybe not. If not, go through all seven steps–in
order.

good luck, and have lots of fun.


MultiplePersonality

Thank you Multi Personality for the detail instruction. I do not know how to roll back to the older Java version. I tried second step but it still did not work.

Anyway, it is not a big deal without accessing to the https sites.

Best regards.

spfoo wrote:
> Thank you Multi Personality for the detail instruction. I do not know
> how to roll back to the older Java version.

welcome, but to roll back you just UNinstall one and install the
other, this way

-open YaST
-search on Java
-find the version 6 java bits that are checked and
-check the SAME v5 parts for installation and then
-right click on the v6 parts and select them to UNinstall…

> I tried second step but it
> still did not work.

well, if the bank’s page will NOT work with version 6 of Java, as is
the case here, then OF COURSE the second step failed…

> Anyway, it is not a big deal without accessing to the https sites.

THANK YOU! if is it not a big enough deal for you to really wanna fix
it, then please do NOT ask.


solo

Hi,
well i got same issue then i have called dbs bank customer care then they said to download the Java 1.6 update 13 for windows(if ur OS is windows XP)
after installed i am able to access net banking.

hope it wil work for u…

ANwy

Always could create separate accounts from Windows98 and restrict access of others.Caveat though, you can not keep this secret. Your IP will show up in searches, and your provider will have records of where you have been. So better make it adult XXX sites that you go to.


business web hosting

I can’t access https sites either. I’m really not sure why. For example, my web browser shows an internal communication error each time I try to log-in to MySpace. Does anyone have any suggestions?

epicurious wrote:
> I can’t access https sites either. I’m really not sure why. For example,
> my web browser shows an internal communication error each time I try to
> log-in to MySpace. Does anyone have any suggestions?

what have you done so far to try to fix the problem?

do you have the same problem when using Firefox, Konqueror, Opera or
other browser??

have you turned off IPv6 support in the OS and in Firefox?


deConficter

Well, I’m not sure what the problem is. That’s why I was asking for suggestions from people who may have had the same problem. Constant tinkering could mean that I create another problem. I did turn off the firewall when I thought that WICD was the problem - but WICD is working absolutely fine [and is a good program, by the way].

do you have the same problem when using Firefox, Konqueror, Opera or
other browser??

I’m only using Opera here. I’m using Fluxbox so don’t have Konqueror. It’s on my work laptop and I’m keeping the number of apps to a minimum, so there won’t be the installing of several browsers on it. Suffice to say that on the same network my desktop - which is what I’m using now so I can log-in to reply - connects to https sites fine.

have you turned off IPv6 support in the OS…]?

IPv6 was set to off when I installed the system. I always do that.

So I’m a bit stuck.

Any suggestions?

Forgot to say - My desktop also uses Opera, same version, same settings. It has FF and IE4Linux and they’re both fine. It’s definitely not the browser.

> my web browser shows an internal communication error each time I try to
> log-in to MySpace. Does anyone have any suggestions?

while waiting for someone who has also had your exact problem, and
fixed it, to chime in with the magic bullet:

i have a suggestion: post the full text of that error back to this forum…

also: launch your Opera from a terminal session, then try to connect
to an https page/site, and if there is a message in the terminal,
paste that back to here too…

next: is it true that using your laptop you can’t connect to ANY
https, or is it just a few? MySpace and what else, for example?

in your Sat, 11 Apr 2009 02:26:01 MDT you wrote: “My desktop also uses
Opera, same version, same settings. It has FF and IE4Linux and they’re
both fine. It’s definitely not the browser.”

have you actually carefully compared all browser settings?
are both browsers running in the same OS/version with exact security
and network settings?

if you type about:config into the address bar, hit enter you will be
able to see the several hundred (or thousands) of Opera’s usually
hidden settings…are the two browsers using the same version of
(for example) java; and are all the (for example) network settings and
security preferences the same?

some browsers have a user controlled level of security paranoia…some
of which get set the first time you encounter a certain situation
(like, it might say something like “You are entering a secure site, do
you want to blah blah blah…” are you CERTAIN you answered any/all of
those questions absolutely the same, with both machines?

does the laptop have more than one connection profile (one set for use
at home, another at the office, and a third/more for on the road)…are
https connections blocked no matter where/which environment you try to
connect from?


Andy Sipowicz

[QUOTE=Andy Sipowicz;1971439]> my web browser shows an internal communication error each time I try to
> log-in to MySpace. Does anyone have any suggestions?

while waiting for someone who has also had your exact problem, and
fixed it, to chime in with the magic bullet:

i have a suggestion: post the full text of that error back to this forum…

also: launch your Opera from a terminal session, then try to connect
to an https page/site, and if there is a message in the terminal,
paste that back to here too…

Those are good suggestions! I get


NPP_GetValue()
NPP_GetValue()
NPP_GetValue()

But nothing else.

When I try any https site - like logging into this site, MySpace, Facebook, GRC’s ShieldsUp! &c. - I get

ERROR!
Internal communication error
You tried to access the address https://login.facebook.com/login.php?login_attempt=1, which is currently unavailable. Please make sure that the Wep address (URL) is correctly spelled and punctuated, then try reloading the page.

Make sure your Internet connection is active and check whether other applications that rely on the same connection are working.

So I pop open Pidgin, and it logs in to jabber and FacebookChat, no problem. I can use Opera to look at http sites with no issue.

next: is it true that using your laptop you can’t connect to ANY
https …]?

Yes.

have you actually carefully compared all browser settings?
are both browsers running in the same OS/version with exact security
and network settings?

if you type about:config into the address bar, hit enter you will be
able to see the several hundred (or thousands) of Opera’s usually
hidden settings…are the two browsers using the same version of
(for example) java; and are all the (for example) network settings and
security preferences the same?

The Opera settings are the same since I imported them. They’re the same version, using the same version of Java and Flash. I’ve been using Opera since I was on Windows 98, so I’ve got that covered. I’ve been on the Opera fora too, to see if I could find an answer. It’s really not the browser.

The only difference is that the desktop and the laptop use different kernels. The laptop’s system is 2.6.25.20-0.1-rt, whereas the the desktop is 2.6.29-rc6-jen77-rt. Would that really cause an issue? I’m reluctant to upgrade the kernel on the laptop since everything else is working fine… But I might give it a go if that’s the only way.

does the laptop have more than one connection profile (one set for use
at home, another at the office, and a third/more for on the road)…

No.

are
https connections blocked no matter where/which environment you try to
connect from?

Yes. Only just two days ago I was working away - same issue. Been like this for around about two-and-a-half weeks: Google searching has led to dead ends.

From the questions you’ve asked, it seems like you’re saying that if there’s a difference then the difference is the problem. Would that mean that someone else using 2.6.25.20-0.1-rt would have the same problem?

Ah well.

Remembered that the desktop is openSUSE 11.1 - which I couldn’t install on my laptop [6 weeks of trying - won’t be doing that again]. I changed the kernel on the laptop, but no difference. But I still didn’t have this problem on the desktop when IT was on 11.0…So I really am stumped. I’ve got a couple of friendly Linux mates coming round later, so maybe they’ll have some ideas… I’ll let you know how I get on.

> Remembered that the desktop is openSUSE 11.1 - which I couldn’t install
> on my laptop [6 weeks of trying - won’t be doing that again]. I changed
> the kernel on the laptop, but no difference. But I still didn’t have
> this problem on the desktop when IT was on 11.0…So I really am
> stumped. I’ve got a couple of friendly Linux mates coming round later,
> so maybe they’ll have some ideas… I’ll let you know how I get on.

i hope they can help because i am fresh out of ideas other than:

did you ever answer (or did i ask you, or someone else?): are both the
desktop and laptop connected via the same means? (or is one wired and
the other wireless?)

and last: i KNOW you are absolutely certain it is not an Opera problem
but anyway, humor me:

load in firefox (even if only temporarily) and see if you can connect
with it…
a. if you can: the problem is Opera
b. if you can’t: the problem is in the network, most likely in the
network configuration setup of the laptop…[and you don’t happen to
have blocked port 443 in the firewall of that laptop, have you?]

and, have you searched google for similar problems? i just got 111,000
hits on this string:

opera internal communication error You tried to access the address

good luck.

Andy Sipowicz

Woohoo! Success!

Although my bad… it WAS the browser. Sort of. More the settings folder.

My mate popped open openssl and brought up a “local user certificate” weirdness… he then downloaded lynx which brought up the same thing but loaded the https page. He then [after we stared at the laptop a long time] deleted my .opera folder, which had lots of random certificate files in it [which my other Opera installation does not]. This cured the problem, although the cause is a mystery to both of us - random corruption? Either way it all works now!

congratulations…

i wish i had thought of having you test via lynx (a LOT easier than
installing another browser), huh?


Andy Sipowicz

And smaller, too. I’ve got a solid state drive on the laptop, so the less times I have to install and then remove large things, the better, I reckon. Thanks for your help though!

> I’ve got a solid state drive on the laptop, so the
> less times I have to install and then remove large things

and, i hadn’t thought about that possibility either (see, we both
learned)…

> Thanks for your help though!

very welcome…happy you got it working…


Andy Sipowicz