Not able to access internet from guest inside vm using "NAT Network"

I used the 13.2 version but, as stated, I saw no noticeable difference to OS repos (apart the minor release bump). I don’t think it matters…

I guess it’s worth asking the question again.
Although you said earlier the Guest was installed on this machine, the above suggests that’s not the case.

It’s <critical> that you answer truthfully whether your CentOS was built from source (most likely using a CentOS install DVD, either ISO file or optical disk) because if this Guest came from another machine then you will have MAC address mis-matches which need to be addressed.


Yes, the guest was installed on this machine only(via ISO file downloaded from centos site). But one doesn’t have to install virbr0,virbr0-nic manually in centos, it comes along with the installation by default in gui installs(so i didn’t install it) and it doesn’t come with minimal installs ,that’s all.

I have both CentOS7 and CentOS6.4 Guests created from the standard ISOs, and none of them install bridge devices by default.

You’re making a selections somewhere that’s not correct.

Review your selections.
You should not configure anything other than the target disk and create a User.


I also have two centos7 installs (one as main install) checked , and as i mentioned earlier i used only "server with gui’ option while installing.You can also check with - yum groupinfo “server with gui” and you can see ‘virtualization*’ tools under Optional groups but they still come along - .So they do come by default for “server with gui”.

I tried to open the guest vms installed in opensuse Leap in my other distro where i installed the latest virtualbox(from ) to test this issue, surprising all vms worked with the “NatNetwork” very well(i could connect to the internet). Also created new vm and checked that as well too just out of the box, problem doesn’t seem to be with any network settings.

They said this error was caused due to packaging issue (so they don’t know what else might be messed up/broken like this)

So i think the virtualbox version available via yast in Leap official repos is bugged.

Pls post the results of the following which will display information about your virtualbox, including the source and your current version (assumes you installed Virtualbox packaged as an RPM).

zypper info virtualbox


BTW, if it were the upstream version you need to type:

zypper info VirtualBox-5.0

zypper info virtualbox
Loading repository data...
Reading installed packages...

Information for package virtualbox:
Repository: openSUSE-Leap-42.1-Update
Name: virtualbox
Version: 5.0.10-10.1
Arch: x86_64
Vendor: openSUSE
Installed: Yes
Status: up-to-date
Installed Size: 29.9 MiB
Summary: VirtualBox is an Emulator
  VirtualBox is an extremely feature rich, high performance product
  for enterprise customers, it is also the only professional solution
  that is freely available as Open Source Software under the terms of the
  GNU Public License (GPL).