Noob question zypper dup? right way to update? & packman factory essentials.

Is

zypper dup

the way I’m supposed to update my Tumbleweed essentials? I depend on Apper to handle it on my openSUSE 13.1 installs.

I’ve added the Packman Factory Essentials to my repos and set it for 98 so I don’t get updates that break my multimedia. I noticed when I did

zypper dup

It did “downgrade” or change some packages to the Packman version. Those were mostly multimedia files. I’m wondering is this going to make my Tumbleweed install unstable?

Ignore my signature. That’s a different machine entirely.

Thanks.
Steven

Packman Factory??? Did you mean Tumbleweed? Yes, I use zypper dup with Packman Tumbleweed repos for Essentials and Multimedia enabled for example. The url should contain “…/openSUSE_Tumbleweed/Essentials/”.

Well, at the moment, all packages in Packman Tumbleweed (built against a weekly Factory snapshot) are built against libvpx1, which is not available in Tumbleweed any more.

Packman Factory OTOH is built against the current Factory/Tumbleweed, so that’s why he’s using Factory I suppose.

If you already have things like vlc or MPlayer installed and are just updating, you don’t have a problem of course. You’d just keep the old libvpx1 (which was already installed on your system, but is not available in any repo any more) without zypper complaining.

Have a look in YaST (or run “zypper se -s libvpx”), and you’d probably see that you have a obsoleted libvpx1… :wink:

@FlameBait:
Those downgrades probably were not really “downgrades”.
The second number is just the rebuild count. That is irrelevant when compared between different repos.

And if you have Packman at a higher priority, there probably will be more packages switched to it. But that won’t make your system “unstable”.
Actually it’s probably preferable to have all packages with full multimedia capability.

Thanks for the clarification on

 zypper dup 

I thought Factory Packman was what we were supposed to use and Tumbleweed was for the old Tumbleweed release. It’s not?
Going by the Wiki that’s what it looked like. I’m trying to remember if the link even looked right.
I remember on the factory mail list someone saying that in the distant past too. I seem I have my wires crossed.
Guess I need to find the right URL for the Packman Tumbleweed repo.

Actually Packman Tumbleweed is intended for Tumbleweed.

But Packman Factory works too, as there really is no difference between Factory and Tumbleweed.
(there is no such thing as “Tumbleweed” on OBS neither)

As written, at the moment Packman Tumbleweed is outdated unfortunately, as it builds against a weekly Factory snapshot to save on build power.
(and this was the recommended way by the “officials” to build packages for Tumbleweed in November when the new Tumbleweed has been established)

OK… I already changed repos and “downgraded” to Tumbleweed. SMplayer is broken in both of the repos. Had to fall back to MPlayer. Not sure where to report that issue.

How often do I need to do

zypper dup

Packman issues should be reported to their mailinglist:
http://lists.links2linux.de/cgi-bin/mailman/listinfo/packman
(you don’t have to subscribe to post a message)

But before you do, what exact problem do you have with SMPlayer?

How often do I need to do

zypper dup

Depends on how up-to-date you want your system to have.

That said, nowadays (with today’s Tumbleweed) it should be fine most of the time to just run “zypper up” (that’s actually the recommendation from one of Tumbleweed’s creators), or use Apper or similar.
But there might be situations where this doesn’t suffice.

YaST->Online Updates is not an option though, as there is no update repo on Tumbleweed (well, there is, but it’s empty most of the time, it’s only intended for emergency cases).

I’ve got this same SMplayer error with the Essentals repo and the Multimedia repos installed.

When trying to open a video file in SMplayer this is the following error from it’s
‘log’

INFO_MEDIA_TITLE=${=media-title:} --term-status-msg=STATUS: ${=time-pos} / ${=length:0} P: ${=pause} B: ${=paused-for-cache} I: ${=core-idle} /home/flamebait/Desktop/movies/5002012/Fall 2012/[Commie] Girls und Panzer/[Commie] Girls und Panzer - 01v3 [EA213BDD].mkv


Option ao: ':' expected after label.
Error parsing option ao (option could not be parsed)
Setting command line option '--ao=@@DEFAULT@@,' failed.
Exiting... (Fatal error) 

Yes I had noticed the obsolete libvpx1 here, and conflicts when I tried to remove it a while back, so I didn’t. I have vlc and s/mplayer installed.

Then of course even with old Tumbleweed the wiki was always one step from reality in stating there was only essentials and no multimedia etc. repos for it when they actually existed (albeit as grace & favour I suppose). Originally Packman Factory with limited content was only added to assist Milestone testing, certainly up to and including 13.2.

My old Tumbleweed broke (kernel 3.17.1/Btrfs bug) just before it obsoleted, repaired it, then re-based on 13.2 with Packman essentials and multimedia repos. When I upgraded to new Tumbleweed, for some reason I expected Tumbleweed repos were for it, and Factory were for those still running factory repos up to April/May time when they would be removed.

Nope I didn’t install VLC as SMplayer has been don’t all I need and there are no conflicts as was the case in the past with VLC.
MPlayer works but it’s not as nice as the more enhanced front end SMplayer provides.

I guess the maintainer of the Packman repos is aware of this situation and it has to be waited out until upstream uses the more current file that’s required.

I’ll do zypper dup as I see updated snapshots announced on the Factory mailing list.

Have you tried the “mpv Media Player” that’s installed by default I think?

On Fri 29 May 2015 05:26:01 PM CDT, wolfi323 wrote:

That said, nowadays (with today’s Tumbleweed) it should be fine most of
the time to just run “zypper up” (that’s actually the recommendation
from one of Tumbleweed’s creators), or use Apper or similar.
But there might be situations where this doesn’t suffice.

Hi
I only use ‘zypper up’ these days, but only have two tumbleweed repos
(oss and update) and a local rpm repo active. If I run zypper dup it
wants to re-install plymouth and add a gnu-cash doc and ftp release
notes which I don’t want…

No issues so far and everything gets updated fine…


Cheers Malcolm °¿° LFCS, SUSE Knowledge Partner (Linux Counter #276890)
SUSE Linux Enterprise Desktop 12 GNOME 3.10.1 Kernel 3.12.39-47-default
If you find this post helpful and are logged into the web interface,
please show your appreciation and click on the star below… Thanks!

I just tried it and it does show subtitles on multiple files I tried but no audio playback what so ever. Zip… Checked mixer setting and everything is cranked up.

Tumbleweed really only uses one repo called Tumbleweed (not oss).

Hi
Umm, no…



zypper lr
# | Alias               | Name                        | Enabled | GPG Check | Refresh
--+---------------------+-----------------------------+---------+-----------+--------
1 | Local_rpms          | Local_rpms                  | Yes     | ( p) Yes  | Yes    
2 | openSUSE-20150516-0 | openSUSE-20150516-0         | No      | ----      | No     
3 | repo-debug          | openSUSE-Tumbleweed-Debug   | No      | ----      | No     
4 | repo-non-oss        | openSUSE-Tumbleweed-Non-Oss | No      | ----      | No     
5 | repo-oss            | openSUSE-Tumbleweed-Oss     | Yes     | (r ) Yes  | Yes    
6 | repo-source         | openSUSE-Tumbleweed-Source  | No      | ----      | No     
7 | repo-update         | openSUSE-Tumbleweed-Update  | Yes     | ( p) Yes  | Yes 

Oops, I forgot about non-oss being separated. The point was Tumbleweed-Update is not really “used”, not so far and maybe never. I don’t even have it set up.

Hi
Yes, the update one is probably only a place holder for testing to ensure it gets created/added, then when it’s slated for a release it should all work…

Strange, I have audio playback with mpv, at least when playing .mp4 video.

Apparently, SMPlayer calls MPlayer with the option ‘–ao=@@DEFAULT@@’, which is of course non-sense.

Probably the @@DEFAULT@@ should have been replaced during building of the package, or it should be replaced by the value in the configuration settings.
So I’d suggest to have a look into SMPlayer’s “audio output” (or similar) settings, maybe this is somehow specified there? If you’d change it to your preferred audio output driver (if possible), it should work in that case. Good choices are “pulse” or “alsa”, I suppose…

I never used SMPlayer, so I’m not sure about that though.
I might install it myself tomorrow or so, and have a look.

No, it’s actually intended for emergency security fixes, when Factory cannot be released as new Tumbleweed snapshot because of some breakage.

Like it happened in December with the openssl vulnerability…