noob issues with vnc

I have seen others post with this issue but haven’t found a solutions yet, if anyone knows the answer or a thread that solves this I would love to know.

The problem that I am having is.

I have opensuse 12.3 on two different computers.

When I try to connect to one of them using vncviewer or a web browser. After entering the vnc passwd I am presented with the user and password challange for the session. As soon as I enter the password for the user I get a message about the connection being closed by the server.

Using answers to others questions in the forums I have done the following to get the vncviewer passwd to work

  1. in the root & my user home I ran vncpasswd.

  2. using yast administrator settings, network services (xinetd) I assigned vnc1 to root and added -rfbauth /root/.vnc/passwd to it’s server arguments. I then assigned vnchttpd1 to root also. After doing this I no longer received the no passwd auth assigned error and vnc would connect and bring up the session login screen.

I am using the gnome desktop, I have tried going into the desktop sharing settings under the internet menu and checking allowing others to view and control my desktop, this made no change.

And this is where I am stuck any help would be greatly appreciated.


Have a look at my blog post on remote control: How To Use VNC/Remmina to Remote Control an openSUSE 12.3 KDE Desktop - Blogs - openSUSE Forums and for file sharing, have a look on my post about using Samba: S.A.C.T. - Samba Automated Configuration Tool - Version 1.03 - Blogs - openSUSE Forums

Thank You,


Thanks for the reply, I had already found your blog in my search for answers :slight_smile: It was what lead me to change the remote desktop settings trying to mimic your setup in KDE. I have now ran vncserver from my user home creating the startx and pid file, and I am able to use the pid file in this case 3. To connect ie vncviewer and it will let me in but only with a simple text window. So I can now use test mode aps but not gnome as it is already running on So not really a solution. I am still stuck with vncviewer disconnecting after entering my session user name and password. Is there any where I need to enable a remote desktop user similar to what you do with SAMBA users, smbpasswd -L -e your_username?

vncpasswd is what is used. Here is a link to its usage: vncpasswd(1): change VNC password - Linux man page and here is a nice article that talks about such things: Linux 101: Easy VNC server setup | TechRepublic

Thank You,

Since there is already a thread for VNC I guess I can post here…
I have OpenSuse 12.3 in headless mode and I’m unable to connect via VNC viewer to the “default” port 5901/5801 that is enabled by yast (the text mode one) by enabling Remote Administration (VNC). I start TightVNC viewer (or Chrome). I’m asked for password, I enter the password and I get “No password configured for VNC Auth”. This is not how it worked in 12.2 - it just did connect. I did run “vncpasswd” (as root) to set the password before. When I execute “vncserver” it starts again and opens ports 5902/5802 - I can connect to these no problem. I also have a WinXP guest and I can connect to it no problem, which probably doesn’t matter anyway.
Not sure if it’s relevant but the first bit of my /etc/xinetd.d/vnc is as follows (default, I didn’t mess with it):

service vnc1{
        socket_type     = stream
        protocol        = tcp
        wait            = no
        user            = nobody
        server          = /usr/bin/Xvnc
        server_args     = -noreset -inetd -once -query localhost -geometry 1024x768 -depth 16
        type            = UNLISTED
        port            = 5901

I’m not sure what I had in 12.2 as I never had to look in here…
I tried changing user to root but it made no difference.
Any help appreciated.