Noob Having trouble setting up ati x2300 graphics card

Hello everyone

Im a complete linux noob, been looking into swithcing to linux for a while and recently my pc was giving me problems and decided its about time to break free from the prison of microsft, looked into a couple of linux distros so I tried Ubuntu quite liked the whole linux OS and found out that opensuse has even more to offer so I just recently switched to it.

Ive been having a problem with my graphics card I want to enable visual effects but I cant its disabled and if I do try to enable it, I get a message saying that my hardware does not support this and if I still want to go ahead.

Being a complete noob I would rather not enable it the reason being, twice now I installed/updated my pc to get the graphics card working all went well and the install/update returned a message successful not one error, unlike with ubuntu but when I restart the pc all I get is a black screen.

Tried running the recovery tools and tried reparing to no avail, having nothing on my pc I opted to reinstall os twice now because both times they failed. LOL Iam a bit lost and would like some help dont want to keep reinstalling the operating system over and over. :shame:

Currently Im running the Gnome desktop
my graphics card is not detected in Sax2
its a ati mobility x2300 on a sony laptop
Have no clue whats going on :stuck_out_tongue:
Dont want to go back to windows even if it means no graphics card lol!


BTW Im running the 64 bit version of opensuse 11.1 forgot to mention it

i’m a n00b too i have to say, but it worked for me, here is what i did:

-open yast
-go to sotware repositories
-click add
-comunity repositories, next
-scroll down and select ati
-add the repositories

-back to yast
-open software management
-search for ati and add the one from the ati repositories(probably will update your kernel aswell, mine did)

  • wait for it to finish(for me it took a while…)
    -you’ll get a message to restart your comp to update kernel(if you updated it), anyways, restart your machine

  • on the boot screen(were you select your boot device/OS and you can also set sope parameters/options below)

  • add the option 1 (mine looked like “vga=0x361 1”, i just added the "1"at the end), so it will boot into runlevel 1

  • enter root pass

  • run “aticonfig --initial”

  • run “sax2”

  • sax2 will try to run, if you get a blue screen with squares on each corner, you’ll probably get a message to save the configuration
    -save the configuration

-reboot / or “init 6”

  • it should work, if it doesn’t the i cannot help you further… i know no more.



Ok cool thanks for the response will try it and let ya know

I followed everything you posted to the tee and like you mentioned I waited while it updated and asked to restart, when I reached the point where I had to add option 1 I did that, entered root pwd ran the aticonfig command successfully but when it came to running the sax2 I got the blank black screen again.

Nevertheless with your help there has been some developments. For one when I rebooted I had the option of choosing a debug mode on the boot screen did that and when I logged on I restarted cause nothing was working example no sound, no wireless card etc, I assumed this maybe the opensuse equivalent to windows safe mode.

Anyways restarted again and booted normally and the OS actually booted usually by now Id be stuck on a black screen. Now when I come to open Sax2 I get a message saying:

“Cannot deactivate all displays at least one display must be active”

click ok it opens Sax2 but still nothing is enabled in the card options.

Also in the application browser I have 2 new apps there
ati catalyst control center

Im getting somewhere so Thanks a load for your help, wanted to know are you running the same graphics card?

hello there,

i’m disapointed to hear it didin’t work out, for me it worked like a charm. i’m using a hd3200 on a AMD based laptop.

i’ve had the same problem with my former sony laptop, a ati igp 315(radeon 7000 like), it installed all the drivers fine, but didin’t start sax, so i was very confused and had no idea how to proceed, blank screens everytime freaked me out.

once i made it work, after some research, i think you can also try it, here it goes:

-once you boot in runlevel 1 type the folowing while root:

“rm /usr/lib/dri/ && ln -s /usr/lib64/dri/ /usr/lib/dri/”

“sax2 -r -m 0=fglrx”

see it that works, i had written this on a piece of paper a while back, and still have no clue what it exctly does, but it made my igp graphics card work. good luck

anyone with a bit of knowledge wants to join in? i’m a newbie too… lol i can’t get my sound to work…


Your timing is unfortunate. There was a kernel update a few days ago which broke the sound on a number of user’s PCs (kernel updates unfortunately cause this sort of breakage on all Linux distribution user’s PCs (and not just openSUSE)). Typically the SuSE-GmbH alsa packager will package an updated alsa version for the new kernel, but that has not happened yet. I note Thursday was a holiday in Germany and many people took the entire week as a vacation. Hence if the past is a guide, there is a chance we will see an update to alsa some time mid-next week.

There is also an audio troubleshooting guide here: SDB:AudioTroubleshooting - openSUSE BUT if the kernel update is the reason for your sound not working then the audio troubleshooting guide will not help you.

Run level 1 is rather “deep” to go. Most users will only go down to runlevel 3 and hence will only type “3” . Some information on run levels: Runlevel - Wikipedia, the free encyclopedia

If the proprietary driver does not work, other sax2 commands one can try are dependant on one’s ATI hardware (and assuming one has only one graphic hardware device):

  • sax2 -r -m 0=ati
  • sax2 -r -m 0=radeon
  • sax2 -r -m 0=radeonhd
  • sax2 -r -m 0=vesa

Another alternative is to copy the /etc/X11/xorg.conf.install file on top of the /etc/X11/xorg.conf file in the hope that installation xorg.conf file will work.

One can also force sax2 to configure with a lower resolution. One can find the sax2 options by typing: man sax2

oh well, oldcpu. i hope none minds… the audio troubleshooting guide didin’t help me, i’m quite lost on what to do, maybe you know a few things i could try? if so should i start a new thread or could you PM me? i don’t like to trotter other’s thread with my own problems… kernel update… 0.0 i had no idea

thx for explaining, i didn’t knew there was much diferrence, tought only runlevel 1 was root only and runlevel 3 was multiuser… anyways it worked for me and since no one said something i thought i would just try to help :smiley:

anymore mistakes i may make, feel free to correct me :smiley: i’m here to learn aswell, hope rabbit09 will get it to work


Its quite possible the kernel update has complicated everything. What kernel do you have installed? If you type:
uname -a
it will tell you your kernel version.

Reference your sound, its likely best you start a new thread. As you likely suspected, most moderators do not provide private support via PM. Rather we try to encourage public posting.

Thanks mehezeen

I searched for settings along the lines of what you gave me and finally got it working rotfl!

Thanks a load the help Muchas Gracias!

I searched for the lines of code you gave me and added x2300 to the search term

I used this code instead of the last lines above finally enabled it to work:

init 3
sax2 -r 0=fglrx
init 5

All of a suddenly all the desktop visual effects start working, the desktop rotates in a cube when switching from one to another which is quite a cool feature I mean talk about a powerful operating system, I think this feature alone of having 4 desktops, I can convince many friends to make the switch from windows to Linux.

The only issue Im having now is with one repository, everytime I come to update this is what I get:

ati-fglrxG01-kmp-trace-8.582_2.6.27.19_3.2-2.1.x86_64 requires kernel(trace:fs) = eaa038e67699313d, but this requirement cannot be provided

Looked for this on the forums but seems like there was one other person who had this problem and never got feedback on it.

Getting my unix book in 2 days cant wait still got a lot of things to figure out and learn but to put it short

OpenSuse is the BOMB

Thanks again for all the help

For those with non-functioning sound as a result of the new kernel, the SuSE-GmbH packager has now released the rpms for the update to 1.0.20 of alsa for the kernel. Note this is on a special multimedia repository and not on the standard “update” repository.

There is guidance here for doing the update:
Alsa-update - openSUSE

Note one MUST send six zypper commands, being certain to pick the one’s specific to one’s openSUSE version. I recommend one optimize the alsa apps to be installed to match what one has on one’s PC already. … and also the second last command in the 3 command group should be specific to one’s kernel. Do NOT install multiple alsa-driver-kmp-<packages> … Only install the ONE that is applicable.