NoMachine nxclient-nxserver redux

I have configured one linux box with nxserver and am trying to connect to it from another linux box using nxclient. Everything looks just fine in the remote session up to the point at which I see the SuSE login progress bar at the end of its process, just when I would normally see the SuSE desktop appear.

Here is the client’s “errors” log for one session. If you have worked with this before, the client’s logs are located in a directory under ~/.nx in the user’s home. In this case, the directory was labeled ~/.nx/S-localhost-1005-8429ED789377D0AAEBF7D6EA7E7A0A4B

Proxy: PANIC! Failure reading from the peer proxy on FD#9.
Loop: PANIC! No shutdown of proxy link performed by remote proxy.

I’ve seen it also say “…on FD#11”. I don’t know what ‘FD#’ refers to.

And here is the “session” log for the same attempt

NXPROXY - Version 3.2.0

Copyright (C) 2001, 2007 NoMachine.
See NoMachine NX - Desktop Virtualization and Remote Access Management Software for more information.

Info: Proxy running in client mode with pid ‘15025’.
Session: Starting session at ‘Tue Aug 26 18:01:40 2008’.
Info: Connection with remote proxy completed.
Info: Using ADSL link parameters 512/24/1/0.
Info: Using cache parameters 4/4096KB/131072KB/131072KB.
Info: Using pack method ‘adaptive-7’ with session ‘kde’.
Info: Using product ‘LFE/None/LFEN/None’.
Info: Using ZLIB data compression 1/1/32.
Info: Using ZLIB stream compression 4/4.
Info: No suitable cache file found.
Info: Forwarding X11 connections to display ‘:0.0’.
Info: Listening to font server connections on port ‘11005’.
Session: Session started at ‘Tue Aug 26 18:01:40 2008’.
Info: Established X server connection.
Info: Using shared memory parameters 1/4096K.
Error: Failure reading from the peer proxy.
Error: Connection with remote peer broken.
Error: Please check the state of your network and retry.
Session: Terminating session at ‘Tue Aug 26 18:01:47 2008’.
Session: Session terminated at ‘Tue Aug 26 18:01:47 2008’.

The relevant line here is Error: Failure reading from the peer proxy. but it’s not too informative.

It would be GREAT if someone who has used the No Machine version of NX would come along. I’ve scoured the internet for days seeking out insights. Others have had this problem, but I’ve not yet seen explicit solutions.

Mine is a straight-shot installation of the NX rpm’s, done in the proper order and with nothing changed in the config files except the logging level.

I’ll get the server’s log messages next and paste in the most suspicious entries, and I’ll describe my port settings next as well if someone expresses interest in trying to help figure this out. I would that think given the great speed of NX Server, many people in SuSE-land should have got this working and have solved various configuration issues. I also think it would be GREAT to be able to offer better instructions than I’ve seen out there to newcomers who wish to take advantage of NX.

Never had an issue with my installs of NoMachine NX both linux and
Solaris on an internal network. Your using a proxy and going out over
the internet?

Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 11.0 x86 Kernel
up 1 day 10:49, 2 users, load average: 0.02, 0.14, 0.25
GPU GeForce 6600 TE/6200 TE - Driver Version: 173.14.12

Malcolm, I am going over the internet and to my knowledge there is no proxy involved except nxagent on the server, which I believe acts as a proxy of some kind. But I am only parroting back what I have read with incomplete understanding.

I was hoping the default installation would work, but since the error message to the user in the nxclient GUI is vague -

The connection with the remote server was shut down. Please check the state of your network connection.
all eyes are on “the network”.

What can I say about the network? On the nxserver machine there is a firewall router that translates SSH requests received from my public (static) IP and sends them to the target machine in the remote LAN. On the return trip to the client my firewall router does not do any port forwarding or address mapping, but it does have a rule that allows traffic from the server’s public IP into my LAN on TCP/IP ports 22, 5000-5002, and 7000-7002.

From my reading I crudely guessed that those ports might be needed and while I’m getting this to work there is no harm in keeping them open. At minimum, I know port 22 is required.

I have been successful logging in remotely via ssh, and I have also been successful connecting with x11nvc as server and Krdc as client, but the first is not up to what I require and the second is quite slow.

The key seems to be

Proxy: PANIC! Failure reading from the peer proxy on FD#9.

I have had no luck determining what that means. From your knowledge of the elements that go into making this sort of thing work, do you have a theory?

I have resolved this issue. In /var/log/messages the first error written by nxserver was

ERROR: Unexpected termination of nxagent because of signal: 11
Subsequent errors in the log cascaded from that.

At least one other person once encountered this problem and fixed it and posted the fix. The link to that discussion is at NXserver stopped working after enabling Compiz [Archive] - Ubuntu Forums, and the solution is

ssh to the server machine.
create a new user:
/sudo /usr/NX/bin/nxserver --useradd <a new username> --system

This action permitted nxclient to complete the connection and draw a remote desktop, albeit not as the user originally wanted.

Someone suggested in the other discussion that compiz was breaking the remote session. I do not have compiz enabled on the remote machine, though I did at one time. I’m not sure which desktop feature, video driver, user configuration, etc., causes the problem when logging in as the original user, but the new user circumvents that issue. I would like to log in as myself, not the ersatz user, but for now at least I can log in as SOMEbody.

I hope this will be useful to others. NX is so poorly documented and useful information is scattered and disjointed.

Just tried it out here, both machines are running compiz. I can connect
from SLED->openSUSE but it barfs on openSUSE->SLED. I normally connect
from the SLED machine, so have never noticed :slight_smile: It will be the display
settings by the looks, but at least you have a working solution :slight_smile:

Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 11.0 x86 Kernel
up 7:46, 2 users, load average: 0.08, 0.48, 0.32
GPU GeForce 6600 TE/6200 TE - Driver Version: 173.14.12