Noisy sound from my speakers

I hear noisy sound coming out from my speakers.
That noise stays whether I play music or not.
The noise doesn’t exists in Windows 7. (I have dual-boot configuration)

Details:

Using openSuSE 11.2 x86_64 (KDE)
Using Creative Labs Inspire 2.1 2500 Stereo Speakers

$ hwinfo --sound
18: PCI 1b.0: 0403 Audio device                                 
  [Created at pci.318]                                          
  UDI: /org/freedesktop/Hal/devices/pci_8086_3b56               
  Unique ID: u1Nb.CIYqfO7zKxE                                   
  SysFS ID: /devices/pci0000:00/0000:00:1b.0                    
  SysFS BusID: 0000:00:1b.0                                     
  Hardware Class: sound                                         
  Model: "Intel 5 Series/3400 Series Chipset High Definition Audio"
  Vendor: pci 0x8086 "Intel Corporation"                           
  Device: pci 0x3b56 "5 Series/3400 Series Chipset High Definition Audio"
  SubVendor: pci 0x1043 "ASUSTeK Computer Inc."                          
  SubDevice: pci 0x8435                                                  
  Revision: 0x06                                                         
  Driver: "HDA Intel"                                                    
  Driver Modules: "snd_hda_intel"                                        
  Memory Range: 0xfbcf8000-0xfbcfbfff (rw,non-prefetchable)              
  IRQ: 22 (19184 events)                                                 
  Module Alias: "pci:v00008086d00003B56sv00001043sd00008435bc04sc03i00"  
  Driver Info #0:                                                        
    Driver Status: snd_hda_intel is active                               
    Driver Activation Cmd: "modprobe snd_hda_intel"                      
  Config Status: cfg=no, avail=yes, need=no, active=unknown              

31: PCI 100.1: 0403 Audio device
  [Created at pci.318]          
  UDI: /org/freedesktop/Hal/devices/pci_1002_aa58
  Unique ID: NXNs.j18tSRZEo21
  Parent ID: 3hqH.qNcqIMr0SqF
  SysFS ID: /devices/pci0000:00/0000:00:03.0/0000:01:00.1
  SysFS BusID: 0000:01:00.1
  Hardware Class: sound
  Model: "ATI Audio device"
  Vendor: pci 0x1002 "ATI Technologies Inc"
  Device: pci 0xaa58
  SubVendor: pci 0x1458 "Giga-byte Technology"
  SubDevice: pci 0xaa58
  Driver: "HDA Intel"
  Driver Modules: "snd_hda_intel"
  Memory Range: 0xfbdfc000-0xfbdfffff (rw,non-prefetchable)
  IRQ: 17 (23 events)
  Module Alias: "pci:v00001002d0000AA58sv00001458sd0000AA58bc04sc03i00"
  Driver Info #0:
    Driver Status: snd_hda_intel is active
    Driver Activation Cmd: "modprobe snd_hda_intel"
  Config Status: cfg=no, avail=yes, need=no, active=unknown
  Attached to: #9 (PCI bridge)

BTW, I can’t find the Sound module in the Hardware section in YaST, as written here.

Any ideas? :slight_smile:

Try switching some of the options in the mixer on / off, one by one.

Tried that, didn’t work (By “on/off” I assume that you mean to mute the option)

That as well, but also for example: My Xonar has some checkboxes for switching options of the card on and off. If I enable ‘Analog Loopback’ I hear a squeeking noise through music. I’ve seen changing the capture device in the mixer cause/solve matters like this.

I can’t find Xonar nor the Analog Loopback option :\

If you wish to get more information on your audio setup, then run the diagnostic script from a terminal or bash shell:

/usr/sbin/alsa-info.sh

In addition to that, its not likely that your Sound Module is not showing up in YaST. If you still think this, go to YaST > Hardware > Sound and do a screen print, and post the screen dump (of YaST > Hardware > Sound ) image on ImageBam - Fast, Free Image Hosting and Photo Sharing because I confess to being a bit skeptical.

I ran that script. Here’s the content of the /tmp/alsa-info.txt.HhEKRZMLg0 file: #976442 - Pastie](http://pastie.org/976442)

I don’t have the sound module in YaST. Here’s a screenshot of YaST: ImageBam - Fast, Free Image Hosting and Photo Sharing

You have to go to YaST > Hardware > Sound.

It appears you are over driving your sound, with the volume jacked up to 100% on most controls (except PCM). Back OFF on those settings.

Please check to ensure you don’t have broken dependencies wrt YaST. In a terminal with root permissions run:

zypper ve

You mean YaST > Hardware > Hardware Information > Sound ? If so, here it is: ImageBam - Fast, Free Image Hosting and Photo Sharing

What is the meaning of “back off on those settings” ?
Should I decrease the volume on some options (like Master and Front), or to mute some?

I tried many variations, some helped to decrease the noise but then I couldn’t hear any music at all :expressionless:

Here is my current settings: ImageBam - Fast, Free Image Hosting and Photo Sharing
Please advice :slight_smile:

Install it:


zypper in yast2-sound

OK, here’s the output:

$ zypper ve
Loading repository data...
Reading installed packages...

Dependencies of all installed packages are satisfied.

Got it! I have the Sound module now.
Here’s the screenshot: ImageBam - Fast, Free Image Hosting and Photo Sharing

By back OFF I mean reduce the volume. Try putting each volume level at 65% and then gradually increase each until volume is acceptable.

Also try going to YaST > Hardware > Sound > Other > Volume and ensure you do not have the volume too loud such that it is in distortion there.

I tried reducing the volume and then gradually increasing it, but I can’t find a proper volume that is high enough & not too noisy.
Tried doing that both via YaST and the mixer window (KMix, I guess).

Wait! I think I found it! Ya! :slight_smile:
Out of curiosity, how come in Windows I don’t need to do these adjustments?

Edit: actually the noise is still there (when no music is played) … sorry.

I think I found something, check it out: ImageBam - Fast, Free Image Hosting and Photo Sharing

It appears when I edit a Card Model in the Sound module in YaST.
I always click “No”. Should I do otherwise? Maybe that can solve the problem.