No Youtube video on 64bit Mozilla Firefox

Quick question:

On 64-bit Firefox I cannot watch videos on youtube. If I turn back to 32bit FF (nothing else changed) I can watch them. What may be the problem?

did you have flash player installed?

give an output

> rpm -qa|grep flash

Uninstall 32bit flashplayer, download and install flashplayer 10 64bit (it’s alpha I think, but it works great)

In Yast, go to Software/Software Management, and in Search type flash.

Remove ‘libflashsupport’ I put a lock, never install, personally, since for some reason upgrades often reinstall this which should never have been automatically included in the first place ] and ‘pullin-flash-player’. Further remove any other listed files except the flash-player itself — particularly other flashplayers such as Gnash, since they compete; but it’s the the first two files which seem most of the problem ( particularly with sound on flash ).

In Firefox, go to Preferences/Applications. Make sure ‘Shockwave Flash’ says ‘use Shockwave Flash - in Firefox’ actually, sometime ago with this problem, I found that toggling between that and ‘use Flash Player - Default’ would work if the previous setting stopped ]. For nearly all the other media settings I have ‘use xine-plugin’ I think this may have been chosen back then to force Firefox to use Alsa, but I don’t remember: however this set-up works on my machine.


I removed the packages you suggested and tweeked the FF preferences and still no videos on Youtube… any more ideas?

I can’t seem to get the 64bit flash version, can anyone point me into the right direction?

Ok guys it’s all done! I downloaded libflashplayer from adobe website, extracted it and I moved it to /usr/lib64/browser-plugins/ and I can finally watch youtube videos! Thanks for the help :slight_smile: