No Xorg with Tumbleweed in VirtualBox

I just wanted to give openSUSE a try and installed the current Tumbleweed snapshot 20160422 in kubuntu 16.04 running VirtualBox 5.0.18.

Installation goes well but after the first start there is no graphical login, just a tty.

So I logged in and tried “startx” but starting Xorg seems to fail with permission problems.

Looking at Xorg.0.log everything seems to go well like loading VBoxVideo but then there is “Operation not permitted”:

  2130.658] (II) VBoxVideo: guest driver for VirtualBox: vbox
  2130.658] (II) modesetting: Driver for Modesetting Kernel Drivers: kms
  2130.658] (II) FBDEV: driver for framebuffer: fbdev
  2130.658] (II) VESA: driver for VESA chipsets: vesa
  2130.658] (WW) xf86OpenConsole: VT_ACTIVATE failed: Operation not permitted
  2130.658] (EE) 
Fatal server error:
  2130.658] (EE) xf86OpenConsole: Switching VT failed
  2130.658] (EE) 
  2130.658] (EE) 
Please consult the The X.Org Foundation support 
 for help. 
  2130.658] (EE) Please also check the log file at "/home/dode/.local/share/xorg/Xorg.0.log" for additional information.
  2130.658] (EE) 

Any ideas?

Kernel 4.5.x currently in TW closed a kernel-memory loophole that was apparently used by the VBox video driver prior to version 5.0.18.
Testing the upstream (from 5.0.18 version I had to add “iomem=relaxed 3” to the boot command line, login to console as root, install the 5.0.18 GuestAdditions in the guest Tumbleweed, reboot and I still use “iomem=relaxed” to boot.
I don’t know anything about the VBox configuration used by Kubuntu, but the tweak above is worth trying.

Following your advice I finally saw that the issue is described on VirtualBox’s download page.

So I uninstalled openSUSE’s VirtualBox guest additions 5.0.17 and manually installed 5.0.20. What was a bit strange for me is that even though the running kernel was 3.5.0, YaST installed the kernel headers for 3.5.2 so the installation didn’t succeed until I updated the kernel to 3.5.2.

Graphics however only started to work for me after I removed “iomem=relaxed” again.

So now it works fine!


Nice to know that it is working.
Please be aware that Tumbleweed is a true rolling release and the current kernel has just been updated to 4.5.2; the installer just got the last kernel-default-devel available, even if you had a previous kernel-default installed.
If it worked, don’t mind it; should you decide to update your installation using the “zypper dup” command, the whole kernel lineup will be updated to the last version available at that time.
Should you have problems and decide not to update the whole install, please be aware that kernel-default-devel-4.5.0-3.1 (and matching dependencies) is still available in the repo
If you need that exact version you should open yast2-software and check in the “Versions” tab the version you need instead of the last one.

Thanks so much for this useful info!