No xorg.conf file

I just noticed something strange with my 11.2 rc1 installation. I can’t seem to find my “xorg.conf” anywhere. It’s not at root/etc/X11 nor any other locations.

Is this possible?

Yes, it is possible with X-server >= 1.6.

If you run sax2 from a su term it will create one though.

I was quite amazed. Just installed the NVIDIA driver, no sax2 or nvidia-xconfig, just init 5 && exit, works. Ascpecially amazed about the Wacom tablets: plug in, work.

Everything just works great for me too. Totally loving it.:wink:

Thanks guys. I’ll try the “sax2” command.

On Sun, 25 Oct 2009 15:56:01 +0000, Knurpht wrote:

> Ascpecially amazed about the
> Wacom tablets: plug in, work.

I found that to be the case with 11.1 as well with my Intuos4 - but in
the end I did end up building a patched version of the wacom.ko kernel
driver (for support for uploading images to the OLED displays - it’s a
very new patch created week before last).

Out of curiosity, is hotplug supported in what’s in 11.2?


Jim Henderson
openSUSE Forums Moderator

Any reason for that?

Is there something not working as expected?

If anything is OK, then why create a xorg.conf which is not needed any more?

Interestingly I just installed the nvidia driver, did sax2 (habbit I suppose) and it didn’t work. Installation went fine but the driver wouldn’t work. I read this thread and rename xorg.conf, rebooted and now my driver’s working fine. Amazing… Just deleted all xorg.conf.* files and it’s still working.

Very happy now :slight_smile:

So,Gumper, try and rename your xorg.conf something else and reboot your machine. That might get it working if the nvidia installer says all went well.

I think you are drawing the wrong conclusion, or doesn’t it look like it works because you did not use the now obsolete way with xorg.conf/sax2?

This thread should be linked to all those people complaining, whining and even calling the developers/maintainers who decided to obsolete sax2 (without removing it, so it is still there as a fallback option!) “morons” and “stupid”.

I installed it ones. Ran sax2, rebooted and no composting. Reran sax2, still no composting. rename xorg.conf, reboot and now it works. I think I am drawing the right conclusion. In either way it now works so I don’t care how :stuck_out_tongue:

I installed the nvidia driver via init 3 etc and every thing seemed fine. However when I launch a console I keep getting this maessage. " syslogd@linux-jpk2 at Oct 25 22:22:37 …
kernel: 1280.923958] do_IRQ: 0.107 No irq handler for vector (irq -1)">:(

If I remove nvidia and sax2 back to vesa all is ok again, any ideas what is wrong.:confused:


You might want to look at var/log/Xorg.0.log to see whats going on. Can you boot up in failsafe mode (with basic vesa driver) ok?

Not that it has made a difference so far here, but just in case something happens between now & GM is that the nvidia-xconfig that is renamed? I’m looking at this as an alternative to sax2.
While I’m here is it sax2,xorg.conf’s or something else going bye bye?:confused:

Actually I was toying with the idea of installing Archlinux and I wanted to see what it looked like for reference.

You do know, that Archlinux as a “bleeding edge” distro does also not rely on a xorg.conf any longer?

I agree with Akoelh. First there’s loads of complaints about the difficulties in installing third party drivers, now that a way is found to make this all an easier, more OOTB experience, the complaints are about not having these difficulties.
This is a leap forwards, specially for people who are new to linux.

Just FYI;
I just instal Fedora 11 on my Box and was amazed at the OOTB experience I had with my Nvidia card. It installed their “nouveau” driver. I tell you it’s amazing, I had desktop effects in Gnome, but not in kde for some reason. I later installed the Nvidia driver (beta) manually as I usually do though.

I’ll have a number of 11.2 installs with nvidia to do after release so I’ll be interested to see how things go. There’s always a way round things though;)