No X11 DISPLAY variable was set

HI there,

I was trying to install **Vivado Xilinx **software on Tumbleweed machine.
It is not a supported distro for Vivado but I wanted to give it a try as I’m using Tumbleweed as my daily driver nowadays.
If I just start to install binary without **sudo **the installation process starts with no problem and will stop at the very late stage of installation.
I tried with sudo and it not allowing me to to install with X11 error:

ERROR: Installer could not be started. 
No X11 DISPLAY variable was set, but this program performed an operation which requires it.
No X11 DISPLAY variable was set, but this program performed an operation which requires it.
    at java.desktop/java.awt.GraphicsEnvironment.checkHeadless(
    at java.desktop/java.awt.Window.<init>(
    at java.desktop/java.awt.Frame.<init>(
    at java.desktop/java.awt.Frame.<init>(
    at java.desktop/javax.swing.JFrame.<init>(
    at h.b.<init>(Unknown Source)
    at com.xilinx.installer.gui.F.<init>(Unknown Source)
    at com.xilinx.installer.gui.InstallerGUI.<init>(Unknown Source)
    at com.xilinx.installer.gui.InstallerGUI.<clinit>(Unknown Source)
    at com.xilinx.installer.api.InstallerLauncher.main(Unknown Source)

I also have tried Vivado on Leap 15.2 ( even is not supported) and worked fine with no issue.
Now I’m wondering if that X11 error could be sorted on Tumbleweed?

Kind Regards

This apparently being a program that wants to run in an X GUI environment, I doubt it is to be run by root, because root never uses a GUI.

Isn’t it correct that it is a user program to be run in a GUI?

When you use “sudo” to run a program, the environment $DISPLAY is not passed through.

As an alternative, you can use:

su -

to get a command line, and then run the command from root command line. It’s up to you to decide whether it is safe to do that.


Thank you very much for the support.
That wa true. Sudo will not pass $DISPLAY.
Now it is working perfectly fine :slight_smile:

Kind Regards