no X after mysterious crash

I recently woke up my laptop computer from suspend and instead of resuming it rebooted. It restarted with X up and running. When I later restarted the computer, X wouldn’t start anymore. In the log file it says “no usable screens found”. There were other strange problems which seem to be due to a lot of config files having vanished (no, no ext4 on this computer…) but I could solve all of them. Unfortunately this is not true for the X problem. I tried reconfigering the gfx system with “sax2 -r” and it detects the graphics card (Intel 915GM) and the LCD (1400x1050) correctly. It even lets me choose the right resolution and colour depth, alas, the server does not start for the test and sax2 gives a generic error message.

Here is the log-file:

Any ideas why I can’t get back to the normal accelerated X server instead of the vesa server?

It looks like you are another victim of the recent xorg-x11-driver-video package update. See the last post in this thread for how to revert to the previous version.

xorg issue with intel-driver - openSUSE Forums

Thanks for the hint, reverting to the older version indeed solved my problem. It looks like the autoupdate had a deferred effect on my installation as I usually put my laptop to suspend mode instead of rebooting it.

And sorry for not searching the forum, I didn’t expect my problem to be any common as I thought it was related to the crash when waking up from suspend…

Don’t worry about it. I too thought it was something else wrong with my machine. I had been playing with a DVB-T USB dongle and thought it had somehow borked the hardware. Only when I did a google search did I find the other thread. Then I remembered that there had been an update. It’s not the sort of thing you expect to so badly broken by an update but it is.