No X after install of Nvidia G06 using the latest Tumbleweed

I just built a new computer. It is Intel based using a Nvidia 4060Ti GPU. After installing the latest version of Tumbleweed and subsquent updates I checked the repositories. The Nvidia repository was already added so using YAST I added the Nvidia G06 packages. After rebooting I can no longer start an X session. It will make 3 attempts and then go to a console login. I ran zypper to update anything that might need an update. Zypper reported every package was current.

How do I get back into X?


What exactly?

I ran zypper update but all packages are current.

Just went back to the Linux side and reinstalled all of the Nvidia G06 packages. YAST reran the configure script after the install. No change, still no X

It has probably nothing to do with your problem, but you should NOT use zypper up on Tumbleweed, only zypper dup .

appreciate that. first time on tumbleweed.

So go to Runlevel three, login, then type “startx”…

What happens?

I figured it out finally. Had to do with Secure Boot. I wasn’t doing the mok correctly at startup. I reinstalled all of the drivers and completed the mok script correctly and everything works great. Thanks for taking the time to respond.


Hello, I uninstall and install the driver again but when I run prime-select get-current says: No driver configured.
I have reinstalled the drivers a few times, it asks to write MOK on the boot everything seems to be fine but when I try to switch to nvidia nothing happens

Please don’t hijack other threads. You seem to have a different problem as the TO (he isn’t using prime). So please open a new dedicated thread with your problem.

This is the same issue

@jfespinal Hi, different hardware, please start a new thread :wink: