No wireless

Have today installed OpenSuse 11.2 and everything is great except my wireless isn’t working. I’ve read the stickies and hope I’ve done the right thing in checking various details. What I have is as follows:
Wireless LAN = Realtek WLAN controller
Kernel Driver = rtl8187

When I run iwlisy scan, I get no output (yes I ran as sudo)

Help please!:open_mouth:

On 07/13/2010 06:26 PM, djwake wrote:
>
> Have today installed OpenSuse 11.2 and everything is great except my
> wireless isn’t working. I’ve read the stickies and hope I’ve done the
> right thing in checking various details. What I have is as follows:
> Wireless LAN = Realtek WLAN controller
> Kernel Driver = rtl8187
>
> When I run iwlisy scan, I get no output (yes I ran as sudo)

The rtl8187 devices work “out of the box” and do not need firmware. Please post
the output of


lsusb

Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 002: ID 0bda:8189 Realtek Semiconductor Corp. RTL8187B Wirele02.11g 54Mbps Network Adapter
Bus 001 Device 003: ID 0bda:0158 Realtek Semiconductor Corp. Mass Storage De
Bus 001 Device 004: ID 04f2:b022 Chicony Electronics Co., Ltd Gateway USB 2.bcam
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub

On 07/13/2010 07:46 PM, djwake wrote:

> Bus 001 Device 002: ID 0bda:8189 Realtek Semiconductor Corp. RTL8187B
> Wirele02.11g 54Mbps Network Adapter

Your device is an RTL8187B, which is well supported. Are you using
NetworkManager? If not please switch to it, then run the following commands and
post the output:


/usr/sbin/iwconfig
sudo  /usr/sbin/iwlist scan

lo no wireless extensions.

eth0 no wireless extensions.

wmaster0 no wireless extensions.

wlan0 IEEE 802.11bg ESSID:""
Mode:Managed Frequency:2.412 GHz Access Point: Not-Associated
Tx-Power=20 dBm
Retry long limit:7 RTS thr: off Fragment thr: off
Power Management: off
Link Quality: 0 Signal level: 0 Noise level: 0
Rx invalid nwid: 0 Rx invalid crypt: 0 Rx invalid frag: 0
Tx excessive retries: 0 Invalid misc: 0 Missed beacon: 0

lo Interface doesn’t support scanning.

eth0 Interface doesn’t support scanning.

wmaster0 Interface doesn’t support scanning.

wlan0 Scan completed :
Cell 01 - Address: 00:1C: DF: D8: 00:ED
Channel:1
Frequency:2.412 GHz (Channel 1)
Quality=70/70 Signal level=-17 dBm
Encryption key: on
ESSID:“David & Carol”
Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 9 Mb/s
18 Mb/s; 36 Mb/s; 54 Mb/s
Bit Rates:6 Mb/s; 12 Mb/s; 24 Mb/s; 48 Mb/s
Mode:Master
Extra:tsf=00000016605c7dfc
Extra: Last beacon: 1941ms ago
IE: Unknown: 000D44617669642026204361726F6C
IE: Unknown: 010882848B961224486C
IE: Unknown: 030101
IE: Unknown: 2A0100
IE: Unknown: 32040C183060
IE: WPA Version 1
Group Cipher : TKIP
Pairwise Ciphers (1) : TKIP
Authentication Suites (1) : PSK
IE: Unknown: DD180050F2020101000003A4000027A4000042435E0062322F00
IE: Unknown: DD07000C4307000000
Cell 02 - Address: 00:1C:DF:88:3A:61
Channel:6
Frequency:2.437 GHz (Channel 6)
Quality=44/70 Signal level=-66 dBm
Encryption key:off
ESSID:“wolfe family network”
Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 9 Mb/s
18 Mb/s; 36 Mb/s; 54 Mb/s
Bit Rates:6 Mb/s; 12 Mb/s; 24 Mb/s; 48 Mb/s
Mode:Unknown/bug
Extra:tsf=0000005982a5dcc2
Extra: Last beacon: 1372ms ago
IE: Unknown: 0014776F6C66652066616D696C79206E6574776F726B
IE: Unknown: 010882848B961224486C
IE: Unknown: 030106
IE: Unknown: 32040C183060
IE: Unknown: 0706555320010B10
IE: Unknown: 33082001020304050607
IE: Unknown: 33082105060708090A0B
IE: Unknown: DD0E0050F204104A0001101044000101
IE: Unknown: 050400010000
IE: Unknown: 2A0104
IE: Unknown: 2D1AEC0117FFFF0000000000000000000000000000000C0000000000
IE: Unknown: 3D1606000000000000000000000000000000000000000000

Your postings indicate that you should be able to configure with ifup or
NetworkManager (your choice) and it should work. If this is a new 11.2
installation, you may have the routing and/or resolv.conf bugs, but those are
well covered on this list.

If it sheds any light on the issue, it works fine if I connect an ethernet cable.

On 07/14/2010 06:36 PM, djwake wrote:
>
> If it sheds any light on the issue, it works fine if I connect an
> ethernet cable.

Absolutely none.

How are you controlling your network devices? Are you using ifup or NetworkManager?

When I look in Global Options, it tells me I’m using Network Manager but I have no idea how I access it.

On 07/15/2010 01:46 AM, djwake wrote:
>
> lwfinger;2188716 Wrote:
>> On 07/14/2010 06:36 PM, djwake wrote:
>>>
>>> If it sheds any light on the issue, it works fine if I connect an
>>> ethernet cable.
>>
>> Absolutely none.
>>
>> How are you controlling your network devices? Are you using ifup or
>> NetworkManager?
>
> When I look in Global Options, it tells me I’m using Network Manager
> but I have no idea how I access it.

In the “system tray”, you should see an icon for the NetworkManager applet. The
details will depend on whether you are using KDE or Gnome.