No wireless networking and no NetworkManager app

Just installed 11.2 Milestone 8 on a Thinkpad T61p.
Wireless networking does not work. (Wired networking worked out of the box.)
When I use KMenu to open NetworkManager, nothing happens - no application opens up.
What should I try next?
(Yast tells me to use NetworkManager.)

Network Manager should be residing in your systray. Click it and go to ‘New Connection’.
Fill in the details as necessary in each section, choose ‘Connect Automatically’ Save and Connect.

When you open New Connection you should see available stations within range:

Depending on what version of the Manager you have it may look different:](](

Where do I find “new connection”? (Sorry, noob here.)

And shouldn’t the NetworkManager app come up?

Don’t you have it here:](

Nope. Nothing there.

Opne a terminal and type:

rpm -qi NetworkManager

Post result

NetworkManager is installed. It shows the latest version from vendor (openSUSE). I can’t paste results because OpenSUSE is running on another computer (with no working network connection).

Nope. Nothing there.

Re: caf4926 image above:

Do you see the right-pointing arrow to the left of the speaker icon in caf4926’s image? If you have this arrow and it’s pointing to the left, click on it to expand the other applet icons.

Is the Knetworkmanager icon visible now?

It may in fact be this you need to do in the terminal I think:

rpm -qi NetworkManager-kde4

Surely you looked under the Hide toggle?:open_mouth:

OK, I have it all figured out. It appears there are some kinks in 11.2 milestone 8. Here is my summary:

  1. The following menu item is not working: KMenu > Applications > System > Desktop Applet > Network Manager. Clicking that menu item produces no action.

  2. KMenu > Applications > Configure Desktop has a section for Network & Connectivity. In there is an icon for “Network Connections”. This link does work. (I assume it brings up the same app the broken link was intended to open.)

  3. In Configure Desktop > Network & Connectivity > Other > Tray Icon, I had “Show tray icon” checked. I had “Icon 1” with the “Wireless network interfaces” assigned to it. Yet nothing was showing up in my tray icon. (And it was not simply hidden.)

To resolve this I simply made “Icon 2” and assigned “Wireless network interfaces” to it. That gave me a tray icon. Once I had that, I was able to connect to my wireless network.

It is working for me now. Thanks for the help. I hope the people working on milestone 8 are aware of these minor issues.

On 10/13/2009 03:46 PM, MountainX wrote:
> It is working for me now. Thanks for the help. I hope the people
> working on milestone 8 are aware of these minor issues.

Not unless you file a bug report! Nearly everyone has no problem -
yours is the first report of this kind of trouble. My system brings up
KNM without any problems.

Good to hear you have made some progress. But I’m not sure it’s necessarily the best choice for you to be using development release.:expressionless:

Hmmm… why so little confidence in…

the last milestone before the first release candidate.

This development version is already better than Kubuntu IMO. (And that comes from a formerly very dedicated Ubuntu user.)

It seems other voices are encouraging more of us to use this development release.

If you’re interested in testing the next release of openSUSE you can start with openSUSE 11.2 Milestone 8.

Sticky: openSUSE-11.2 - CALL FOR TESTERS

I’m pleased so far.

@MountainX: Yes, we want folks to be testers of the development release. I just had the feeling you were struggling with a rather basic concept. My apologies, it may just be your unfamiliarity with openSUSE at this point that had you asking somewhat basic questions. Please enjoy using openSUSE. My mistake.:slight_smile:

Further to caf4926’s comment - yes we are indeed looking for testers. :slight_smile:

… but to put our comments into context, as a support community to openSUSE releases, we are a bit “gun shy” after having some new users install the alpha/beta releases (which are now called “milestone-x” releases), with the intent to use the releases as if they were operational releases, and then they fire off a rant about openSUSE because of the bugs they encounter, and they storm off in a huff.

Hence the many qualifications and warnings we give about 11.2 (before its official release), when we are trying to help new users with whom we are not familiar, on openSUSE milestone release support.

I guess it sort of goes without saying that the majority of us are openSUSE fans, and we are keen to see testing in openSUSE, and hence are thankful for any effort/support you can provide.

I hope your assessments of openSUSE continue to be good. In the past my experience has been that the best openSUSE experience typically comes about 2 to 3 months ( ! ) after the GM version. The reason for the 2 to 3 months is after the GM version is released, the “masses” descend on openSUSE and use it a LOT. Many bugs that were missed in the testing process are uncovered, and there are many updates immediately after the GM version to fix the more serious of these new bugs. That takes 2 to 3 months.

Many of us are looking forward to 11.2, as it promises to have some neat aspects that were not in 11.1. OpenSUSE 11.2 - openSUSE Thinks like:

  • improved desktop for both Gnome and KDE
  • new kernel 2.6.31 which has many improvements over the 2.6.27 kernel in 11.1 in both hardware support , hot plug mounting , wireless improvements, etc …
  • default use of ext4 files system instead of ext3
  • superior encryption capabilities
  • more automatic configuration of graphics
  • better netbook support
  • superior liveCD (capability to bit copy the liveCD to a USB stick for installation from a USB bootable computer)
    *]newer libraries, new application versions …

That list includes many of the reasons I decided to go with 11.2-8 at this time.

I’ve only been using Linux for about 2 years, and I have only used Ubuntu. I’m not a developer or admin. I’m just a casual user and I do not have time to go under the hood of Linux like I wish I could. And I had never touched KDE until a couple days ago. So moving to OpenSUSE KDE 11.2-8 was a pretty big move for me. I felt like a total newbie (still do).

But I’m not without some background. (I have a degree in computer science from way back, have installed Ubuntu about 200 times in the last 2 years, etc.)

That mix of experience, together with my hardware (Thinkpad T61p – this isn’t a machine I have to rely on day-to-day) and OpenSUSE 11.2-8 turned out to be a good match. In fact, this is by far the best experience I have ever had with any newly installed OS. No exaggeration!

I too have the same problem, but I’m using 11.1 and KDE 4. I tried doing as you advised but under Network & Connectivity there is no Other setting.

I’ve seen similar posts and they have advised using WICD, so will try that.

In 11.1, do you have either a “Manage Connections” context menu choice from the taskbar or another way to access the Configure-KDE Control Module?

That’s where you will find the choices I mentioned.

Hmmm . . neither, which means something is not right . . .