No wireless card found - SUSE 11.4 on Fujitsu Siemens AMILO La1703

Hey folks,

Sorry to bother you, but i’m stuck. I installed SUSE 11.4 on a rather old Fujitsu Siemens AMILO La1703 notebook and everything is okey till now, except wireless card is not recognized.

lspci, lsusb and dmesg all gave nothing with wireless, ethernet and/or 802 in it, except the wired Rhine II card

I think i had more luck browsing YAST’s hardware information, where i found this:
62: USB 00.0: 0000 Unclassified device
[Created at usb.122]
Unique ID: wkjR.WmLnN3rQmOE
Parent ID: k4bc.22MfGOBVe10
SysFS ID: /devices/pci0000:00/0000:00:10.4/usb1/1-5/1-5:1.0
SysFS BusID: 1-5:1.0
Hardware Class: unknown
Model: “Fujitsu Siemens Computers Unclassified device”
Hotplug: USB
Vendor: usb 0x0bf8 “Fujitsu Siemens Computers”
Device: usb 0x100f
Revision: “3.00”
Speed: 480 Mbps
Module Alias: “usb:v0BF8p100Fd0300dc00dsc00dp00icFFisc00ip00”
Config Status: cfg=no, avail=yes, need=no, active=unknown
Attached to: #57 (Hub)

My guess is this is the wireless adapter because of the “Speed: 480 Mbps” row.

I tried this:
http://forums.opensuse.org/english/get-technical-help-here/wireless/430399-no-wireless-amilo-la1703-laptop.html
but like dcw6 i had no luck.

Please, help,

Georgi

My wife had this machine in the past, the wireless worked with
ndiswrapper and the 32bit XP driver, we do no longer have this notebook
so I cannot provide more details.
Maybe there is meanwhile some better way (native linux driver) to make
its wlan work.


PC: oS 11.4 x86_64 | Intel Core i7-2600@3.40GHz | 16GB | KDE 4.6.0 |
GeForce GT 420
Eee PC 1201n: oS 12.1 x86_64 | Intel Atom 330@1.60GHz | 3GB | KDE 4.8.0
| nVidia ION
eCAFE 800: oS 12.1 i586 | AMD Geode LX 800@500MHz | 512MB | KDE 3.5.10 |
xf86-video-geode

Thank you Martin it worked :slight_smile:

For if anyone needs assistance this is the card: SourceForge.net: FujitsuSiemens Connect2Air E-5400 - ndiswrapper
And this is the how-to i used: Quick HOWTO : Ch13 : Linux Wireless Networking - Linux Home Networking