No wifi logon page in FF

I log on using KDE and NetworkManager connects to a wifi access point, but when I start FireFox I don’t get the wifi logon page. This used to work, and I’m not sure what I changed.

Are there any diagnostic data that I should collect? Any ideas? Thanks.

Please post:

ping -c1
ping -c1
cat /etc/resolv.conf


Maybe it’s a cache problem of firefox.
Delete your favo etc.

often you also have to go to a website that does not use https
Than Access points usually come with the login page


I mean your history NOT your favo

linux-0ksw:~ # ping -c1
PING ( 56(84) bytes of data.
--- ping statistics ---
1 packets transmitted, 0 received, 100% packet loss, time 0ms

linux-0ksw:~ # ping -c1
ping: Name or service not known

linux-0ksw:~ # cat /etc/resolv.conf
### /etc/resolv.conf file autogenerated by netconfig!
# Before you change this file manually, consider to define the
# static DNS configuration using the following variables in the
# /etc/sysconfig/network/config file:
# or disable DNS configuration updates via netconfig by setting:
# See also the netconfig(8) manual page and other documentation.
# Note: Manual change of this file disables netconfig too, but
# may get lost when this file contains comments or empty lines
# only, the netconfig settings are same with settings in this
# file and in case of a "netconfig update -f" call.
### Please remove (at least) this line when you modify the file!

Clearing the FF history does not resolve the problem. I also tried logging on with Gnome instead of KDE, and got the same results.

this result is normal you are not connected to access point

comes the login page if you visit a website that does not use ssl / https

I tried using the http schema and got the same results.

I think, only a DNS Problem.
As root:

netconfig update -f

I concur with this. It is a name resolution issue ie no valid name server applied.

That did it. Thanks.