No wifi interface after upgrading from Leap 15.1 to 15.2

Hello, happy new year forum!

I have a lenovo Y510P that had been running Leap 15.1. After I did the upgrade to Leap 15.2, I noticed that no wifi scan was availble in the networkmanager (KDE) anymore.

Command “ip link” showed no wireless interface either. “lspci” shows a "broadcom BCM43142 802.11b/g/n (rev 01).

That said, if I boot to the old kernel 4.12, wifi works fine just like before.

Package “boradcom-wl” from packman repo has always been in the system. I tried to install some other wl packages but it didn’t help.

You need to have the matching (running) kernel ‘broadcom-wl-kmp-default’ package installed as well.

OK. I do see that I only have the version 6.30…k4.12…package installed.

How am I supposed to install the k5.3 version then?

Do you have the packman repo configured? Is it the correct repo for Leap 15.2, or is it still the 15.1 repo? Check the repo url. The broadcom-wl drivers are there.

Sorry, I’m stupid !! I forgot to change the url of packman to 15.2…:shame:

That’s an easy mistake to make. Hopefully things are now working as they should.

But after I installed the broadcom-wl-kmp-default k5.3 version I still have no wifi available.

The wl interface is still missing.

Tried uninstall-reinstall all the wl packages without any improvement.

What’s worse, the k4.12 version has been replaced by the k5.3 version and I don’t even have wifi with kernel 4.12. :frowning:


rpm -qa broadcom* kernel*
uname -a

Do you have wired ethernet connectivity available?

Yeah I do have wired connection.

~> rpm -qa broadcom* kernel*
~> uname -a
Linux LENSU 5.3.18-lp152.57-default #1 SMP Fri Dec 4 07:27:58 UTC 2020 (7be5551) x86_64 x86_64 x86_64 GNU/Linux

Don’t know what’s the number in “lp152.14 or lp152.57” if those matter.

The kernel package looks to be ok for your running kernel.

Check if there is a driver loaded

/sbin/lspci -nnk | grep -iA3 net

I marked the Version-Release in bold:

I marked the Version-Release in bold:

k = kernel
lp152 = Leap 15.2
pm = Packman

If the module wl is not loaded as deano_ferrari mentioned, install the kernel package once more:

zypper in -f broadcom-wl-kmp-default

and run:

dracut -f

Both as root with

su -l

Many thanks!

I will not be near the machine for a few days but I’ll try those commands when I am and report back.

Hello, this is the output of your suggested command. My understanding is that wifi driver is not loaded?

# /sbin/lspci -nnk | grep -iA3 net
07:00.0 Ethernet controller [0200]: Qualcomm Atheros QCA8171 Gigabit Ethernet [1969:10a1] (rev 10)
        Subsystem: Lenovo Device [17aa:3800]
        Kernel driver in use: alx
        Kernel modules: alx
08:00.0 Network controller [0280]: Broadcom Inc. and subsidiaries BCM43142 802.11b/g/n [14e4:4365] (rev 01)
        Subsystem: Lenovo Device [17aa:0611]
        Kernel modules: wl

So then I did

zypper in -f broadcom-wl-kmp-default
dracut -f

and reboot.

Wifi scan is still not available. I ran

# /sbin/lspci -nnk | grep -iA3 net

again and the result is the same as above.

That shows that the wl driver is loaded.

Any suggestion on where else to look at?


ip link

Hello, I can’t always login the forum on that laptop so I am posting from the other machine now.

My ‘ip link’ has only the following 3 entries:

  1. lo
  2. eth
  3. teredo (yes I use teredo for some ipv6 access).

So the wl entry is missing I guess?
I tried using the “wicked” service and it couldn’t find any wireless connection.
I tried the hotkey for “flight mode” on/off and it didn’t seem to work either.

It’s strange because when I had access to the 4.12 kernel boot entry wifi works fine there. BTW now I don’t even have a boot entry for 4.12 kernel any more after some system update.

I finally found out the problem after more research on the internet.

I had to disable secure boot to get the wifi to work. So its driver is not signed.

I have never had a similar problem with opensuse although I have always enabled secure boot on opensuse machines.

Why is that this particular driver is not automatically signed by opensuse? Can I make it work with secure boot enabled now?

See here: