no WIFI for Lenova Thinkpad 3680-EU2

Please help me find/make functional my WIFI. Thank you in advance. :slight_smile:

My laptop is a Lenova Thinkpad x201 3860-EU2
My NIC card is Intel Gigabit 82577m
I am running OpenSUSE 13.2
I am a hw guy, sw is a foriegn language.

I am accessing the internet with a CAT6 cable. I would like have the option to go WIFI.

I clicked on the internet connection icon (connection editor) at the botton of the desktop screen and added the wireless router that is not seen even though it is a few feet away.

I looked online for OpenSUSE wireless and found instructions to run these commands:

linux-xk5z:/home/bta # hwinfo --wlan --short
linux-xk5z:/home/bta # sudo /sbin/lspci | grep thernet
00:19.0 Ethernet controller: Intel Corporation 82577LM Gigabit Network Connection (rev 06)
linux-xk5z:/home/bta # sudo /sbin/lspci -n
00:00.0 0600: 8086:0044 (rev 02)
00:02.0 0300: 8086:0046 (rev 02)
00:16.0 0780: 8086:3b64 (rev 06)
00:16.3 0700: 8086:3b67 (rev 06)
00:19.0 0200: 8086:10ea (rev 06)
00:1a.0 0c03: 8086:3b3c (rev 06)
00:1b.0 0403: 8086:3b56 (rev 06)
00:1c.0 0604: 8086:3b42 (rev 06)
00:1c.3 0604: 8086:3b48 (rev 06)
00:1d.0 0c03: 8086:3b34 (rev 06)
00:1e.0 0604: 8086:2448 (rev a6)
00:1f.0 0601: 8086:3b07 (rev 06)
00:1f.2 0101: 8086:3b2e (rev 06)
00:1f.3 0c05: 8086:3b30 (rev 06)
00:1f.5 0101: 8086:3b2d (rev 06)
00:1f.6 1180: 8086:3b32 (rev 06)
ff:00.0 0600: 8086:2c62 (rev 02)
ff:00.1 0600: 8086:2d01 (rev 02)
ff:02.0 0600: 8086:2d10 (rev 02)
ff:02.1 0600: 8086:2d11 (rev 02)
ff:02.2 0600: 8086:2d12 (rev 02)
ff:02.3 0600: 8086:2d13 (rev 02)

hwinfo --wlan --short was not helpful so I tried it withhout —short. In both instances the red lettering flashed through some changes too fast for me to see and ended with nothing to show.

I tried YaST>Network devices>Network Settings: “WARNING Network is currently handled by NetworkManager or completely disabled. YaST is unable to configure sone options.”

I tried Install/Remove Software, maybe something was missing… (I keep getting this annoying notification - Cannot access installation media hd:///?device=/dev/disk/by-id/scsi-1PHISON_USB3-part1(Medium 1). Please help me get rid of that notification.) I installed RPM groups>hardware>WIFI>“ipw-formware” and something else, forgot what but looked helpful/harmless.

I previously had Ubuntu before with functional WIFI and my wife presently has WIndows 7 pro with functional WIFI.

Go to YAST2 / Software / Software Repositories, find openSUSE 13.2 OSS which has the URL hd:/// and remove the checkmark from Enabled. OK and it should be gone.

Thank you Miuku. That allowed me to get a lot of updates. I still do not have WIFI capabilities but believe I am closer. :wink:

Install kernel-firmware and reboot. It should contain the Intel firmware that you need for the WLAN.