No Wifi after reinstall of LEAP 15

I reinstalled Leap 15 on a new hard drive. Before, the system worked without problems. I installed from a USB key, so did not have internet during install. After install, I do have ethernet but no Wifi.


> lspci
02:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8101/2/6E PCI Express Fast Ethernet controller (rev 05)
03:00.0 Network controller: Ralink corp. RT3090 Wireless 802.11n 1T/1R PCIe

The driver seems do be loaded


   22.326305] rt2800pci 0000:03:00.0 wlan1: renamed from wlan0
   33.794361] IPv6: ADDRCONF(NETDEV_UP): wlan1: link is not ready

Wlan is hard-blocked, though. Enabled in BIOS.


0: ideapad_bluetooth: Bluetooth
        Soft blocked: no
        Hard blocked: no
1: phy0: Wireless LAN
        Soft blocked: no
        Hard blocked: yes
2: hci0: Bluetooth
        Soft blocked: no
        Hard blocked: no

Unblocking does not change the hardblock.

Here is the modinfo, which seems fine:


k/rt2x00/rt2800pci.ko
license:        GPL
firmware:       rt2860.bin
description:    Ralink RT2800 PCI & PCMCIA Wireless LAN driver.
version:        2.3.0
author:         http://rt2x00.serialmonkey.com
suserelease:    openSUSE Leap 15.0
srcversion:     540E1502CE586B9C43C89F6
alias:          pci:v00001814d0000539Fsv*sd*bc*sc*i*
alias:          pci:v00001814d0000539Bsv*sd*bc*sc*i*
alias:          pci:v00001814d0000539Asv*sd*bc*sc*i*
alias:          pci:v00001814d00005392sv*sd*bc*sc*i*
alias:          pci:v00001814d00005390sv*sd*bc*sc*i*
alias:          pci:v00001814d00005362sv*sd*bc*sc*i*
alias:          pci:v00001814d00005360sv*sd*bc*sc*i*
alias:          pci:v00001814d0000359Fsv*sd*bc*sc*i*
alias:          pci:v00001814d00003593sv*sd*bc*sc*i*
alias:          pci:v00001814d00003592sv*sd*bc*sc*i*
alias:          pci:v00001814d00003562sv*sd*bc*sc*i*
alias:          pci:v00001814d00003062sv*sd*bc*sc*i*
alias:          pci:v00001814d00003060sv*sd*bc*sc*i*
alias:          pci:v00001432d00007722sv*sd*bc*sc*i*
alias:          pci:v00001432d00007711sv*sd*bc*sc*i*
alias:          pci:v00001814d00003390sv*sd*bc*sc*i*
alias:          pci:v00001814d00003290sv*sd*bc*sc*i*
alias:          pci:v00001A3Bd00001059sv*sd*bc*sc*i*
alias:          pci:v00001462d0000891Asv*sd*bc*sc*i*
alias:          pci:v00001432d00007768sv*sd*bc*sc*i*
alias:          pci:v00001432d00007758sv*sd*bc*sc*i*
alias:          pci:v00001432d00007748sv*sd*bc*sc*i*
alias:          pci:v00001432d00007738sv*sd*bc*sc*i*
alias:          pci:v00001432d00007728sv*sd*bc*sc*i*
alias:          pci:v00001432d00007727sv*sd*bc*sc*i*
alias:          pci:v00001432d00007708sv*sd*bc*sc*i*
alias:          pci:v00001814d00003092sv*sd*bc*sc*i*
alias:          pci:v00001814d00003091sv*sd*bc*sc*i*
alias:          pci:v00001814d00003090sv*sd*bc*sc*i*
alias:          pci:v00001814d00000781sv*sd*bc*sc*i*
alias:          pci:v00001814d00000701sv*sd*bc*sc*i*
alias:          pci:v00001814d00000681sv*sd*bc*sc*i*
alias:          pci:v00001814d00000601sv*sd*bc*sc*i*
depends:        rt2x00lib,rt2800lib,rt2800mmio,rt2x00mmio,rt2x00pci,eeprom_93cx6
retpoline:      Y
intree:         Y
vermagic:       4.12.14-lp150.12.48-default SMP mod_unload modversions retpoline 
parm:           nohwcrypt:Disable hardware encryption. (bool)

No mention of any firmware loading:

dmesg | grep firmware

is empty.

This must be a configuration problem, as wifi worked before also on Leap 15.

Thanks for any help in advance.

Hard Blocked means:
Unblock it with a key-combination, mostly Fn+Fx key…

In my case the Fn+Fx key only changes the softblock status. There is another switch on the side of the laptop that also only toggles softblock status.

Check if disabled in BIOS perhaps.

It is enabled in the BIOS. I tried to toggle forth and back without any effect.

I missed your previous comment regarding firmware. Install the kernel-firmware package. That will provide the necessary rt2860.bin firmware. See how that goes.

kernel-firmware is installed. rt2860.bin is installed in /lib/firmware/rt2860.bin

Post

/sbin/lspci -nnk | grep -iA3 net

I did reboot into the installation usb key and tried to configure wlan there. No network showed up. I am now suspecting a hardware problem. During hard drive replacement I had to manipulate the antenna. I will have to open the laptop again and will report back.

Ok, thanks for the update.

Have you tried (and is it possible) installing an older kernel-firmware?

I have locked mine to 20190118-lp150.2.12.1


02:00.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8101/2/6E PCI Express Fast Ethernet controller [10ec:8136] (rev 05)
        Subsystem: Lenovo Device [17aa:397b]
        Kernel driver in use: r8169
        Kernel modules: r8169
03:00.0 Network controller [0280]: Ralink corp. RT3090 Wireless 802.11n 1T/1R PCIe [1814:3090]
        Subsystem: Lenovo Device [17aa:f101]
        Kernel driver in use: rt2800pci
        Kernel modules: rt2800pci

I could not find anything specific on the hardware side. I have now decided to plug in a USB dongle which work on another installation. Strangely, the dongle does not work.


lsusb
...
Bus 002 Device 003: ID 7392:7811 Edimax Technology Co., Ltd EW-7811Un 802.11n Wireless Adapter [Realtek RTL8188CUS]
...


ip addr
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
2: eth0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc pfifo_fast state DOWN group default qlen 1000
    link/ether f0:de:f1:83:2a:4d brd ff:ff:ff:ff:ff:ff
3: wlan0: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN group default qlen 1000
    link/ether 06:0a:00:1e:b0:de brd ff:ff:ff:ff:ff:ff
5: eth1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP group default qlen 1000
    link/ether 80:1f:02:75:cc:42 brd ff:ff:ff:ff:ff:ff
    inet 192.168.1.100/24 brd 192.168.7.255 scope global noprefixroute dynamic eth1
       valid_lft 31534752sec preferred_lft 31534752sec
    inet6 fe80::d163:9c10:6702:a806/64 scope link noprefixroute 
       valid_lft forever preferred_lft forever
6: wlan1: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN group default qlen 1000
    link/ether ae:99:67:a8:7b:c4 brd ff:ff:ff:ff:ff:ff

Here is how far I got with the dongle:


sudo ip link set wlan1 up

brings up the interface.


sudo iwlist scan

now lists the wireless networks.


nmcli dev wifi con mywifi password key
Error: No network with SSID 'mywifi' found.

As the wifi device nodes are present, and you can apparently scan successfully for available wifi networks, it should be possible to connect. Are you sure that the typed SSID was correct? As you have two wifi devices connected, are you sure that they are both compatible with the wireless protocol used by your AP? It would be nice for you to post the scanning output with us to see for ourselves as well. You can also use the following command to get that information…

nmcli d wifi list

Try creating a connection profile like this (and choose the preferred wifi device explicitly eg wlan1

nmcli c add type wifi con-name <name> ifname wlan1 ssid <ssid>

then add the credentials…

nmcli c modify <name> wifi-sec.key-mgmt wpa-psk wifi-sec.psk <password>

sudo rfkill list
0: ideapad_bluetooth: Bluetooth
        Soft blocked: no
        Hard blocked: no
1: phy0: Wireless LAN
        Soft blocked: no
        Hard blocked: yes
2: phy1: Wireless LAN
        Soft blocked: no
        Hard blocked: no
3: hci0: Bluetooth
        Soft blocked: no
        Hard blocked: no


nmcli radio wifi on

does not change anything.


nmcli device
DEVICE  TYPE      STATE        CONNECTION         
eth0    ethernet  connected    Wired connection 1 
wlan0   wifi      unavailable  --                 
wlan1   wifi      unavailable  --                 
lo      loopback  unmanaged    --                 

I could get the dongle working by blacklisting the kernel module for the internal wifi (rt2800pci).

Still, help to get it working would be appreciated. The internal wifi seems to mess enough with the system so that the dongle cannot be activated although it works fine when alone.

Do you try to unblock the wifi with an key-combination?

I mentioned earlier in the thread that I have tried everything in this regard (switch/Fn-Combo/Bios). My current diagnosis is a regression in the driver or firmware The hard block is merely a symptom. This is due to the fact that blacklisting is required to get the other wlan adpator to work. I am a bit pessimistic that the issue can be solved as the driver is probably not used by many any more. It would be nice to report somewhere, though.

We have the same issue here after a fresh install. No WIFI Network on taskbar.

1.Yast>System>Network Settings>Network Setup Method>NetworkManager Service>If properly set, switch to wicked and switch back to NetworkManager.

This operation triggers the WIFI network on taskbar here. SWITCHING TO WICKED REPRODUCE THE EXACT PROBLEM THAT WE HAVE AFTER A FRESH INSTALL: No WIFI Icon ON Taskbar.

The same can be done during the fresh install in the Installation Settings Page or Menu>>Network Configuration=Switch from one to the other> Wicked to NetworkManager.

This method is always working.

Other way around to wake up the WIFI

2.Yast>System>services manager:
3. Network Manager = Start/on boot
4. systemd-networkd = Start/manually
5.Apply chages and restart to see if it works.