No wi-fi on Asus 1215N laptop

(Linux noob here)

I have just switched from Wİndows7 to SuSe 12.1 and facing this annoying problem. I let the updates download and install in case it caused by a bug but now i’m %100 positive that’s certainly not the case.
At the moment I’m using the wired connection (ethernet) but I’d very much like to connect to my wireless network.

My desktop manager is Gnome and there are only two options in the “Network” list: “Wired” and “Proxy”. I think Proxy has nothing to do with wi-fi. If i disconnect the network cable no internet access and no connection can be found… I’m sure that i’m in wi-fi range because it was working fine in Win7.

What should I do to make my wi-fi controller work?

On 04/17/2012 04:16 PM, DazTheT4z wrote:
>
> (Linux noob here)
>
> I have just switched from Wİndows7 to SuSe 12.1 and facing this
> annoying problem. I let the updates download and install in case it
> caused by a bug but now i’m %100 positive that’s certainly not the case.
>
> At the moment I’m using the wired connection (ethernet) but I’d very
> much like to connect to my wireless network.
>
> My desktop manager is Gnome and there are only two options in the
> “Network” list: “Wired” and “Proxy”. I think Proxy has nothing to do
> with wi-fi. If i disconnect the network cable no internet access and no
> connection can be found… I’m sure that i’m in wi-fi range because it
> was working fine in Win7.
>
> What should I do to make my wi-fi controller work?

First of all, go to the wireless forum and read the stickies there. That will
give you some preliminary info on how to report the problem. Do you understand
that we have no idea what wifi card is in an Asus 1215N? In fact, it is not
certain that all 1215N’s have the same card.

OK, after typing “/sbin/lspci” in the console i found out that my wireless controller is "Broadcom Corporation BCM4313 802.11b/g/n Wireless LAN Controller (rev01)

What next? and why SuSe doesn’t recognize these type of most common devices?

On 04/17/2012 05:26 PM, DazTheT4z wrote:
>
> OK, after typing “/sbin/lspci” in the console i found out that my
> wireless controller is "Broadcom Corporation BCM4313 802.11b/g/n
> Wireless LAN Controller (rev01)
>
> What next? and why SuSe doesn’t recognize these type of most common
> devices?

Your device is not common - it is quite new.

Have you installed the firmware? Did you look at the output of the dmesg
command? Note that I did NOT ask you to post that output here. That is the first
step to check.

That device is likely too new for the standard kernel used in openSUSE 12.1. I
do not remember exactly when b43 started handling the 4313, but brcmsmac has
been around for a while.

To get the latest version of each of those drivers, you need to enable the
wireless repo at
http://download.opensuse.org/repositories/driver:/wireless/openSUSE_12.1 and
install the compat-wireless package for your device. if you select driver b43,
the firmware will still be needed. Firmware for brcmsmac should be installed,
but it comes from the kernel-firmware package.

thank you very much. i typed “broadcom” in software manager and few drivers came up. installed them and now it works.

a kernel was also installed alongside the driver though. after installing that kernel, i see several other options in the boot menu now.

I guess that the drivers were also kernel modules that are existing in several flavors according to the different kernel flavors. And I guess further that you have not only installed the drivers/modules that were fitting to the kernel flavor that you were using already (for example: desktop) but also at least for some other kernel module (for example: default) - so the other kernel flavor(s) were installed as dependencies of that modules.

You (and we) could see the kernel flavor you are using now if you would copy and paste (with the mouse) in a terminal emulator (GNOME terminal, konsole, …)

uname -a

and paste the output here.

Personally I would not rate it a problem to use different kernel flavors parallel - for example according to a test I read in the (german version of) the Linux Magazine openSUSE’s “default” kernel should use less power than the (a bit faster) “desktop” kernel - so on a laptop it would make sense to use kernel-default if you are using the battery and kernel-desktop if you want to have more performance.

I would appreciate if you let us know what driver you are using now
and the hexadecimal PCI ID of your wireless device (to help me to tag the thread and to help others with to find).

Both information would be included in the output of

/sbin/lspci -nnk | grep -A2 -i net

or if you are able to find and copy the right lines for your wireless device just

/sbin/lspci -nnk

.

Regards
Martin