No Wallpaper

I’ve recently upgraded from KDE 4.0 to 4.1.2 and I can no longer change my wallpaper from the default green SuSE background. I have tried turning compositing and desktop effects on and off, but to no avail. I have also tried using all of the three different desktop choice and am currently using the plain desktop. The slideshow option does not allow for modification either. I am running 64-bit openSuSE 11.0 with the onboard Intel G31 GMA (which is detected as a G33).

Thanks for the help.

make sure you have all the updates for 4.1.2 you might have to go into yast2 and browse repositories and update that way
i know i had to do it that way

side note make sure you have all the repos add for 4.1.2 also
Index of /repositories/KDE:/KDE4:/Factory:/Desktop/openSUSE_11.0
Index of /repositories/KDE:/Qt/openSUSE_11.0
Index of /repositories/KDE:/KDE4:/Factory:/Extra-Apps/openSUSE_11.0
Index of /repositories/KDE:/KDE4:/Community/openSUSE_11.0_KDE4_Factory_Desktop

I’ve added the repositories you listed here and manually gone through and upgraded everything kde4-related; however, the wallpaper is still not working. What are the kde4.1.2 repositories you didn’t list?

them are all the kde 4.1 repo’s
theres got to be an update your missing somewhere cause i’ve done 2 desktops now and working on a 3rd and after the updates everything works great