No Virtualization section in Yast (openSuSE 12.2)

I just recently installed a couple of test servers that I want to run windows in a Xen VM on. I installed openSuSE 12.2, but when I open up Yast2, there is not Virtualization section. I read that the hardware must support virtualization technology and must be enabled. I looked in BIOS and saw that it was. I also ran the following command and got the following output:

linux-k63v:~ # egrep ‘(vmx|svm)’ /proc/cpuinfoflags : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe lm constant_tsc arch_perfmon pebs bts aperfmperf pni dtes64 monitor ds_cpl vmx est tm2 ssse3 cx16 xtpr pdcm lahf_lm dtherm tpr_shadow
flags : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe lm constant_tsc arch_perfmon pebs bts aperfmperf pni dtes64 monitor ds_cpl vmx est tm2 ssse3 cx16 xtpr pdcm lahf_lm dtherm tpr_shadow

I also read a post from a few weeks ago, where someone else had the same issue, but at least got the virtualization section to come up after installing yast-vm. I attempted to do the same thing, but I got the following message.

linux-k63v:~ # zypper install yast-vm
Loading repository data…
Reading installed packages…
‘yast-vm’ not found in package names. Trying capabilities.
No provider of ‘yast-vm’ found.
Resolving package dependencies…
Nothing to do.

So I ran it asking for yast2-vm and here is what I got.

linux-k63v:~ # zypper install yast2-vm
Loading repository data…
Reading installed packages…
‘yast2-vm’ is already installed.
No update candidate for ‘yast2-vm-2.22.1-2.1.2.i586’. The highest available version is already installed.
Resolving package dependencies…

What am I doing wrong? I am new to openSuSe (although I have used other linux distros), so I hope this is not a stupid question.

Thanks,
Keith

Here is what I see in YaST of openSUSE 12.2:

http://paste.opensuse.org/view/download/41316552

As fas as I can tell, this comes from the application yast2-vm which can look for in YaST. I might suggest you go with VirtualBox. Read About it here:

http://forums.opensuse.org/content/59-how-install-virtualbox-opensuse-11-4-12-1-tumbleweed.html

I have links to the latest version you can find here:

http://forums.opensuse.org/english/get-technical-help-here/virtualization/478410-oracle-releases-vm-virtualbox-4-2-a.html

Thank You,

Thank you for your response. I am familiar with virtualbox, but one thing I did not mention in my original post is I am tasked with mirroring our production environment in a lab, but in 12.2. The production environment is currently running 11.4. It is running Xen, which the developers are comfortable with. I would prefer not to change that unless absolutely required. I do not have the Virtualization nor the support sections and I have it installed on 12 systems with various hardware and I get the same thing on all of them. That is why I figured I am just doing something stupid.

Thanks,
Keith

It sounds like the the YaST2-vm package is installed. You could install the patterns-openSUSE-xen_server (Meta package for pattern xen_server) package and see what you get or run yast2 from terminal or run YaST GUI from a desktop and see what you get.

Thank You,

On 2012-10-03 16:36, keithouellette wrote:

> So I ran it asking for yast2-vm and here is what I got.
>
>
> linux-k63v:~ # zypper install yast2-vm
> Loading repository data…
> Reading installed packages…
> ‘yast2-vm’ is already installed.
> No update candidate for ‘yast2-vm-2.22.1-2.1.2.i586’. The highest
> available version is already installed.
> Resolving package dependencies…

Are you using 32 bit nowdays? Why?


Cheers / Saludos,

Carlos E. R.
(from 12.1 x86_64 “Asparagus” at Telcontar)

Thank you. I installed patters as you suggest and I now get the Virtualization section in Yast. When I tried to get into the Virtual Machine Manager, it said that I had to boot into the Xen kernel. I installed kernel-xen in software manager, but when I rebooted, it did not come up as an option in the grub2 menu. Is there something else I am missing?

So consider that I am using VirtualBox and not zen. However, if a new kernel was installed, perhaps you need to run the Grub 2 terminal update command as root?

sudo /usr/sbin/grub2-mkconfig --output=/boot/grub2/grub.cfg

I have a complete Grub 2 bash utility that includes the same command you can find here: GNU Grub2 Command Help/Config Editor - Version: 1.85 - Blogs - openSUSE Forums

Thank You,

Thank you again for your response. I tried to issue that command and here is what I got:

linux-ns8t:~ # /usr/sbin/grub2-mkconfig --output=/boot/grub2/grub.cfg
Generating grub.cfg …
Found linux image: /boot/vmlinuz-3.4.6-2.10-default
Found initrd image: /boot/initrd-3.4.6-2.10-default
No volume groups found
done
linux-ns8t:~ # ls /boot
backup_mbr symtypes-3.4.6-2.10-default.gz
boot symtypes-3.4.6-2.10-xen.gz
boot.readme symvers-3.4.6-2.10-default.gz
config-3.4.6-2.10-default symvers-3.4.6-2.10-xen.gz
config-3.4.6-2.10-xen sysctl.conf-3.4.6-2.10-default
do_purge_kernels sysctl.conf-3.4.6-2.10-xen
grub System.map-3.4.6-2.10-default
grub2 System.map-3.4.6-2.10-xen
initrd vmlinux-3.4.6-2.10-default.gz
initrd-3.4.6-2.10-default vmlinux-3.4.6-2.10-xen.gz
initrd-3.4.6-2.10-xen vmlinuz
initrd-xen vmlinuz-3.4.6-2.10-default
memtest.bin vmlinuz-3.4.6-2.10-xen
message vmlinuz-xen

I also went to openSUSE 12.2: Chapter 12. Installing Multiple Kernel Versions to try to figure it out, but according to this site, I should not have to do anything but install the kernel. So here is what I did not install the kernel, maybe there lies the issue. I went to software management in yast and clicked on kernel-xen, then clicked intall. I am assuming that should take care of all dependancies, if any. Is there something I am missing.

Thanks,
Keith

Yes you must install kernel-xen, YaST should meet any requirements and then you must restart your PC. In the Grub 2 menu, select the Advanced menu and then select the correct kernel by name. The single top entry in the Grub 2 menu is the newest kernel version, which may or may not be xen. You can also use my FastBoot bash script and select the xen kernel before you restart.

GNU Grub2 Command Help/Config Editor - Version: 1.85 - Blogs - openSUSE Forums

Thank You,

Xen support was dropped out of 32-bit openSUSE after 11.4. And, although 12.1 still offers to install Xen host in 32-bit edition, it’s just a broken package: no hypervisor was ever built for this edition.

You should either go 64-bit with openSUSE 12.1 and onwards, or stay with good old openSUSE 11.4.

Thank you! I guess that was what Carlos was trying to subtlely say earlier and I did not pick up on it. I have 10 servers I am installing and some are old, which is why I started with 32 bit. For the ones that need Xen, I can use the 64 bit. Thanks again.