No video or sound in Youtube.


All of a sudden youtube doesn’t work anymore. Yesterday it worked fine. Now I get the message: You have Java script disabled or you have an older version of adobe flash player. I downloaded and installed the newest flash player but still the same problem.
Java is also enabled so I don’t know where this error is for?
Can anyone help me please?
Thanks in advance!!!

you probably have javascript turned off in your browser (reference: JavaScript / Flash Player error : Common Error Messages - YouTube Help). Check the options of the browser to make sure javascript is enabled

I followed the tutorial youtube error help. I uninstalled and reinstalled the newest adobe flash player. I uninstalled and reinstalled firefox. And all the boxes are checked in firefox enable java script. But still same problem.
And its weird that 2 days ago I had no problems with youtube.
And now all of a sudden I do?

Did you do any update in your system (or have automatic updates option on)?

Have you installed the NoScript plugin for Firefox, which disables Javascript by default?
Look in the lower right corner for the “S” icon and click on it to allow

Yes I have automatic updates option on.

do you think its because of that?

And I don’t have NoScript plugin for Firefox installed. So I don’t see the S in the lower right corner.

Any other ideas?
Because else I’m going to format my partitions and reinstall Suse all over again. Cause with a clean installation of Suse my sound and video worked in Youtube?
Or is this a bad idea?

A very bad idea. You cannot reinstall the system just because the sound is not working. Investigate a bit more. Try another browser such as Konqueror or Opera. Try to play some music with vlc or xmms or mplayer. Check if pulseaudio is running and check that output is ok with pavucontrol. There are many things to check and try before considering an OS reinstall !

Indeed. Reinstalling does not make sense. Did you try moving your /home/YOURUSERNAME/.mozilla/firefox folder? That would give FF a brand new start.

Also check the PCM volume slider in your mixer. If you don’t see it, install alsamixer and run it from a terminal window, you might see it there.

Please also state if you’re running 32/64 bit, KDE4/KDE3/Gnome etc.

I’m running kde4 and 64 bits Suse.
and in Konqueror I have the same problem… Flash plugin missing.
Vlc mediaplayer works fine.
I have video and sound. And in Yast softwaremanagement I can see Flash player installed.
I dont’t know why firefox keeps telling me to install flashplayer?

It may be that Firefox does not find the plugin. Have a look at this link on how to install it :

Managing the Flash plugin

Also in the Firefox Preferences check the application used for Shockwave Flash File.

Same here, did an update restarted and now flash does not work. Second time in 6 months this has happened. Search the forums, Uninstall, reinstall, restart browser… 2 hours later. Only have packman enabled and suse repos. WTF is with flash and suse 64bit?

finally found this How install flash 64 bit? - Page 2 - openSUSE Forums
Get the 64 bit from here Adobe Labs - Downloads: Flash Player 10 for 64-bit Linux
Put it in your root>usr>lib64>browser-plugins folder
That got it working again. Wish I had found that thread 2 hours ago.