No video- no flash player

I’m using KDE, 32 bit. This is a new install, and I’m not familiar with Opensuse. But so far, it’s pretty nice! But now I need to get video working, and I’ll try to explain what I’ve got so far. I’ve installed the multimedia codecs from, even though I really only want to get flash working. When I try rpm -qa | grep flash bash shows


in Firefox, about:plugins shows
QuickTime Plug-in 7.6.9

File: gecko-mediaplayer-qt.soVersion: Gecko Media Player 1.0.7

When I look at add-ons in Firefox, this is how I am setup. I have installed Totem, even though it is normally associated with GNOME and I also use KDE. Compare EVERY Line here on my Working system to yours… (I am not sure that Adobe reader is required however):

I am using just Mplayer and there are three ways to go, but this is what I use (Terminal Command):

Command: **rpm --query --queryformat '%{NAME}-%{VERSION}-%{RELEASE}-%{ARCH} -> %{VENDOR}
' MPlayer mplayerplug-in smplayer**

MPlayer-1.1+35127-2.15-x86_64 ->
smplayer-0.8.3-1.1-x86_64 ->

You should expect to have three -> MPLayer <- packages installed from Packman.
----------------> MPlayer <---------------------- from the Packman Repository.
----------------> smplayer <--------------------- from the Packman Repository.

Youcan see a lot more on your setup looking at this bash script called mmcheck:

I normally use 64 bit. There has been a few cases where the video hardware was at fault such as a very old SIS chipset, an old nVIDIA 6200 or older series and some older ATI cards. Your video hardware does matter when trying to view the very latest movies and clips.

Thank You,

I liked the mmcheck program, but it didn’t open when I tried to run it. I may have screwed it up.

rm ~/bin/mmcheck ; wget -nc -O ~/bin/mmcheck ; chmod +x ~/bin/mmcheck
rm: cannot remove ‘/root/bin/mmcheck’: No such file or directory
--2013-01-08 20:56:50--
Resolving (, 2a01:430:28::3
Connecting to (||:80... connected.
HTTP request sent, awaiting response... 200 OK
Cookie coming from attempted to set domain to
Cookie coming from attempted to set domain to
Length: unspecified [text/plain]
Saving to: `/root/bin/mmcheck'

     &lt;=&gt;                                   ] 23,529       120K/s   in 0.2s    

2013-01-08 20:56:52 (120 KB/s) - `/root/bin/mmcheck' saved [23529]

linux-jezh:/home/larry # mmcheck
If 'mmcheck' is not a typo you can use command-not-found to lookup the package that contains it, like this:
    cnf mmcheck

I went ot the ‘ad software’ section of YaST, and selected everything that showed up under Totem. Then I tried playing a Youtube video in Firefox, and all I have is a black box where the video goes. Same as before. I did a pastebin for the contents of about:plugins, as it’s too large for a post here.

I just installed mplayer, I’ll have to close Firefox and reopen it to try and see what happens with video, but I want to post this first.

Also here’s the output from the mplayer script.

rpm --query --queryformat '%{NAME}-%{VERSION}-%{RELEASE}-%{ARCH} -> %{VENDOR}
' MPlayer mplayerplug-in smplayer
MPlayer-1.1+35127-2.15-i586 ->
package mplayerplug-in is not installed
smplayer-0.8.3-1.1-i586 ->

When I search for mplayerplug-in, YaST shows"no results."

I use only the two mplayer files shown and nothing from the gecko. Installing too many files can be just as bad as too few. If more than one serves up a video or audio format, often the last loaded is in control. Notice in my Firefox add-in screen that Totem is being used in all video/audio places. You should see the same on your setup. Then you just need the media files recommended in mmcheck and flash. You can test your flash player here: Adobe - Flash Player

Its hard for me to know exactly what is wrong, but we also need to know your video hardware type to see if it is supported with the latest stuff or not.

Thank You,

Just as an afterthought, I originally asked about flash in another part of the forum.caf4926 gave me what he was running, but it was all 64 bit, and I held off because I have a 32 bit system. I’m under the assumption that installing a 64 bit program on a 32 bit system is not going to work. Is that correct? (post #10)

I’m under the assumption that installing a 64 bit program on a 32 bit system is not going to work. Is that correct?

Yes, that is correct.

Via Yast
Create a new user and login with it. Start firefox and try it as is…

If it still fails.Logout and back in to your normal account. Go to Yast software management and delete gecko-mediaplayer
And install totem-browser-plugin

It will pull in some other stuff…

Now try again

Removed gecko-mediaplayer, totem-browser-plugin was already installed. No change, but shockwave-flash is now listed under about:plugins in Firefox.

pastebin from Firefox: Shockwave Flash File: Version: Shockwave Fla -

Firefox still “flashes” a black box, the “box” is where the video goes, and it goes through three or four “flashes,” as if the video is trying to work, but it fails. Google just shows “Could not load shockwave flash.”

Did we establish if you had tried Google Chrome?

Have you tried renaming your current .mozilla to test firefox in a clean profile?

I’m posting this from Chrome now. I made another user to test Firefox, results were the same. I wondered what could change when I did that, as the system is the same installed programs. I’m also not expecting much when I download some video codecs, because while I want to play Youtube, Ted, etc, (etc being Redtube, and…), all the video codecs seem to be for playing DVDs. I do that with a DVD player on my TV.

I see others saying that they have video, and are trying to get movies, or other stuff. Wonder how they got video to work, and I haven’t?

EDIT: Just switched to the other user I created, and Firefox does the same, three flashes of a black box, then just a solid black box, no video. Was surprised that Google Chrome wasn’t in the other user, so I see what you mean by a fresh environment.

Why not tell us about your video hardware. The company, like AMD, nVIDIA or Intel & Chipset or model number.

Thank You,

I am in the same boat, but with a twist. I have an OpenSuse 12.2 64 bit running a late amd desktop - not working. Chrome works but I want to capture some flash streams for off line use, and Firefox with the Ant toolbar is perfect for that. But FF does not play flash video.

I have a 64bit Notebook running OpenSuse 11.x and it does everything I need as far as watching flash video. FF and Chrome both play video, and the Ant toolbar in FF works well. This could become my machine of choice except for the irritating feature where the screen dims after 30 seconds. It is very hard to watch dimmed video.

So, is ther a way to expect a list of the chosen programs in my machines so that I can compare them, and perhaps replicate the stuff I have loaded in the Notebook?

Melbourne, Aistralia

I do not normally reply to my own posts, but I should add that I have just run the OneClick Multimedia process, in the hope that the extraneous **** may have been removed and the right stuff installed. Still no result. But i like the idea. So back to the program list idea.

I think the short answer is Nvidia and AMD. Here’s a little more long winded answer;

Just realized that, although I was seeing “Nvidia” at boot, that was another computer, not the one I have Opensuse on. Sorry.

Checked the Arch Linux wiki for flash player.

It said to run cat /proc/cpuinfo | grep sse2 and if it returned nothing, then that was the problem. I tried it, and it returned nothing. Solution is supposed to be using an older version of flash.

When I run the same terminal command, it fills up half of the screen though I can’t say I have seen that sse2 support is required by your CPU for flash video to work. I have requested info on your video and perhaps we need to know about your CPU hardware as well. I have a bash script that produces a lot of good data you could post here in the forum, if you will, inside of code # tags in the advanced message editor:

H.I. Hardware Information - A Bash script to install and run inxi with default options!

Without knowing more about your hardware, there is little reason to post any more reply’s to this message thread.

Thank You,

jdmcdaniel3, I tried all 3 ways of getting hi…(???. I was having a lot of trouble typing that with a straight face. And I had another grin session as I typed that second line, too! Anyways…), and all I got was nada when I tried to run “hi.”

linux-jezh:/home/larry # rm ~/bin/hi ; wget -nc -O ~/bin/hi ; chmod +x ~/bin/hi
--2013-01-12 01:51:16--
Resolving (, 2a01:430:28::3
Connecting to (||:80... connected.
HTTP request sent, awaiting response... 200 OK
Cookie coming from attempted to set domain to
Cookie coming from attempted to set domain to
Length: 5036 (4.9K) [text/plain]
Saving to: `/root/bin/hi'

100%======================================&gt;] 5,036       --.-K/s   in 0.001s  

2013-01-12 01:51:18 (4.86 MB/s) - `/root/bin/hi' saved [5036/5036]

linux-jezh:/home/larry # hi
If 'hi' is not a typo you can use command-not-found to lookup the package that contains it, like this:
    cnf hi

Sounds like what I need, but for some reason I can’t get there from here.

**Do not run **the program as ROOT from terminal! I can see that it is saved at /root/bin/hi, but this folder is NOT in your path. There is nothing in my blog that requires you to be root to get this file. As a NORMAL user, open terminal, and run this command:

**rm ~/bin/hi ; wget -nc -O ~/bin/hi ; chmod +x ~/bin/hi**

The package inxi must be downloaded the first time you run hi from your /home/username/bin folder and install it. That install will request the root password when it should be used. Then you should get the correct results.

Thank You,

“Say the magic word and the duck comes down from the ceiling.”

System:    Host: linux-jezh Kernel: 3.4.11-2.16-default i686 (32 bit) 
           Desktop KDE 4.8.5 Distro: openSUSE 12.2 (i586) VERSION = 12.2 CODENAME = Mantis
Machine:   System: Compaq Presario 06 product: DA236A-ABA 6420NX NA910 version: 0n41411RE101CROSS
           Mobo: MICRO-STAR model: MS-6390 version: 3.0 Bios: Phoenix version: 3.01 date: 12/10/2002
CPU:       Single core AMD Athlon XP 2200+ (-UP-) cache: 256 KB flags: (sse) clocked at 1798.630 MHz 
Graphics:  Card: Advanced Micro Devices [AMD] nee ATI RV280 [Radeon 9200] 
           X.Org: 1.12.3 drivers: ati,radeon (unloaded: fbdev,radeonhd,vesa) Resolution: 1280x1024@60.0hz 
           GLX Renderer: Mesa DRI R200 (RV280 5961) x86/MMX+/3DNow!+/SSE TCL DRI2 GLX Version: 1.3 Mesa 8.0.4
Audio:     Card: VIA VT8233/A/8235/8237 AC97 Audio Controller driver: snd_via82xx Sound: ALSA ver: 1.0.25
Network:   Card-1: VIA VT6102 [Rhine-II] driver: via-rhine 
           IF: eth0 state: down speed: 10 Mbps duplex: half mac: 00:10:dc:df:17:dd
           Card-2: Airgo Networks AGN100 802.11 a/b/g True MIMO Wireless Card 
           IF: N/A state: N/A mac: N/A
Drives:    HDD Total Size: 40.0GB (15.1% used) 1: /dev/sda WDC_WD400EB 40.0GB 
Partition: ID: / size: 15G used: 4.8G (36%) fs: rootfs ID: / size: 15G used: 4.8G (36%) fs: ext4 
           ID: /home size: 21G used: 918M (5%) fs: ext4 ID: swap-1 size: 1.78GB used: 0.11GB (6%) fs: swap 
Sensors:   Error: You do not have the sensors app installed.
Info:      Processes: 165 Uptime: 2 days  9:21 Memory: 667.1/1130.5MB Client: Shell inxi: 1.7.24